ruby-devel-2.2.8-1.mga6.x86_64.rpm


Advertisement

Description

ruby-devel - Development file for the powerful language Ruby

Property Value
Distribution Mageia 6.0
Repository Mageia Core Updates x86_64
Package name ruby-devel
Package version 2.2.8
Package release 1.mga6
Package architecture x86_64
Package type rpm
Installed size 20.66 MB
Download size 3.25 MB
Official Mirror distrib-coffee.ipsl.jussieu.fr
Ruby is the interpreted scripting language for quick and
easy object-oriented programming.  It has many features to
process text files and to do system management tasks (as in
Perl). It is simple, straight-forward, and extensible.
This package contains the Ruby's devel files.

Alternatives

Package Version Architecture Repository
ruby-devel-2.2.8-1.1.mga6.x86_64.rpm 2.2.8 x86_64 Mageia Core Updates
ruby-devel-2.2.8-1.1.mga6.i586.rpm 2.2.8 i586 Mageia Core Updates
ruby-devel-2.2.8-1.mga6.i586.rpm 2.2.8 i586 Mageia Core Updates
ruby-devel-2.2.7-1.mga6.i586.rpm 2.2.7 i586 Mageia Core Updates
ruby-devel-2.2.7-1.mga6.x86_64.rpm 2.2.7 x86_64 Mageia Core Updates
ruby-devel-2.2.5-15.mga6.i586.rpm 2.2.5 i586 Mageia Core
ruby-devel-2.2.5-15.mga6.x86_64.rpm 2.2.5 x86_64 Mageia Core
ruby-devel - - -

Requires

Name Value
devel(libcrypt(64bit)) -
devel(libdl(64bit)) -
devel(libm(64bit)) -
lib64ruby2.2 == 2.2.8
pkgconfig -
ruby == 2.2.8

Provides

Name Value
devel(libruby(64bit)) -
pkgconfig(ruby) == 2.2.8
ruby-devel == 2.2.8-1.mga6
ruby-devel(x86-64) == 2.2.8-1.mga6

Download

Type URL
Binary Package ruby-devel-2.2.8-1.mga6.x86_64.rpm
Source Package ruby-2.2.8-1.mga6.src.rpm

Install Howto

  1. Enable Mageia Core Updates repository on "Install and Remove Software"
  2. Update packages list:
    # urpmi.update -a
  3. Install ruby-devel rpm package:
    # urpmi ruby-devel

Files

Path
/usr/include/ruby.h
/usr/include/ruby/config.h
/usr/include/ruby/debug.h
/usr/include/ruby/defines.h
/usr/include/ruby/digest.h
/usr/include/ruby/encoding.h
/usr/include/ruby/intern.h
/usr/include/ruby/io.h
/usr/include/ruby/missing.h
/usr/include/ruby/oniguruma.h
/usr/include/ruby/re.h
/usr/include/ruby/regex.h
/usr/include/ruby/ruby.h
/usr/include/ruby/st.h
/usr/include/ruby/subst.h
/usr/include/ruby/thread.h
/usr/include/ruby/thread_native.h
/usr/include/ruby/util.h
/usr/include/ruby/version.h
/usr/include/ruby/vm.h
/usr/include/ruby/backward/classext.h
/usr/include/ruby/backward/rubyio.h
/usr/include/ruby/backward/rubysig.h
/usr/include/ruby/backward/st.h
/usr/include/ruby/backward/util.h
/usr/lib64/libruby-static.a
/usr/lib64/libruby.so
/usr/lib64/pkgconfig/ruby.pc

Changelog

See ruby-2.2.8-1.mga6.x86_64.rpm changelog.

See Also

Package Description
ruby-doc-2.2.7-1.mga6.noarch.rpm Documentation for the powerful language Ruby
ruby-doc-2.2.8-1.1.mga6.noarch.rpm Documentation for the powerful language Ruby
ruby-doc-2.2.8-1.mga6.noarch.rpm Documentation for the powerful language Ruby
ruby-io-console-0.4.3-1.1.mga6.x86_64.rpm IO/Console is a simple console utilizing library
ruby-io-console-0.4.3-1.mga6.x86_64.rpm IO/Console is a simple console utilizing library
ruby-irb-2.2.7-1.mga6.noarch.rpm The Interactive Ruby
ruby-irb-2.2.8-1.1.mga6.noarch.rpm The Interactive Ruby
ruby-irb-2.2.8-1.mga6.noarch.rpm The Interactive Ruby
ruby-json-1.8.3-3.1.mga6.x86_64.rpm JSON Implementation for Ruby
ruby-json-doc-1.8.3-3.1.mga6.noarch.rpm Documentation for ruby-json
ruby-power_assert-0.2.2-1.1.mga6.noarch.rpm Power Assert for Ruby
ruby-power_assert-0.2.2-1.mga6.noarch.rpm Power Assert for Ruby
ruby-rmagick-2.15.4-12.2.mga6.x86_64.rpm Ruby binding to ImageMagick
ruby-rmagick-doc-2.15.4-12.2.mga6.noarch.rpm Documentation for ruby-rmagick
ruby-rubyzip-1.1.7-1.1.mga6.noarch.rpm A ruby module for reading and writing zip files
Advertisement
Advertisement