cpp-ethereum-1.3.0-0.20160911.6.mga6.nonfree.i586.rpm


Advertisement

Description

cpp-ethereum - Ethereum C++ client

Distribution: Mageia 6.0
Repository: Mageia Nonfree i586
Package name: cpp-ethereum
Package version: 1.3.0
Package release: 0.20160911.6.mga6.nonfree
Package architecture: i586
Package type: rpm
Installed size: 1.83 MB
Download size: 444.19 KB
Official Mirror: distrib-coffee.ipsl.jussieu.fr
It is the third most popular of the Ethereum clients, behind geth (the go client) and Parity (the rust client). The code is exceptionally portable and has been used successfully on a very broad range of operating systems and hardware. We are in the process of re-licensing the codebase from the copyleft GPLv3 license to the permissive Apache 2.0 licence, to enable Ethereum to be used as broadly as possible. There is a long-form article - "Ethereum Everywhere" - which talks about the rationale for the change and the history leading up to this proposed change of licensing.

Alternatives

Provides

  • cpp-ethereum == 1.3.0-0.20160911.6.mga6.nonfree
  • cpp-ethereum(x86-32) == 1.3.0-0.20160911.6.mga6.nonfree

    Install Howto

    1. Enable Mageia Nonfree repository on "Install and Remove Software"
    2. Update packages list:
      # urpmi.update -a
    3. Install cpp-ethereum rpm package:
      # urpmi cpp-ethereum

    Files

    • /usr/bin/bench
    • /usr/bin/eth
    • /usr/bin/ethkey
    • /usr/bin/ethminer
    • /usr/bin/ethvm
    • /usr/bin/rlp
    • /usr/share/doc/cpp-ethereum/LICENSE
    • /usr/share/doc/cpp-ethereum/README.md

    Changelog

    2017-05-16 - neoclust <neoclust> 1.3.0-0.20160911.6.mga6 + Revision: 1102005 - Rebuild against new miniupnpc

    2017-01-07 - daviddavid <daviddavid> 1.3.0-0.20160911.5.mga6.nonfree + Revision: 1080516 - rebuild for llvm 3.9.1

    2017-01-02 - akien <akien> 1.3.0-0.20160911.4.mga6.nonfree + Revision: 1079576 - Rebuild for libjsoncpp changed soname

    2016-09-12 - dlucio <dlucio> 1.3.0-0.20160911.3.mga6.nonfree + Revision: 1051588 - identifies 64 bits instead others - it will require devel subpackages until I figure out a patch

    2016-09-12 - dlucio <dlucio> 1.3.0-0.20160911.2.mga6.nonfree + Revision: 1051582 - amd64 and x86_64 - dont fix evm when we dont need it - no cpuid - libevemjit is only available in x86_64, only requires when x86_64 then - evmjit only for x86_64 -jit support - libevmjit subpackages

    2016-09-10 - daviddavid <daviddavid> 1.3.0-0.20160902.2.mga6.nonfree + Revision: 1051371 - rebuild for missing rpms + dlucio <dlucio> - fglrx optional until it is finished

    2016-09-03 - dlucio <dlucio> 1.3.0-0.20160902.mga6.nonfree + Revision: 1049864 - only rename when different than 32 bits - no x11-driver-video-fglrx as BR - imported package cpp-ethereum

    Advertisement
    Advertisement