okular-devel-19.04.0-1.mga7.i586.rpm


Advertisement

Description

okular-devel - Devel stuff for kdegraphics

Property Value
Distribution Mageia 7
Repository Mageia Core i586
Package filename okular-devel-19.04.0-1.mga7.i586.rpm
Package name okular-devel
Package version 19.04.0
Package release 1.mga7
Package architecture i586
Package type rpm
Category Development/KDE and Qt
Homepage http://www.kde.org/applications/graphics/okular/
License GPLv2
Maintainer -
Download size 58.45 KB
Installed size 273.06 KB
This package contains header files needed if you wish to build applications
based on okular.

Alternatives

Package Version Architecture Repository
okular-devel-19.04.0-1.mga7.x86_64.rpm 19.04.0 x86_64 Mageia Core
okular-devel - - -

Requires

Name Value
chmlib-devel -
devel(libKF5Archive) -
devel(libKF5Bookmarks) -
devel(libKF5ConfigCore) -
devel(libKF5ConfigGui) -
devel(libKF5ConfigWidgets) -
devel(libKF5CoreAddons) -
devel(libKF5I18n) -
devel(libKF5JSApi) -
devel(libKF5KIOCore) -
devel(libKF5KIOWidgets) -
devel(libKF5Service) -
devel(libKF5ThreadWeaver) -
devel(libKF5Wallet) -
devel(libKF5WidgetsAddons) -
devel(libQt5Core) -
devel(libQt5Gui) -
devel(libQt5Network) -
devel(libQt5PrintSupport) -
devel(libQt5Widgets) -
devel(libQt5Xml) -
devel(libgcc_s) -
devel(libm) -
devel(libphonon4qt5) -
devel(libstdc++) -
devel(libz) -
ebook-tools-devel -
libokularcore9 = 19.04.0-1.mga7
pkgconfig(ddjvuapi) -
pkgconfig(libspectre) -
pkgconfig(poppler-qt5) -

Provides

Name Value
cmake(Okular5) = 1.7.0
devel(libOkular5Core) -
okular-devel = 19.04.0-1.mga7
okular-devel(x86-32) = 19.04.0-1.mga7

Download

Type URL
Mirror distrib-coffee.ipsl.jussieu.fr
Binary Package okular-devel-19.04.0-1.mga7.i586.rpm
Source Package okular-19.04.0-1.mga7.src.rpm

Install Howto

  1. Enable the repository in Software Management
  2. Install okular-devel rpm package:
    # dnf install okular-devel

Files

Path
/usr/include/okular/
/usr/include/okular/core/action.h
/usr/include/okular/core/annotations.h
/usr/include/okular/core/area.h
/usr/include/okular/core/document.h
/usr/include/okular/core/fileprinter.h
/usr/include/okular/core/fontinfo.h
/usr/include/okular/core/form.h
/usr/include/okular/core/generator.h
/usr/include/okular/core/global.h
/usr/include/okular/core/observer.h
/usr/include/okular/core/okularcore_export.h
/usr/include/okular/core/page.h
/usr/include/okular/core/pagesize.h
/usr/include/okular/core/pagetransition.h
/usr/include/okular/core/settings_core.h
/usr/include/okular/core/signatureutils.h
/usr/include/okular/core/sound.h
/usr/include/okular/core/sourcereference.h
/usr/include/okular/core/textdocumentgenerator.h
/usr/include/okular/core/textdocumentsettings.h
/usr/include/okular/core/textpage.h
/usr/include/okular/core/tile.h
/usr/include/okular/core/utils.h
/usr/include/okular/core/version.h
/usr/include/okular/interfaces/configinterface.h
/usr/include/okular/interfaces/guiinterface.h
/usr/include/okular/interfaces/printinterface.h
/usr/include/okular/interfaces/saveinterface.h
/usr/include/okular/interfaces/viewerinterface.h
/usr/lib/libOkular5Core.so
/usr/lib/cmake/Okular5/Okular5Config.cmake
/usr/lib/cmake/Okular5/Okular5ConfigVersion.cmake
/usr/lib/cmake/Okular5/Okular5Targets-relwithdebinfo.cmake
/usr/lib/cmake/Okular5/Okular5Targets.cmake

Changelog

2019-04-15 - neoclust <neoclust> 2:19.04.0-1.mga7
+ Revision: 1390535
- New version 19.04.0
- New version 19.04.00
2019-04-09 - neoclust <neoclust> 2:19.03.90-1.mga7
+ Revision: 1387753
- New version 19.03.90
2019-03-31 - umeabot <umeabot> 2:18.12.3-2.mga7
+ Revision: 1383605
- Qt5 Rebuild
2019-03-13 - neoclust <neoclust> 2:18.12.3-1.mga7
+ Revision: 1375764
- New version 18.12.3
2019-02-12 - neoclust <neoclust> 2:18.12.2-1.mga7
+ Revision: 1365658
- New version 18.12.2
2019-01-14 - neoclust <neoclust> 2:18.12.1-1.mga7
+ Revision: 1356595
- New version 18.12.1
2018-12-10 - neoclust <neoclust> 2:18.12.0-1.mga7
+ Revision: 1339600
- New version 18.12.0
2018-11-26 - daviddavid <daviddavid> 2:18.08.3-2.mga7
+ Revision: 1335226
- enable Discount support
2018-11-21 - neoclust <neoclust> 2:18.08.3-1.mga7
+ Revision: 1332830
- New version 18.08.3
- New version 18.08.2
2018-09-12 - daviddavid <daviddavid> 2:18.04.1-2.mga7
+ Revision: 1258612
- add upstream patch to fix CVE-2018-1000801 (mga#23562)

See Also

Package Description
okular-handbook-19.04.0-1.mga7.noarch.rpm Okular handbook
olive-0.0-1.git20190421.1.mga7.i586.rpm A non-linear video editor
omnitux-1.2.1-9.mga7.noarch.rpm Omnitux is an education platform for children
onboard-1.4.1-5.mga7.i586.rpm On-screen keyboard with spelling suggestions, auto-show and more
onestroke-0.8.4-10.mga7.i586.rpm Gesture recognition for tablet PC's
ongres-scram-1.0.0~beta.2-1.mga7.noarch.rpm Salted Challenge Response Authentication Mechanism (SCRAM) - Java Implementation
ongres-scram-client-1.0.0~beta.2-1.mga7.noarch.rpm Client for ongres-scram
ongres-scram-javadoc-1.0.0~beta.2-1.mga7.noarch.rpm Javadoc for ongres-scram
ongres-scram-parent-1.0.0~beta.2-1.mga7.noarch.rpm Parent POM of ongres-scram
opam-2.0.1-1.mga7.i586.rpm A source-based package manager for OCaml
opam-doc-2.0.1-1.mga7.i586.rpm Documentation files for opam
open-1.4-28.mga7.i586.rpm A tool which will start a program on a virtual console
open-adventure-1.0-3.mga7.i586.rpm Forward-port of Colossal Cave Adventure 2.5 from 1995
open-iscsi-2.0-872.18.mga7.i586.rpm An implementation of RFC3720 iSCSI
open-vm-tools-10.3.10-1.mga7.i586.rpm Open Virtual Machine Tools for virtual machines hosted on VMware
Advertisement
Advertisement