openssh-server-8.0p1-1.mga7.i586.rpm


Advertisement

Description

openssh-server - OpenSSH Secure Shell protocol server (sshd)

Property Value
Distribution Mageia 7
Repository Mageia Core i586
Package filename openssh-server-8.0p1-1.mga7.i586.rpm
Package name openssh-server
Package version 8.0p1
Package release 1.mga7
Package architecture i586
Package type rpm
Category System/Servers
Homepage http://www.openssh.com/
License BSD
Maintainer -
Download size 424.86 KB
Installed size 1.66 MB
Ssh (Secure Shell) is a program for logging into a remote machine and for
executing commands in a remote machine.  It is intended to replace
rlogin and rsh, and provide secure encrypted communications between
two untrusted hosts over an insecure network.  X11 connections and
arbitrary TCP/IP ports can also be forwarded over the secure channel.
OpenSSH is OpenBSD's rework of the last free version of SSH, bringing it
up to date in terms of security and features, as well as removing all
patented algorithms to separate libraries (OpenSSL).
This package contains the secure shell daemon. The sshd is the server
part of the secure shell protocol and allows ssh clients to connect to
your host.

Alternatives

Package Version Architecture Repository
openssh-server-8.0p1-1.mga7.x86_64.rpm 8.0p1 x86_64 Mageia Core
openssh-server - - -

Requires

Name Value
chkconfig >= 0.9
libc.so.6(GLIBC_2.28) -
libcom_err.so.2 -
libcrypt.so.1 -
libcrypt.so.1(XCRYPT_2.0) -
libcrypto.so.1.1 -
libcrypto.so.1.1(OPENSSL_1_1_0) -
libgssapi_krb5.so.2 -
libgssapi_krb5.so.2(gssapi_krb5_2_MIT) -
libkrb5.so.3 -
libkrb5.so.3(krb5_3_MIT) -
libpam.so.0 -
libpam.so.0(LIBPAM_1.0) -
libsystemd.so.0 -
libsystemd.so.0(LIBSYSTEMD_209) -
libutil.so.1 -
libutil.so.1(GLIBC_2.0) -
libz.so.1 -
makedev -
openssh = 8.0p1-1.mga7
openssh-clients = 8.0p1-1.mga7
openssl >= 0.9.7
pam >= 0.74
rpm-helper >= 0.24.8-1

Provides

Name Value
config(openssh-server) = 8.0p1-1.mga7
openssh-server = 8.0p1-1.mga7
openssh-server(x86-32) = 8.0p1-1.mga7
ssh-server -
sshd -

Download

Type URL
Mirror distrib-coffee.ipsl.jussieu.fr
Binary Package openssh-server-8.0p1-1.mga7.i586.rpm
Source Package openssh-8.0p1-1.mga7.src.rpm

Install Howto

  1. Enable the repository in Software Management
  2. Install openssh-server rpm package:
    # dnf install openssh-server

Files

Path
/etc/avahi/services/openssh.service
/etc/pam.d/sshd
/etc/ssh/denyusers
/etc/ssh/moduli
/etc/ssh/sshd_config
/etc/sysconfig/sshd
/etc/xinetd.d/sshd-xinetd
/usr/lib/.build-id/
/usr/lib/.build-id/0a/1aefb8b18569ef5ebf681eda2557e9832ba5e6
/usr/lib/.build-id/36/a5e20325ae9a77725773dcd47e0840efcf59ac
/usr/lib/systemd/system/sshd-keygen.service
/usr/lib/systemd/system/sshd.service
/usr/lib/systemd/system/sshd.socket
/usr/lib/systemd/system/sshd@.service
/usr/libexec/openssh/sftp-server
/usr/sbin/sshd
/usr/sbin/sshd-keygen
/usr/share/man/man5/moduli.5.xz
/usr/share/man/man5/sshd_config.5.xz
/usr/share/man/man8/sftp-server.8.xz
/usr/share/man/man8/sshd.8.xz
/var/empty/

Changelog

2019-04-29 - guillomovitch <guillomovitch> 8.0p1-1.mga7
+ Revision: 1395920
- new version 8.0p1
2019-03-12 - wally <wally> 7.9p1-3.mga7
+ Revision: 1374875
- own /usr/libexec/openssh/ with openssh instead of openssh-server
2019-02-03 - luigiwalser <luigiwalser> 7.9p1-2.mga7
+ Revision: 1362761
- resync patches with fedora as of 2019-01-14 including fix for CVE-2018-20685
2018-10-26 - guillomovitch <guillomovitch> 7.9p1-1.mga7
+ Revision: 1325830
- new version 7.9p1
sync patches with Fedora
2018-08-25 - guillomovitch <guillomovitch> 7.8p1-1.mga7
+ Revision: 1254324
- new version 7.8p1
- sync patch set with fedora
- enable vendor patch level in server banner
2018-08-16 - guillomovitch <guillomovitch> 7.7p1-1.mga7
+ Revision: 1252048
- new version 7.7p1
- fix user enumeration issue (#2452)
2017-12-20 - wally <wally> 7.6p1-2.mga7
+ Revision: 1183593
- sync openssh-7.0p1-show-more-fingerprints.patch with fedora
2017-12-19 - guillomovitch <guillomovitch> 7.6p1-1.mga7
+ Revision: 1183501
- new version 7.6p1
- sync patch set with fedora
2017-08-02 - guillomovitch <guillomovitch> 7.5p1-3.mga7
+ Revision: 1133963
- rebuild for latest openssl
- support for system-wide crypto policies

See Also

Package Description
openssl-1.1.0j-1.mga7.i586.rpm Secure Sockets Layer communications libs & utils
openssl-perl-1.1.0j-1.mga7.i586.rpm Perl scripts provided with OpenSSL
openstereo-0.1.4-7.mga7.noarch.rpm Software for structural geology analysis
opensubdiv-doc-3.3.3-6.mga7.noarch.rpm High performance subdivision surface libraries
opensvp-0.4-11.mga7.noarch.rpm Firewall hole pincher
openteacher-3.2-8.mga7.i586.rpm Vocabulary training application
opentest4j-1.0.0-1.mga7.noarch.rpm Open Test Alliance for the JVM
opentest4j-javadoc-1.0.0-1.mga7.noarch.rpm Javadoc for opentest4j
opentracker-0.cvs20100808-5.mga7.i586.rpm An open and free bittorrent tracker
openttd-1.9.1-1.mga7.i586.rpm An open source clone of the Microprose game "Transport Tycoon Deluxe" game
openttd-opengfx-0.5.5-1.mga7.noarch.rpm OpenGFX graphics replacement set for OpenTTD
openttd-openmsx-0.3.1-9.mga7.noarch.rpm OpenMSX music replacement set for OpenTTD
openttd-opensfx-0.2.3-10.mga7.noarch.rpm OpenSFX sound replacement set for OpenTTD
openvas-cli-1.4.5-2.mga7.i586.rpm Command-line tool to drive OpenVAS Manager
openvas-gsa-7.0.3-1.mga7.i586.rpm Greenbone Security Assistant (GSA) is GUI to the OpenVAS
Advertisement
Advertisement