perl-Test-Pod-LinkCheck-0.8.0-4.mga7.noarch.rpm


Advertisement

Description

perl-Test-Pod-LinkCheck - Tests POD for invalid links

Property Value
Distribution Mageia 7
Repository Mageia Core i586
Package filename perl-Test-Pod-LinkCheck-0.8.0-4.mga7.noarch.rpm
Package name perl-Test-Pod-LinkCheck
Package version 0.8.0
Package release 4.mga7
Package architecture noarch
Package type rpm
Category Development/Perl
Homepage http://search.cpan.org/dist/Test-Pod-LinkCheck
License GPL+ or Artistic
Maintainer -
Download size 37.37 KB
Installed size 115.16 KB
This module looks for any links in your POD and verifies that they point to
a valid resource. It uses the the Pod::Simple manpage parser to analyze the
pod files and look at their links. In a nutshell, it looks for 'L<Foo>'
links and makes sure that Foo exists. It also recognizes section links,
'L</SYNOPSIS>' for example. Also, manpages are resolved and checked.
This module does *NOT* check "http" links like 'L<http://www.google.com>'
in your pod. For that, please check out the Test::Pod::No404s manpage.
Normally, you wouldn't want this test to be run during end-user
installation because they might not have the modules installed! It is
HIGHLY recommended that this be used only for module authors'
RELEASE_TESTING phase. To do that, just modify the synopsis to add an env
check :)

Alternatives

Package Version Architecture Repository
perl-Test-Pod-LinkCheck-0.8.0-4.mga7.noarch.rpm 0.8.0 noarch Mageia Core
perl-Test-Pod-LinkCheck - - -

Requires

Name Value
perl(App::PodLinkCheck::ParseLinks) >= 4.0.0
perl(App::PodLinkCheck::ParseSections) -
perl(Capture::Tiny) -
perl(Exporter) -
perl(File::Spec) -
perl(Moose) >= 1.10.0
perl(Moose::Util::TypeConstraints) >= 1.10.0
perl(Pod::Find) -
perl(Test::Builder) >= 0.940.0
perl(Test::Pod) >= 1.440.0
perl(parent) -
perl(strict) -
perl(warnings) -
perl-base >= 5.28.0

Provides

Name Value
perl(Test::Pod::LinkCheck) = 0.8.0
perl-Test-Pod-LinkCheck = 0.8.0-4.mga7

Download

Type URL
Mirror distrib-coffee.ipsl.jussieu.fr
Binary Package perl-Test-Pod-LinkCheck-0.8.0-4.mga7.noarch.rpm
Source Package perl-Test-Pod-LinkCheck-0.8.0-4.mga7.src.rpm

Install Howto

  1. Enable the repository in Software Management
  2. Install perl-Test-Pod-LinkCheck rpm package:
    # dnf install perl-Test-Pod-LinkCheck

Files

Path
/usr/share/doc/perl-Test-Pod-LinkCheck/Changes
/usr/share/doc/perl-Test-Pod-LinkCheck/INSTALL
/usr/share/doc/perl-Test-Pod-LinkCheck/LICENSE
/usr/share/doc/perl-Test-Pod-LinkCheck/META.json
/usr/share/doc/perl-Test-Pod-LinkCheck/META.yml
/usr/share/doc/perl-Test-Pod-LinkCheck/README
/usr/share/doc/perl-Test-Pod-LinkCheck/SIGNATURE
/usr/share/doc/perl-Test-Pod-LinkCheck/examples/linkcheck.t
/usr/share/man/man3/Test::Pod::LinkCheck.3pm.xz
/usr/share/perl5/vendor_perl/Test/
/usr/share/perl5/vendor_perl/Test/Pod/LinkCheck.pm

Changelog

2018-09-19 - umeabot <umeabot> 0.8.0-4.mga7
(not released yet)
+ Revision: 1271988
- Mageia 7 Mass Rebuild
2016-06-19 - pterjan <pterjan> 0.8.0-3.mga6
+ Revision: 1034525
- Rebuild for perl 5.22.2
2016-02-18 - umeabot <umeabot> 0.8.0-2.mga6
+ Revision: 967059
- Mageia 6 Mass Rebuild

See Also

Package Description
perl-Test-Pod-No404s-0.20.0-3.mga7.noarch.rpm Using this test module will check your POD for any http 404 links
perl-Test-Pod-Spelling-CommonMistakes-1.1.0-4.mga7.noarch.rpm Checks POD for common spelling mistakes
perl-Test-Portability-Files-0.100.0-1.mga7.noarch.rpm Check file names portability
perl-Test-Prereq-2.2.0-3.mga7.noarch.rpm Check if Makefile.PL has the right pre-requisites
perl-Test-Random-20130427.0.0-7.mga7.noarch.rpm Make testing random functions deterministic
perl-Test-Refcount-0.80.0-6.mga7.noarch.rpm Assert reference counts on objects
perl-Test-Regression-0.80.0-2.mga7.noarch.rpm Test library to generate and compare output
perl-Test-Reporter-1.620.0-4.mga7.noarch.rpm Sends test results to cpan-testers@perl.org
perl-Test-Reporter-Transport-Metabase-1.999.10-3.mga7.noarch.rpm Metabase transport for Test::Reporter
perl-Test-Requires-0.100.0-4.mga7.noarch.rpm Checks to see if the module can be loaded
perl-Test-Requires-Git-1.8.0-3.mga7.noarch.rpm Check your test requirements against the available version of Git
perl-Test-RequiresInternet-0.50.0-4.mga7.noarch.rpm Easily test network connectivity
perl-Test-Roo-1.4.0-6.mga7.noarch.rpm Test::Roo examples
perl-Test-Run-0.30.400-3.mga7.noarch.rpm Named sprintf according to the
perl-Test-Run-CmdLine-0.13.100-3.mga7.noarch.rpm Command line front-end for Test-Run
Advertisement
Advertisement