php-pimple-3.2.3-2.mga7.noarch.rpm


Advertisement

Description

php-pimple - A simple dependency injection container for PHP (extension)

Property Value
Distribution Mageia 7
Repository Mageia Core i586
Package filename php-pimple-3.2.3-2.mga7.noarch.rpm
Package name php-pimple
Package version 3.2.3
Package release 2.mga7
Package architecture noarch
Package type rpm
Category Development/PHP
Homepage http://pimple.sensiolabs.org
License MIT
Maintainer -
Download size 16.22 KB
Installed size 35.64 KB
A simple dependency injection container for PHP (extension).
Autoloader: /usr/share/php/Pimple/autoload.php

Alternatives

Package Version Architecture Repository
php-pimple-3.2.3-2.mga7.noarch.rpm 3.2.3 noarch Mageia Core
php-pimple - - -

Requires

Name Value
php >= 5.3.0
php-composer(fedora/autoloader) -
php-composer(psr/container) >= 1.0

Provides

Name Value
php-composer(pimple/pimple) = 3.2.3
php-pimple = 3.2.3-2.mga7

Obsoletes

Name Value
php-pimple-lib -

Download

Type URL
Mirror distrib-coffee.ipsl.jussieu.fr
Binary Package php-pimple-3.2.3-2.mga7.noarch.rpm
Source Package php-pimple-3.2.3-2.mga7.src.rpm

Install Howto

  1. Enable the repository in Software Management
  2. Install php-pimple rpm package:
    # dnf install php-pimple

Files

Path
/usr/share/doc/php-pimple/CHANGELOG
/usr/share/doc/php-pimple/LICENSE
/usr/share/doc/php-pimple/README.rst
/usr/share/doc/php-pimple/composer.json
/usr/share/php/Pimple/Container.php
/usr/share/php/Pimple/ServiceIterator.php
/usr/share/php/Pimple/ServiceProviderInterface.php
/usr/share/php/Pimple/autoload.php
/usr/share/php/Pimple/Exception/ExpectedInvokableException.php
/usr/share/php/Pimple/Exception/FrozenServiceException.php
/usr/share/php/Pimple/Exception/InvalidServiceIdentifierException.php
/usr/share/php/Pimple/Exception/UnknownIdentifierException.php
/usr/share/php/Pimple/Psr11/Container.php
/usr/share/php/Pimple/Psr11/ServiceLocator.php

Changelog

2018-09-20 - umeabot <umeabot> 3.2.3-2.mga7
(not released yet)
+ Revision: 1287868
- Mageia 7 Mass Rebuild
2018-02-27 - guillomovitch <guillomovitch> 3.2.3-1.mga7
+ Revision: 1205529
- new version 3.2.3
2017-12-24 - guillomovitch <guillomovitch> 3.2.2-2.mga7
+ Revision: 1184591
- drop extension
- switch autoloader to fedora/autoloader
- restore from obsoletes
+ mokraemer <mokraemer>
- drop php 5.3 package
2017-10-06 - guillomovitch <guillomovitch> 3.2.2-1.mga7
+ Revision: 1169332
- imported package php-pimple

See Also

Package Description
php-pinba-1.1.1-1.mga7.i586.rpm PHP extension for Pinba
php-posix-7.3.6-1.mga7.i586.rpm POSIX extension module for PHP
php-proctitle-0.1.2-15.mga7.i586.rpm Allows setting the current process name on Linux and BSD
php-propro-2.1.0-4.mga7.i586.rpm Property proxy
php-psr-cache-1.0.1-1.mga7.noarch.rpm Common interface for caching libraries
php-psr-container-1.0.0-3.mga7.noarch.rpm Common Container Interface
php-psr-http-message-1.0.1-3.mga7.noarch.rpm Common interface for HTTP messages (PSR-7)
php-psr-log-1.1.0-1.mga7.noarch.rpm Common interface for logging libraries
php-psr-simple-cache-1.0.1-1.mga7.noarch.rpm Common interfaces for simple caching (PSR-16)
php-qrcode-3.4.4-3.mga7.noarch.rpm Endroid QR Code Generator
php-radius-1.4.0b1-6.mga7.i586.rpm Radius client library for PHP
php-raphf-2.0.0-6.mga7.i586.rpm Resource and persistent handles factory
php-readline-7.3.6-1.mga7.i586.rpm Readline extension module for PHP
php-recode-7.3.6-1.mga7.i586.rpm Recode extension module for PHP
php-redis-4.3.0-1.mga7.i586.rpm The phpredis extension provides an API for communicating with the Redis key-value store
Advertisement
Advertisement