python2-lxml-4.3.0-1.mga7.i586.rpm


Advertisement

Description

python2-lxml - A Pythonic binding for the libxml2 and libxslt libraries

Property Value
Distribution Mageia 7
Repository Mageia Core i586
Package filename python2-lxml-4.3.0-1.mga7.i586.rpm
Package name python2-lxml
Package version 4.3.0
Package release 1.mga7
Package architecture i586
Package type rpm
Category Development/Python
Homepage http://codespeak.net/lxml/
License BSD
Maintainer -
Download size 1.05 MB
Installed size 4.46 MB
lxml is a Pythonic binding for the libxml2 and libxslt libraries. It follows
the ElementTree API as much as possible, building it on top of the native
libxml2 tree. It also extends this API to expose libxml2 and libxslt specific
functionality, such as XPath, Relax NG, XML Schema, XSLT, and c14n.

Alternatives

Package Version Architecture Repository
python2-lxml-4.3.0-1.mga7.x86_64.rpm 4.3.0 x86_64 Mageia Core
python2-lxml - - -

Requires

Name Value
libc.so.6(GLIBC_2.4) -
libexslt.so.0 -
libpthread.so.0 -
libpython2.7.so.1.0 -
libxml2.so.2 -
libxml2.so.2(LIBXML2_2.4.30) -
libxml2.so.2(LIBXML2_2.5.2) -
libxml2.so.2(LIBXML2_2.5.7) -
libxml2.so.2(LIBXML2_2.5.8) -
libxml2.so.2(LIBXML2_2.5.9) -
libxml2.so.2(LIBXML2_2.6.0) -
libxml2.so.2(LIBXML2_2.6.1) -
libxml2.so.2(LIBXML2_2.6.10) -
libxml2.so.2(LIBXML2_2.6.14) -
libxml2.so.2(LIBXML2_2.6.15) -
libxml2.so.2(LIBXML2_2.6.16) -
libxml2.so.2(LIBXML2_2.6.17) -
libxml2.so.2(LIBXML2_2.6.18) -
libxml2.so.2(LIBXML2_2.6.2) -
libxml2.so.2(LIBXML2_2.6.20) -
libxml2.so.2(LIBXML2_2.6.21) -
libxml2.so.2(LIBXML2_2.6.23) -
libxml2.so.2(LIBXML2_2.6.24) -
libxml2.so.2(LIBXML2_2.6.32) -
libxml2.so.2(LIBXML2_2.6.5) -
libxml2.so.2(LIBXML2_2.7.0) -
libxml2.so.2(LIBXML2_2.7.4) -
libxml2.so.2(LIBXML2_2.9.0) -
libxslt.so.1 -
libxslt.so.1(LIBXML2_1.0.11) -
libxslt.so.1(LIBXML2_1.0.18) -
libxslt.so.1(LIBXML2_1.0.22) -
libxslt.so.1(LIBXML2_1.0.24) -
libxslt.so.1(LIBXML2_1.1.2) -
libxslt.so.1(LIBXML2_1.1.26) -
libxslt.so.1(LIBXML2_1.1.9) -
python(abi) = 2.7

Provides

Name Value
python-lxml = 4.3.0-1.mga7
python-lxml(x86-32) = 4.3.0-1.mga7
python2-lxml = 4.3.0-1.mga7
python2-lxml(x86-32) = 4.3.0-1.mga7
python2.7dist(lxml) = 4.3.0
python2dist(lxml) = 4.3.0
pythonegg(2)(lxml) = 4.3.0

Obsoletes

Name Value
python-lxml < 3.8.0-2
python-lxml < 4.3.0-1.mga7

Download

Type URL
Mirror distrib-coffee.ipsl.jussieu.fr
Binary Package python2-lxml-4.3.0-1.mga7.i586.rpm
Source Package python-lxml-4.3.0-1.mga7.src.rpm

Install Howto

  1. Enable the repository in Software Management
  2. Install python2-lxml rpm package:
    # dnf install python2-lxml

Files

Path
/usr/lib/.build-id/
/usr/lib/.build-id/09/cae6f9cf4a672f5c310368af74253aa3e8b77b
/usr/lib/.build-id/1d/a3c8286421ff302e86e7f861711621564202a2
/usr/lib/.build-id/1e/b2ec4194fc1550570640f26e39da036d3457ea
/usr/lib/.build-id/79/9eece77cdcc7c0285ec1b31a63448d0985a66c
/usr/lib/.build-id/85/e4170de3ea34c7cfbfb405e5e0a1a118865360
/usr/lib/.build-id/91/26243e9bc3d9865b3995c3b413b9f7354b7aa4
/usr/lib/.build-id/c4/3efe85206029f3a947662c0a43679d5b1a2d03
/usr/lib/python2.7/site-packages/lxml/ElementInclude.py
/usr/lib/python2.7/site-packages/lxml/ElementInclude.pyc
/usr/lib/python2.7/site-packages/lxml/ElementInclude.pyo
/usr/lib/python2.7/site-packages/lxml/__init__.py
/usr/lib/python2.7/site-packages/lxml/__init__.pyc
/usr/lib/python2.7/site-packages/lxml/__init__.pyo
/usr/lib/python2.7/site-packages/lxml/_elementpath.py
/usr/lib/python2.7/site-packages/lxml/_elementpath.pyc
/usr/lib/python2.7/site-packages/lxml/_elementpath.pyo
/usr/lib/python2.7/site-packages/lxml/_elementpath.so
/usr/lib/python2.7/site-packages/lxml/builder.py
/usr/lib/python2.7/site-packages/lxml/builder.pyc
/usr/lib/python2.7/site-packages/lxml/builder.pyo
/usr/lib/python2.7/site-packages/lxml/builder.so
/usr/lib/python2.7/site-packages/lxml/cssselect.py
/usr/lib/python2.7/site-packages/lxml/cssselect.pyc
/usr/lib/python2.7/site-packages/lxml/cssselect.pyo
/usr/lib/python2.7/site-packages/lxml/doctestcompare.py
/usr/lib/python2.7/site-packages/lxml/doctestcompare.pyc
/usr/lib/python2.7/site-packages/lxml/doctestcompare.pyo
/usr/lib/python2.7/site-packages/lxml/etree.h
/usr/lib/python2.7/site-packages/lxml/etree.so
/usr/lib/python2.7/site-packages/lxml/etree_api.h
/usr/lib/python2.7/site-packages/lxml/lxml.etree.h
/usr/lib/python2.7/site-packages/lxml/lxml.etree_api.h
/usr/lib/python2.7/site-packages/lxml/objectify.so
/usr/lib/python2.7/site-packages/lxml/pyclasslookup.py
/usr/lib/python2.7/site-packages/lxml/pyclasslookup.pyc
/usr/lib/python2.7/site-packages/lxml/pyclasslookup.pyo
/usr/lib/python2.7/site-packages/lxml/sax.py
/usr/lib/python2.7/site-packages/lxml/sax.pyc
/usr/lib/python2.7/site-packages/lxml/sax.pyo
/usr/lib/python2.7/site-packages/lxml/sax.so
/usr/lib/python2.7/site-packages/lxml/usedoctest.py
/usr/lib/python2.7/site-packages/lxml/usedoctest.pyc
/usr/lib/python2.7/site-packages/lxml/usedoctest.pyo
/usr/lib/python2.7/site-packages/lxml-4.3.0-py2.7.egg-info/PKG-INFO
/usr/lib/python2.7/site-packages/lxml-4.3.0-py2.7.egg-info/SOURCES.txt
/usr/lib/python2.7/site-packages/lxml-4.3.0-py2.7.egg-info/dependency_links.txt
/usr/lib/python2.7/site-packages/lxml-4.3.0-py2.7.egg-info/not-zip-safe
/usr/lib/python2.7/site-packages/lxml-4.3.0-py2.7.egg-info/requires.txt
/usr/lib/python2.7/site-packages/lxml-4.3.0-py2.7.egg-info/top_level.txt
/usr/lib/python2.7/site-packages/lxml/html/ElementSoup.py
/usr/lib/python2.7/site-packages/lxml/html/ElementSoup.pyc
/usr/lib/python2.7/site-packages/lxml/html/ElementSoup.pyo
/usr/lib/python2.7/site-packages/lxml/html/__init__.py
/usr/lib/python2.7/site-packages/lxml/html/__init__.pyc
/usr/lib/python2.7/site-packages/lxml/html/__init__.pyo
/usr/lib/python2.7/site-packages/lxml/html/_diffcommand.py
/usr/lib/python2.7/site-packages/lxml/html/_diffcommand.pyc
/usr/lib/python2.7/site-packages/lxml/html/_diffcommand.pyo
/usr/lib/python2.7/site-packages/lxml/html/_html5builder.py
/usr/lib/python2.7/site-packages/lxml/html/_html5builder.pyc
/usr/lib/python2.7/site-packages/lxml/html/_html5builder.pyo
/usr/lib/python2.7/site-packages/lxml/html/_setmixin.py
/usr/lib/python2.7/site-packages/lxml/html/_setmixin.pyc
/usr/lib/python2.7/site-packages/lxml/html/_setmixin.pyo
/usr/lib/python2.7/site-packages/lxml/html/builder.py
/usr/lib/python2.7/site-packages/lxml/html/builder.pyc
/usr/lib/python2.7/site-packages/lxml/html/builder.pyo
/usr/lib/python2.7/site-packages/lxml/html/clean.py
/usr/lib/python2.7/site-packages/lxml/html/clean.pyc
/usr/lib/python2.7/site-packages/lxml/html/clean.pyo
/usr/lib/python2.7/site-packages/lxml/html/clean.so
/usr/lib/python2.7/site-packages/lxml/html/defs.py
/usr/lib/python2.7/site-packages/lxml/html/defs.pyc
/usr/lib/python2.7/site-packages/lxml/html/defs.pyo
/usr/lib/python2.7/site-packages/lxml/html/diff.py
/usr/lib/python2.7/site-packages/lxml/html/diff.pyc
/usr/lib/python2.7/site-packages/lxml/html/diff.pyo
/usr/lib/python2.7/site-packages/lxml/html/diff.so
/usr/lib/python2.7/site-packages/lxml/html/formfill.py
/usr/lib/python2.7/site-packages/lxml/html/formfill.pyc
/usr/lib/python2.7/site-packages/lxml/html/formfill.pyo
/usr/lib/python2.7/site-packages/lxml/html/html5parser.py
/usr/lib/python2.7/site-packages/lxml/html/html5parser.pyc
/usr/lib/python2.7/site-packages/lxml/html/html5parser.pyo
/usr/lib/python2.7/site-packages/lxml/html/soupparser.py
/usr/lib/python2.7/site-packages/lxml/html/soupparser.pyc
/usr/lib/python2.7/site-packages/lxml/html/soupparser.pyo
/usr/lib/python2.7/site-packages/lxml/html/usedoctest.py
/usr/lib/python2.7/site-packages/lxml/html/usedoctest.pyc
/usr/lib/python2.7/site-packages/lxml/html/usedoctest.pyo
/usr/lib/python2.7/site-packages/lxml/includes/__init__.pxd
/usr/lib/python2.7/site-packages/lxml/includes/__init__.py
/usr/lib/python2.7/site-packages/lxml/includes/__init__.pyc
/usr/lib/python2.7/site-packages/lxml/includes/__init__.pyo
/usr/lib/python2.7/site-packages/lxml/includes/c14n.pxd
/usr/lib/python2.7/site-packages/lxml/includes/config.pxd
/usr/lib/python2.7/site-packages/lxml/includes/dtdvalid.pxd
/usr/lib/python2.7/site-packages/lxml/includes/etree_defs.h
/usr/lib/python2.7/site-packages/lxml/includes/etreepublic.pxd
/usr/lib/python2.7/site-packages/lxml/includes/htmlparser.pxd
/usr/lib/python2.7/site-packages/lxml/includes/lxml-version.h
/usr/lib/python2.7/site-packages/lxml/includes/relaxng.pxd
/usr/lib/python2.7/site-packages/lxml/includes/schematron.pxd
/usr/lib/python2.7/site-packages/lxml/includes/tree.pxd
/usr/lib/python2.7/site-packages/lxml/includes/uri.pxd
/usr/lib/python2.7/site-packages/lxml/includes/xinclude.pxd
/usr/lib/python2.7/site-packages/lxml/includes/xmlerror.pxd
/usr/lib/python2.7/site-packages/lxml/includes/xmlparser.pxd
/usr/lib/python2.7/site-packages/lxml/includes/xmlschema.pxd
/usr/lib/python2.7/site-packages/lxml/includes/xpath.pxd
/usr/lib/python2.7/site-packages/lxml/includes/xslt.pxd
/usr/lib/python2.7/site-packages/lxml/isoschematron/__init__.py
/usr/lib/python2.7/site-packages/lxml/isoschematron/__init__.pyc
/usr/lib/python2.7/site-packages/lxml/isoschematron/__init__.pyo
/usr/lib/python2.7/site-packages/lxml/isoschematron/resources/
/usr/lib/python2.7/site-packages/lxml/isoschematron/resources/rng/iso-schematron.rng
/usr/lib/python2.7/site-packages/lxml/isoschematron/resources/xsl/RNG2Schtrn.xsl
/usr/lib/python2.7/site-packages/lxml/isoschematron/resources/xsl/XSD2Schtrn.xsl
/usr/lib/python2.7/site-packages/lxml/isoschematron/resources/xsl/iso-schematron-xslt1/iso_abstract_expand.xsl
/usr/lib/python2.7/site-packages/lxml/isoschematron/resources/xsl/iso-schematron-xslt1/iso_dsdl_include.xsl
/usr/lib/python2.7/site-packages/lxml/isoschematron/resources/xsl/iso-schematron-xslt1/iso_schematron_message.xsl
/usr/lib/python2.7/site-packages/lxml/isoschematron/resources/xsl/iso-schematron-xslt1/iso_schematron_skeleton_for_xslt1.xsl
/usr/lib/python2.7/site-packages/lxml/isoschematron/resources/xsl/iso-schematron-xslt1/iso_svrl_for_xslt1.xsl
/usr/lib/python2.7/site-packages/lxml/isoschematron/resources/xsl/iso-schematron-xslt1/readme.txt
/usr/share/doc/python2-lxml/CHANGES.txt
/usr/share/doc/python2-lxml/CREDITS.txt
/usr/share/doc/python2-lxml/PKG-INFO
/usr/share/licenses/python2-lxml/LICENSES.txt

Changelog

2019-01-14 - luigiwalser <luigiwalser> 4.3.0-1.mga7
+ Revision: 1356244
- 4.3.0
2019-01-07 - tmb <tmb> 4.2.5-2.mga7
+ Revision: 1350264
- rebuild for python 3.7
2018-09-20 - kekepower <kekepower> 4.2.5-1.mga7
+ Revision: 1289399
- Update to version 4.2.5
2018-08-11 - kekepower <kekepower> 4.2.4-1.mga7
+ Revision: 1251000
- Update to version 4.2.4
2018-04-17 - kekepower <kekepower> 4.2.1-1.mga7
+ Revision: 1219717
- Update to version 4.2.1
- Use python_provide
2017-10-02 - daviddavid <daviddavid> 3.8.0-2.mga7
+ Revision: 1162483
- rebuild with fixed libxslt (1.1.30-2)
- rename python-lxml to python2-lxml
2017-09-15 - guillomovitch <guillomovitch> 3.8.0-1.mga7
+ Revision: 1153908
- new version 3.8.0
- don't build with cython, it is broken
- spec cleanup
2017-08-03 - philippem <philippem> 3.6.0-2.mga7
+ Revision: 1134407
- rebuild for Python 3.6

See Also

Package Description
python2-ly-0.9.5-6.mga7.noarch.rpm Tool and library for manipulating LilyPond files
python2-lzma-0.5.3-11.mga7.i586.rpm Python bindings for the LZMA compression library
python2-m2crypto-0.26.4-5.mga7.i586.rpm Crypto and SSL toolkit for Python 2
python2-m2r-0.2.1-2.mga7.noarch.rpm Markdown to reStructuredText converter
python2-magic-5.36-1.mga7.noarch.rpm Python module to use libmagic
python2-mako-1.0.9-1.mga7.noarch.rpm Mako template library for Python 3
python2-markdown-3.1-1.mga7.noarch.rpm Python 2 implementation of the markdown text-to-HTML conversion tool
python2-marshmallow-2.2.1-0.8.gitea1def9.mga7.noarch.rpm Python 2 library for converting complex datatypes to and from primitive types
python2-marshmallow-doc-2.2.1-0.8.gitea1def9.mga7.noarch.rpm Documentation for python2-marshmallow
python2-matplotlib-2.2.2-4.mga7.i586.rpm Python 2D plotting library
python2-matplotlib-doc-2.2.2-4.mga7.noarch.rpm Documentation files for python-matplotlib
python2-matplotlib-gtk-2.2.2-4.mga7.i586.rpm GTK backend for python-matplotlib
python2-matplotlib-gtk3-2.2.2-4.mga7.i586.rpm GTK3 backend for python-matplotlib
python2-matplotlib-qt4-2.2.2-4.mga7.i586.rpm Qt4 backend for python-matplotlib
python2-matplotlib-qt5-2.2.2-4.mga7.i586.rpm Qt5 backend for python-matplotlib
Advertisement
Advertisement