python2-soupsieve-1.9.1-2.mga7.noarch.rpm


Advertisement

Description

python2-soupsieve - A modern CSS selector implementation for Beautiful Soup

Property Value
Distribution Mageia 7
Repository Mageia Core i586
Package filename python2-soupsieve-1.9.1-2.mga7.noarch.rpm
Package name python2-soupsieve
Package version 1.9.1
Package release 2.mga7
Package architecture noarch
Package type rpm
Category Development/Python
Homepage https://github.com/facelessuser/soupsieve
License MIT
Maintainer -
Download size 63.63 KB
Installed size 241.56 KB
Soup Sieve is a CSS selector library designed to be used with Beautiful Soup 4.
It aims to provide selecting, matching, and filtering using modern CSS
selectors. Soup Sieve currently provides selectors from the CSS level 1
specifications up through the latest CSS level 4 drafts and beyond (though
some are not yet implemented).
Soup Sieve was written with the intent to replace Beautiful Soup's builtin
select feature, and as of Beautiful Soup version 4.7.0, it now is good.
Soup Sieve can also be imported in order to use its API directly for more
controlled, specialized parsing.
Soup Sieve has implemented most of the CSS selectors up through the latest CSS
draft specifications, though there are a number that don't make sense in a
non-browser environment. Selectors that cannot provide meaningful functionality
simply do not match anything.

Alternatives

Package Version Architecture Repository
python2-soupsieve-1.9.1-2.mga7.noarch.rpm 1.9.1 noarch Mageia Core
python2-soupsieve - - -

Requires

Name Value
python(abi) = 2.7
python2dist(backports.functools-lru-cache) -

Provides

Name Value
python-soupsieve = 1.9.1-2.mga7
python2-soupsieve = 1.9.1-2.mga7
python2.7dist(soupsieve) = 1.9.1
python2dist(soupsieve) = 1.9.1
pythonegg(2)(soupsieve) = 1.9.1

Obsoletes

Name Value
python-soupsieve < 1.9.1-2.mga7

Download

Type URL
Mirror distrib-coffee.ipsl.jussieu.fr
Binary Package python2-soupsieve-1.9.1-2.mga7.noarch.rpm
Source Package python-soupsieve-1.9.1-2.mga7.src.rpm

Install Howto

  1. Enable the repository in Software Management
  2. Install python2-soupsieve rpm package:
    # dnf install python2-soupsieve

Files

Path
/usr/lib/python2.7/site-packages/soupsieve/__init__.py
/usr/lib/python2.7/site-packages/soupsieve/__init__.pyc
/usr/lib/python2.7/site-packages/soupsieve/__init__.pyo
/usr/lib/python2.7/site-packages/soupsieve/__meta__.py
/usr/lib/python2.7/site-packages/soupsieve/__meta__.pyc
/usr/lib/python2.7/site-packages/soupsieve/__meta__.pyo
/usr/lib/python2.7/site-packages/soupsieve/css_match.py
/usr/lib/python2.7/site-packages/soupsieve/css_match.pyc
/usr/lib/python2.7/site-packages/soupsieve/css_match.pyo
/usr/lib/python2.7/site-packages/soupsieve/css_parser.py
/usr/lib/python2.7/site-packages/soupsieve/css_parser.pyc
/usr/lib/python2.7/site-packages/soupsieve/css_parser.pyo
/usr/lib/python2.7/site-packages/soupsieve/css_types.py
/usr/lib/python2.7/site-packages/soupsieve/css_types.pyc
/usr/lib/python2.7/site-packages/soupsieve/css_types.pyo
/usr/lib/python2.7/site-packages/soupsieve/util.py
/usr/lib/python2.7/site-packages/soupsieve/util.pyc
/usr/lib/python2.7/site-packages/soupsieve/util.pyo
/usr/lib/python2.7/site-packages/soupsieve-1.9.1-py2.7.egg-info/PKG-INFO
/usr/lib/python2.7/site-packages/soupsieve-1.9.1-py2.7.egg-info/SOURCES.txt
/usr/lib/python2.7/site-packages/soupsieve-1.9.1-py2.7.egg-info/dependency_links.txt
/usr/lib/python2.7/site-packages/soupsieve-1.9.1-py2.7.egg-info/requires.txt
/usr/lib/python2.7/site-packages/soupsieve-1.9.1-py2.7.egg-info/top_level.txt
/usr/share/doc/python2-soupsieve/README.md
/usr/share/licenses/python2-soupsieve/LICENSE.md
/usr/share/licenses/python2-soupsieve/license.md

Changelog

2019-05-28 - kekepower <kekepower> 1.9.1-2.mga7
+ Revision: 1399334
- Remove dependency for python3-backports.functools-lru-cache
2019-05-15 - kekepower <kekepower> 1.9.1-1.mga7
+ Revision: 1397808
- imported package python-soupsieve

See Also

Package Description
python2-speedtest-cli-2.1.1-1.mga7.noarch.rpm Small command-line program to view Network Connexion speed
python2-sphinx-1.8.4-2.mga7.noarch.rpm Python 2 documentation generator
python2-sphinx-autobuild-0.7.1-3.mga7.noarch.rpm Watch a Sphinx directory, rebuild documentation when change is detected
python2-sphinx-epytext-0.0.4-1.mga7.noarch.rpm Sphinx "epytext" extension
python2-sphinx-gallery-0.3.1-1.mga7.noarch.rpm Sphinx extension to automatically generate an examples gallery
python2-sphinx-prompt-1.1.0-1.mga7.noarch.rpm Sphinx directive to add unselectable prompt
python2-sphinx_celery-1.4.0-3.mga7.noarch.rpm Sphinx Celery Theme
python2-sphinx_rtd_theme-0.4.3-1.mga7.noarch.rpm Sphinx theme for readthedocs.org
python2-sphinxbase-0.9-0.0.5prealpha.4.mga7.i586.rpm Python 2 extension for The CMU Sphinx Recognition System
python2-sphinxcontrib-inkscapeconverter-0.1.0-1.mga7.noarch.rpm Sphinx SVG to PDF Converter Extension using Inkscape
python2-sphinxcontrib-rsvgconverter-0.1.0-1.mga7.noarch.rpm Sphinx SVG to PDF Converter Extension using libRSVG
python2-sphinxcontrib-spelling-4.2.1-1.mga7.noarch.rpm Sphinx spelling extension
python2-sphinxcontrib-svg2pdfconverter-0.1.0-1.mga7.noarch.rpm Sphinx SVG to PDF Converter Extension
python2-sphinxcontrib-websupport-1.1.0-1.mga7.noarch.rpm Sphinx API for Web Apps
python2-sphinxtesters-0.2.1-1.mga7.noarch.rpm Utilities for testing Sphinx extensions
Advertisement
Advertisement