python3-flake8-import-order-0.18-3.mga7.noarch.rpm


Advertisement

Description

python3-flake8-import-order - Flake8 and pylama plugin that checks the ordering of import statements

Property Value
Distribution Mageia 7
Repository Mageia Core i586
Package filename python3-flake8-import-order-0.18-3.mga7.noarch.rpm
Package name python3-flake8-import-order
Package version 0.18
Package release 3.mga7
Package architecture noarch
Package type rpm
Category Development/Python
Homepage https://github.com/PyCQA/flake8-import-order
License LGPLv3
Maintainer -
Download size 30.18 KB
Installed size 67.64 KB
A flake8 and Pylama plugin that checks the ordering of your imports. It does
not check anything else about the imports. Merely that they are grouped and
ordered correctly.
In general stdlib comes first, then 3rd party, then local packages, and that
each group is individually alphabetized, however this depends on the style
used. Flake8-Import-Order supports a number of styles and is extensible
allowing for custom styles.
This plugin was originally developed to match the style preferences of the
cryptography project, with this style remaining the default.

Alternatives

Package Version Architecture Repository
python3-flake8-import-order-0.18-3.mga7.noarch.rpm 0.18 noarch Mageia Core
python3-flake8-import-order - - -

Requires

Name Value
python(abi) = 3.7
python3.7dist(pycodestyle) -
python3.7dist(setuptools) -
python3dist(pycodestyle) -
python3dist(setuptools) -

Provides

Name Value
python3-flake8-import-order = 0.18-3.mga7
python3.7dist(flake8-import-order) = 0.18
python3dist(flake8-import-order) = 0.18
pythonegg(3)(flake8-import-order) = 0.18

Download

Type URL
Mirror distrib-coffee.ipsl.jussieu.fr
Binary Package python3-flake8-import-order-0.18-3.mga7.noarch.rpm
Source Package python-flake8-import-order-0.18-3.mga7.src.rpm

Install Howto

  1. Enable the repository in Software Management
  2. Install python3-flake8-import-order rpm package:
    # dnf install python3-flake8-import-order

Files

Path
/usr/lib/python3.7/site-packages/flake8_import_order/__about__.py
/usr/lib/python3.7/site-packages/flake8_import_order/__init__.py
/usr/lib/python3.7/site-packages/flake8_import_order/checker.py
/usr/lib/python3.7/site-packages/flake8_import_order/flake8_linter.py
/usr/lib/python3.7/site-packages/flake8_import_order/pylama_linter.py
/usr/lib/python3.7/site-packages/flake8_import_order/stdlib_list.py
/usr/lib/python3.7/site-packages/flake8_import_order/styles.py
/usr/lib/python3.7/site-packages/flake8_import_order-0.18-py3.7.egg-info/PKG-INFO
/usr/lib/python3.7/site-packages/flake8_import_order-0.18-py3.7.egg-info/SOURCES.txt
/usr/lib/python3.7/site-packages/flake8_import_order-0.18-py3.7.egg-info/dependency_links.txt
/usr/lib/python3.7/site-packages/flake8_import_order-0.18-py3.7.egg-info/entry_points.txt
/usr/lib/python3.7/site-packages/flake8_import_order-0.18-py3.7.egg-info/not-zip-safe
/usr/lib/python3.7/site-packages/flake8_import_order-0.18-py3.7.egg-info/requires.txt
/usr/lib/python3.7/site-packages/flake8_import_order-0.18-py3.7.egg-info/top_level.txt
/usr/lib/python3.7/site-packages/flake8_import_order/__pycache__/__about__.cpython-37.opt-1.pyc
/usr/lib/python3.7/site-packages/flake8_import_order/__pycache__/__about__.cpython-37.pyc
/usr/lib/python3.7/site-packages/flake8_import_order/__pycache__/__init__.cpython-37.opt-1.pyc
/usr/lib/python3.7/site-packages/flake8_import_order/__pycache__/__init__.cpython-37.pyc
/usr/lib/python3.7/site-packages/flake8_import_order/__pycache__/checker.cpython-37.opt-1.pyc
/usr/lib/python3.7/site-packages/flake8_import_order/__pycache__/checker.cpython-37.pyc
/usr/lib/python3.7/site-packages/flake8_import_order/__pycache__/flake8_linter.cpython-37.opt-1.pyc
/usr/lib/python3.7/site-packages/flake8_import_order/__pycache__/flake8_linter.cpython-37.pyc
/usr/lib/python3.7/site-packages/flake8_import_order/__pycache__/pylama_linter.cpython-37.opt-1.pyc
/usr/lib/python3.7/site-packages/flake8_import_order/__pycache__/pylama_linter.cpython-37.pyc
/usr/lib/python3.7/site-packages/flake8_import_order/__pycache__/stdlib_list.cpython-37.opt-1.pyc
/usr/lib/python3.7/site-packages/flake8_import_order/__pycache__/stdlib_list.cpython-37.pyc
/usr/lib/python3.7/site-packages/flake8_import_order/__pycache__/styles.cpython-37.opt-1.pyc
/usr/lib/python3.7/site-packages/flake8_import_order/__pycache__/styles.cpython-37.pyc
/usr/share/doc/python3-flake8-import-order/README.rst

Changelog

2019-01-05 - wally <wally> 0.18-3.mga7
+ Revision: 1349779
- rebuild for python3.7
2018-11-01 - kekepower <kekepower> 0.18-2.mga7
+ Revision: 1327536
- Requires removed because python3-enum34 doesn't exist
2018-11-01 - kekepower <kekepower> 0.18-1.mga7
+ Revision: 1327526
- imported package python-flake8-import-order

See Also

Package Description
python3-flake8-polyfill-1.0.2-3.mga7.noarch.rpm Polyfill package for Flake8 plugins
python3-flask-1.0.2-1.mga7.noarch.rpm A microframework based on Werkzeug, Jinja2 and good intentions
python3-flask-babel-0.11.2-1.mga7.noarch.rpm Adds i18n/l10n support to Flask applications
python3-flask-multistatic-1.0-8.mga7.noarch.rpm A simple flask plugin to allow overriding static files
python3-flask-sphinx-themes-1.0.2-3.mga7.noarch.rpm Sphinx themes for Flask and related projects
python3-flask-sqlalchemy-2.3.2-1.mga7.noarch.rpm Adds SQLAlchemy support to Flask application
python3-flask-wtf-0.14.2-1.mga7.noarch.rpm Simple integration of Flask and WTForms
python3-flexmock-0.10.4-1.mga7.noarch.rpm Mock/Stub/Spy library for Python
python3-flit-1.3-1.mga7.noarch.rpm Simplified packaging of Python modules
python3-fontmake-1.8.0-1.mga7.noarch.rpm Compile fonts from sources (UFO, Glyphs) to binary (OpenType, TrueType)
python3-fontmath-0.4.9-2.mga7.noarch.rpm A set of objects for performing math operations on font data
python3-fontparts-0.8.2-2.mga7.noarch.rpm An API for interacting with the parts of fonts during the font development process
python3-fontpens-0.2.4-1.mga7.noarch.rpm A collection of classes implementing the pen protocol for manipulating glyphs
python3-fonttools-3.38.0-1.mga7.noarch.rpm Python 3 fonttools library
python3-forensic1394-0.2-16.mga7.i586.rpm Python 3 bindings for libforensic1394
Advertisement
Advertisement