python3-soupsieve-1.9.1-2.mga7.noarch.rpm


Advertisement

Description

python3-soupsieve - A modern CSS selector implementation for Beautiful Soup

Property Value
Distribution Mageia 7
Repository Mageia Core i586
Package filename python3-soupsieve-1.9.1-2.mga7.noarch.rpm
Package name python3-soupsieve
Package version 1.9.1
Package release 2.mga7
Package architecture noarch
Package type rpm
Category Development/Python
Homepage https://github.com/facelessuser/soupsieve
License MIT
Maintainer -
Download size 63.73 KB
Installed size 220.48 KB
Soup Sieve is a CSS selector library designed to be used with Beautiful Soup 4.
It aims to provide selecting, matching, and filtering using modern CSS
selectors. Soup Sieve currently provides selectors from the CSS level 1
specifications up through the latest CSS level 4 drafts and beyond (though
some are not yet implemented).
Soup Sieve was written with the intent to replace Beautiful Soup's builtin
select feature, and as of Beautiful Soup version 4.7.0, it now is good.
Soup Sieve can also be imported in order to use its API directly for more
controlled, specialized parsing.
Soup Sieve has implemented most of the CSS selectors up through the latest CSS
draft specifications, though there are a number that don't make sense in a
non-browser environment. Selectors that cannot provide meaningful functionality
simply do not match anything.

Alternatives

Package Version Architecture Repository
python3-soupsieve-1.9.1-2.mga7.noarch.rpm 1.9.1 noarch Mageia Core
python3-soupsieve - - -

Requires

Name Value
python(abi) = 3.7

Provides

Name Value
python3-soupsieve = 1.9.1-2.mga7
python3.7dist(soupsieve) = 1.9.1
python3dist(soupsieve) = 1.9.1
pythonegg(3)(soupsieve) = 1.9.1

Download

Type URL
Mirror distrib-coffee.ipsl.jussieu.fr
Binary Package python3-soupsieve-1.9.1-2.mga7.noarch.rpm
Source Package python-soupsieve-1.9.1-2.mga7.src.rpm

Install Howto

  1. Enable the repository in Software Management
  2. Install python3-soupsieve rpm package:
    # dnf install python3-soupsieve

Files

Path
/usr/lib/python3.7/site-packages/soupsieve/__init__.py
/usr/lib/python3.7/site-packages/soupsieve/__meta__.py
/usr/lib/python3.7/site-packages/soupsieve/css_match.py
/usr/lib/python3.7/site-packages/soupsieve/css_parser.py
/usr/lib/python3.7/site-packages/soupsieve/css_types.py
/usr/lib/python3.7/site-packages/soupsieve/util.py
/usr/lib/python3.7/site-packages/soupsieve-1.9.1-py3.7.egg-info/PKG-INFO
/usr/lib/python3.7/site-packages/soupsieve-1.9.1-py3.7.egg-info/SOURCES.txt
/usr/lib/python3.7/site-packages/soupsieve-1.9.1-py3.7.egg-info/dependency_links.txt
/usr/lib/python3.7/site-packages/soupsieve-1.9.1-py3.7.egg-info/requires.txt
/usr/lib/python3.7/site-packages/soupsieve-1.9.1-py3.7.egg-info/top_level.txt
/usr/lib/python3.7/site-packages/soupsieve/__pycache__/__init__.cpython-37.opt-1.pyc
/usr/lib/python3.7/site-packages/soupsieve/__pycache__/__init__.cpython-37.pyc
/usr/lib/python3.7/site-packages/soupsieve/__pycache__/__meta__.cpython-37.opt-1.pyc
/usr/lib/python3.7/site-packages/soupsieve/__pycache__/__meta__.cpython-37.pyc
/usr/lib/python3.7/site-packages/soupsieve/__pycache__/css_match.cpython-37.opt-1.pyc
/usr/lib/python3.7/site-packages/soupsieve/__pycache__/css_match.cpython-37.pyc
/usr/lib/python3.7/site-packages/soupsieve/__pycache__/css_parser.cpython-37.opt-1.pyc
/usr/lib/python3.7/site-packages/soupsieve/__pycache__/css_parser.cpython-37.pyc
/usr/lib/python3.7/site-packages/soupsieve/__pycache__/css_types.cpython-37.opt-1.pyc
/usr/lib/python3.7/site-packages/soupsieve/__pycache__/css_types.cpython-37.pyc
/usr/lib/python3.7/site-packages/soupsieve/__pycache__/util.cpython-37.opt-1.pyc
/usr/lib/python3.7/site-packages/soupsieve/__pycache__/util.cpython-37.pyc
/usr/share/doc/python3-soupsieve/README.md
/usr/share/licenses/python3-soupsieve/LICENSE.md
/usr/share/licenses/python3-soupsieve/license.md

Changelog

2019-05-28 - kekepower <kekepower> 1.9.1-2.mga7
+ Revision: 1399334
- Remove dependency for python3-backports.functools-lru-cache
2019-05-15 - kekepower <kekepower> 1.9.1-1.mga7
+ Revision: 1397808
- imported package python-soupsieve

See Also

Package Description
python3-sparqlwrapper-1.8.2-1.mga7.noarch.rpm SPARQL Endpoint interface to Python 3
python3-speaklater-1.3-10.mga7.noarch.rpm Implements a lazy string for python3 useful for gettext
python3-speechd-0.9.0-2.mga7.i586.rpm A Python library for communication with Speech Dispatcher
python3-speedtest-cli-2.1.1-1.mga7.noarch.rpm Small command-line program to view Network Connexion speed
python3-sphinx-1.8.4-2.mga7.noarch.rpm Python 3 documentation generator
python3-sphinx-autobuild-0.7.1-3.mga7.noarch.rpm Watch a Sphinx directory, rebuild documentation when change is detected
python3-sphinx-epytext-0.0.4-1.mga7.noarch.rpm Sphinx "epytext" extension
python3-sphinx-gallery-0.3.1-1.mga7.noarch.rpm Sphinx extension to automatically generate an examples gallery
python3-sphinx-prompt-1.1.0-1.mga7.noarch.rpm Sphinx directive to add unselectable prompt
python3-sphinx-theme-alabaster-0.7.12-1.mga7.noarch.rpm Configurable sidebar-enabled Sphinx theme
python3-sphinx_celery-1.4.0-3.mga7.noarch.rpm Sphinx Celery Theme
python3-sphinx_rtd_theme-0.4.3-1.mga7.noarch.rpm Sphinx theme for readthedocs.org
python3-sphinxcontrib-httpdomain-1.7.0-1.mga7.noarch.rpm Sphinx domain for HTTP APIs
python3-sphinxcontrib-inkscapeconverter-0.1.0-1.mga7.noarch.rpm Sphinx SVG to PDF Converter Extension using Inkscape
python3-sphinxcontrib-log-cabinet-1.0.0-1.mga7.noarch.rpm Organize changelog directives in Sphinx docs
Advertisement
Advertisement