libbpf-devel-5.1.20-2.mga7.i586.rpm


Advertisement

Description

libbpf-devel - Developement files for the bpf library from kernel source

Property Value
Distribution Mageia 7
Repository Mageia Core Updates i586
Package filename libbpf-devel-5.1.20-2.mga7.i586.rpm
Package name libbpf-devel
Package version 5.1.20
Package release 2.mga7
Package architecture i586
Package type rpm
Category Development/Kernel
Homepage https://www.kernel.org/
License GPLv2
Maintainer -
Download size 153.82 KB
Installed size 316.93 KB
This package includes libraries and header files needed for development
of applications which use bpf library from kernel source.

Alternatives

Package Version Architecture Repository
libbpf-devel-5.3.6-1.mga7.i586.rpm 5.3.6 i586 Mageia Core Updates Testing
libbpf-devel-5.3.2-1.mga7.i586.rpm 5.3.2 i586 Mageia Core Updates
libbpf-devel-5.2.16-2.mga7.i586.rpm 5.2.16 i586 Mageia Core Updates
libbpf-devel-5.2.13-2.mga7.i586.rpm 5.2.13 i586 Mageia Core Updates
libbpf-devel-5.2.10-1.mga7.i586.rpm 5.2.10 i586 Mageia Core Updates
libbpf-devel-5.2.7-1.mga7.i586.rpm 5.2.7 i586 Mageia Core Updates
libbpf-devel-5.1.18-1.mga7.i586.rpm 5.1.18 i586 Mageia Core Updates
libbpf-devel-5.1.14-1.mga7.i586.rpm 5.1.14 i586 Mageia Core
libbpf-devel - - -

Requires

Name Value
devel(libelf) -

Provides

Name Value
devel(libbpf) -
libbpf-devel = 5.1.20-2.mga7
libbpf-devel(x86-32) = 5.1.20-2.mga7

Download

Type URL
Mirror distrib-coffee.ipsl.jussieu.fr
Binary Package libbpf-devel-5.1.20-2.mga7.i586.rpm
Source Package kernel-5.1.20-2.mga7.src.rpm

Install Howto

  1. Enable the repository in Software Management
  2. Install libbpf-devel rpm package:
    # dnf install libbpf-devel

Files

Path
/usr/include/bpf/bpf.h
/usr/include/bpf/btf.h
/usr/include/bpf/libbpf.h
/usr/include/bpf/xsk.h
/usr/lib/libbpf.a
/usr/lib/libbpf.so

Changelog

2019-07-27 - tmb <tmb> 5.1.20-2.mga7
+ Revision: 1424457
- add current -stable queue
- update to 5.1.20
* drop merged patches
- enable Full dynticks system (tickless) (NO_HZ_FULL)
- add current -stable -net queue
- update to 5.1.19
- add current -stable queue
- iwlwifi: dont send GEO_TX_POWER_LIMIT on version less than 41 (mga#25143)
- x86/amd_nb: Add PCI device IDs for family 17h, model 70h
- hwmon: (k10temp) Add support for AMD family 17h, model 70h CPUs
- update to 5.1.18
* drop merged patches
- update to 5.1.17
- disable CONFIG_VALIDATE_FS_PARSER
- add current -stable queue
- iwlwifi: mvm: disable TX-AMSDU on older NICs
- update to 5.1.16
- add current -stable queue
- update WireGuard to 0.0.20190702
2019-06-22 - tmb <tmb> 5.1.14-1.mga7
+ Revision: 1400488
- update to 5.1.14
* drop merged patches
2019-06-17 - tmb <tmb> 5.1.11-1.mga7
+ Revision: 1400174
- update to 5.1.11
2019-06-16 - tmb <tmb> 5.1.10-3.mga7
+ Revision: 1400130
- add more -stable queue fixes
2019-06-15 - tmb <tmb> 5.1.10-2.mga7
+ Revision: 1400023
- add current -stable queue
- drm/i915: Fix per-pixel alpha with CCS
- io_uring: fix memory leak of UNIX domain socket inode
- libata: Extend quirks for the ST1000LM024 drives with NOLPM quirk
- bcache: fix stack corruption by PRECEDING_KEY()
- bcache: only set BCACHE_DEV_WB_RUNNING when cached device attached
- rtw88: 8822b: add RFE type 3 support
2019-06-15 - tmb <tmb> 5.1.10-1.mga7
+ Revision: 1399991
- update conflicts on btrfs-progs
- update efibootmgr conflicts
- update conflicts on grub2
- update conflicts on mageia-gfxboot-theme
- update firmware conflicts / deps
- r8169: use netif_start_queue instead of netif_wake_qeueue in
rtl8169_start_xmit
- r8169: disable tx interrupt coalescing on RTL8168
- r8169: change irq handler to always trigger NAPI polling
- r8169: remove manual autoneg restart workaround
- hid: input: make sure the wheel high resolution multiplier is set
- hid: input: fix assignment of .value
- re-add: drm/nouveau: add kconfig option to turn off nouveau legacy contexts
- drm/nouveau: Fix build with CONFIG_NOUVEAU_LEGACY_CTX_SUPPORT disabled
- update to 5.1.10
* drop merged/obsolete patches
2019-06-11 - tmb <tmb> 5.1.9-1.mga7
+ Revision: 1399804
- Revert 'drm: allow render capable master with DRM_AUTH ioctls'
- update to 5.1.9 final
2019-06-10 - tmb <tmb> 5.1.8-1.mga7
+ Revision: 1399757
- enable NOUVEAU_LEGACY_CTX_SUPPORT
- disable RTL8821CE on i586 for now
- update -devel filelist for rtl8821ce
- add current -stable queue
- add rtl8821ce support (mga#24605)
- update to 5.1.8
2019-06-06 - tmb <tmb> 5.1.7-2.mga7
+ Revision: 1399625
- fix CVE-2019-10126, CVE-2019-12378, CVE-2019-12379, CVE-2019-12380,
CVE-2019-12381, CVE-2019-12382, CVE-2019-12454, CVE-2019-12455,
CVE-2019-12456, CVE-2019-3846
- Revert "x86/build: Move _etext to actual end of .text"
- x86/kprobes: Set instruction page as executable
2019-06-04 - tmb <tmb> 5.1.7-1.mga7
+ Revision: 1399550
- add current -stable queue
- update to 5.1.7
- memcg: make it work on sparse non-0-node systems
-  scsi: smartpqi: properly set both the DMA mask and the coherent DMA mask
- usb: xhci: avoid null pointer deref when bos field is NULL
- xhci: Convert xhci_handshake() to use readl_poll_timeout_atomic()
- x86/CPU/AMD: Don't force the CPB cap when running under a hypervisor
- add -stable queue patchlist generator

See Also

Package Description
libbpf0-5.1.18-1.mga7.i586.rpm The bpf library from kernel source
libbpf0-5.1.20-2.mga7.i586.rpm The bpf library from kernel source
libbpf0-5.2.10-1.mga7.i586.rpm The bpf library from kernel source
libbpf0-5.2.13-2.mga7.i586.rpm The bpf library from kernel source
libbpf0-5.2.16-2.mga7.i586.rpm The bpf library from kernel source
libbpf0-5.2.7-1.mga7.i586.rpm The bpf library from kernel source
libbpf0-5.3.2-1.mga7.i586.rpm The bpf library from kernel source
libbtrfs-devel-5.2.1-1.mga7.i586.rpm Headers for developing programs that will use btrfs
libbtrfs-devel-5.2.2-1.mga7.i586.rpm Headers for developing programs that will use btrfs
libbtrfs0-5.2.1-1.mga7.i586.rpm Main library for btrfs
libbtrfs0-5.2.2-1.mga7.i586.rpm Main library for btrfs
libbtrfsutil1-5.2.1-1.mga7.i586.rpm Util library for btrfs
libbtrfsutil1-5.2.2-1.mga7.i586.rpm Util library for btrfs
libcap-ng-devel-0.7.9-3.1.mga7.i586.rpm Header files, libraries and development documentation for libcap-ng
libcap-ng-utils-0.7.9-3.1.mga7.i586.rpm Utilities for analysing and setting file capabilities
Advertisement
Advertisement