php-cli-7.3.8-1.mga7.i586.rpm


Advertisement

Description

php-cli - PHP CLI interface

Property Value
Distribution Mageia 7
Repository Mageia Core Updates i586
Package filename php-cli-7.3.8-1.mga7.i586.rpm
Package name php-cli
Package version 7.3.8
Package release 1.mga7
Package architecture i586
Package type rpm
Category Development/PHP
Homepage http://www.php.net/cli
License PHP License
Maintainer -
Download size 1.39 MB
Installed size 4.45 MB
PHP is an HTML-embeddable scripting language. PHP offers built-in database
integration for several commercial and non-commercial database management
systems, so writing a database-enabled script with PHP is fairly simple. The
most common use of PHP coding is probably as a replacement for CGI scripts.
This package contains a command-line (CLI) version of php. You must also
install libphp_common7. If you need apache module support, you also need to
install the apache-mod_php package.

Alternatives

Package Version Architecture Repository
php-cli-7.3.9-1.mga7.i586.rpm 7.3.9 i586 Mageia Core Updates
php-cli-7.3.9-1.mga7.x86_64.rpm 7.3.9 x86_64 Mageia Core Updates
php-cli-7.3.8-1.mga7.x86_64.rpm 7.3.8 x86_64 Mageia Core Updates
php-cli-7.3.6-1.mga7.x86_64.rpm 7.3.6 x86_64 Mageia Core
php-cli-7.3.6-1.mga7.i586.rpm 7.3.6 i586 Mageia Core
php-cli - - -

Requires

Name Value
libc.so.6(GLIBC_2.28) -
libdl.so.2 -
libdl.so.2(GLIBC_2.0) -
libdl.so.2(GLIBC_2.1) -
libm.so.6 -
libm.so.6(GLIBC_2.0) -
libm.so.6(GLIBC_2.1) -
libm.so.6(GLIBC_2.29) -
libpcre2-8.so.0 -
libphp_common7 >= 7.3.8
libresolv.so.2 -
libresolv.so.2(GLIBC_2.0) -
libresolv.so.2(GLIBC_2.2) -
librt.so.1 -
librt.so.1(GLIBC_2.2) -
libxml2.so.2 -
libxml2.so.2(LIBXML2_2.4.30) -
libxml2.so.2(LIBXML2_2.5.2) -
libxml2.so.2(LIBXML2_2.6.0) -
libxml2.so.2(LIBXML2_2.6.11) -
libxml2.so.2(LIBXML2_2.9.0) -
libz.so.1 -

Provides

Name Value
/usr/bin/php -
php = 7.3.8
php-cli = 7.3.8-1.mga7
php-cli(x86-32) = 7.3.8-1.mga7

Download

Type URL
Mirror distrib-coffee.ipsl.jussieu.fr
Binary Package php-cli-7.3.8-1.mga7.i586.rpm
Source Package php-7.3.8-1.mga7.src.rpm

Install Howto

  1. Enable the repository in Software Management
  2. Install php-cli rpm package:
    # dnf install php-cli

Files

Path
/usr/bin/php
/usr/lib/.build-id/
/usr/lib/.build-id/e2/643124d0e660cfc41ae7f668f829a8028d4026
/usr/share/doc/php-cli/CREDITS.cli
/usr/share/doc/php-cli/README.cli
/usr/share/man/man1/php.1.xz

Changelog

2019-08-01 - mokraemer <mokraemer> 3:7.3.8-1.mga7
+ Revision: 1426678
- new version 7.3.8
- new version 7.3.7
2019-05-31 - mokraemer <mokraemer> 3:7.3.6-1.mga7
+ Revision: 1399424
- new release 7.3.6
- Fix apache config files
2019-05-02 - mokraemer <mokraemer> 3:7.3.5-1.mga7
+ Revision: 1396205
- new release 7.3.5
2019-04-04 - mokraemer <mokraemer> 3:7.3.4-1.mga7
+ Revision: 1385810
- new version 7.3.4
2019-03-21 - mokraemer <mokraemer> 3:7.3.3-1.mga7
+ Revision: 1379481
- new version 7.3.3
2019-02-23 - wally <wally> 3:7.3.2-2.mga7
+ Revision: 1369602
- switch to enchant2 (patch from Arch)
2019-02-07 - mokraemer <mokraemer> 3:7.3.2-1.mga7
+ Revision: 1364015
- new version 7.3.2
2019-01-17 - mokraemer <mokraemer> 3:7.3.1-2.mga7
+ Revision: 1357576
- removed some obsolete packages
2019-01-10 - mokraemer <mokraemer> 3:7.3.1-1.mga7
+ Revision: 1354558
- new version 7.3.1
2018-12-29 - luigiwalser <luigiwalser> 3:7.3.0-5.mga7
+ Revision: 1346551
- rebuild for lm_sensors

See Also

Package Description
php-ctype-7.3.8-1.mga7.i586.rpm Ctype extension module for PHP
php-ctype-7.3.9-1.mga7.i586.rpm Ctype extension module for PHP
php-curl-7.3.8-1.mga7.i586.rpm Curl extension module for PHP
php-curl-7.3.9-1.mga7.i586.rpm Curl extension module for PHP
php-dba-7.3.8-1.mga7.i586.rpm DBA extension module for PHP
php-dba-7.3.9-1.mga7.i586.rpm DBA extension module for PHP
php-devel-7.3.8-1.mga7.i586.rpm Development package for PHP
php-devel-7.3.9-1.mga7.i586.rpm Development package for PHP
php-doc-7.3.8-1.mga7.noarch.rpm Documentation for PHP
php-doc-7.3.9-1.mga7.noarch.rpm Documentation for PHP
php-dom-7.3.8-1.mga7.i586.rpm Dom extension module for PHP
php-dom-7.3.9-1.mga7.i586.rpm Dom extension module for PHP
php-enchant-7.3.8-1.mga7.i586.rpm Libenchant binder, support near all spelling tools
php-enchant-7.3.9-1.mga7.i586.rpm Libenchant binder, support near all spelling tools
php-exif-7.3.8-1.mga7.i586.rpm EXIF extension module for PHP
Advertisement
Advertisement