lib64javascriptcoregtk4.0_18-2.26.3-1.mga7.x86_64.rpm


Advertisement

Description

lib64javascriptcoregtk4.0_18 - GTK port of WebKit web browser engine

Property Value
Distribution Mageia 7.1
Repository Mageia Core Updates x86_64
Package filename lib64javascriptcoregtk4.0_18-2.26.3-1.mga7.x86_64.rpm
Package name lib64javascriptcoregtk4.0_18
Package version 2.26.3
Package release 1.mga7
Package architecture x86_64
Package type rpm
Category System/Libraries
Homepage http://www.webkitgtk.org
License BSD and LGPLv2+
Maintainer -
Download size 4.90 MB
Installed size 19.97 MB
The GTK port of WebKit is intended to provide a browser component
primarily for users of the portable GTK UI toolkit on platforms like
Linux.

Alternatives

Package Version Architecture Repository
lib64javascriptcoregtk4.0_18-2.26.4-1.mga7.x86_64.rpm 2.26.4 x86_64 Mageia Core Updates Testing
lib64javascriptcoregtk4.0_18-2.26.2-1.1.mga7.x86_64.rpm 2.26.2 x86_64 Mageia Core Updates
lib64javascriptcoregtk4.0_18-2.26.2-1.mga7.x86_64.rpm 2.26.2 x86_64 Mageia Core Updates
lib64javascriptcoregtk4.0_18-2.24.4-1.mga7.x86_64.rpm 2.24.4 x86_64 Mageia Core Updates
lib64javascriptcoregtk4.0_18-2.24.2-2.mga7.x86_64.rpm 2.24.2 x86_64 Mageia Core
lib64javascriptcoregtk4.0_18 - - -

Requires

Name Value
ld-linux-x86-64.so.2()(64bit) -
ld-linux-x86-64.so.2(GLIBC_2.3)(64bit) -
libc.so.6(GLIBC_2.17)(64bit) -
libdl.so.2()(64bit) -
libdl.so.2(GLIBC_2.2.5)(64bit) -
libgcc_s.so.1()(64bit) -
libgcc_s.so.1(GCC_3.4)(64bit) -
libgio-2.0.so.0()(64bit) -
libglib-2.0.so.0()(64bit) -
libgobject-2.0.so.0()(64bit) -
libicui18n.so.63()(64bit) -
libicuuc.so.63()(64bit) -
libm.so.6()(64bit) -
libm.so.6(GLIBC_2.2.5)(64bit) -
libm.so.6(GLIBC_2.29)(64bit) -
libpthread.so.0()(64bit) -
libpthread.so.0(GLIBC_2.12)(64bit) -
libpthread.so.0(GLIBC_2.2.5)(64bit) -
libpthread.so.0(GLIBC_2.3.2)(64bit) -
libstdc++.so.6()(64bit) -
libstdc++.so.6(CXXABI_1.3)(64bit) -
libstdc++.so.6(CXXABI_1.3.9)(64bit) -
libstdc++.so.6(GLIBCXX_3.4)(64bit) -
libstdc++.so.6(GLIBCXX_3.4.11)(64bit) -
libstdc++.so.6(GLIBCXX_3.4.14)(64bit) -
libstdc++.so.6(GLIBCXX_3.4.15)(64bit) -
libstdc++.so.6(GLIBCXX_3.4.18)(64bit) -
libstdc++.so.6(GLIBCXX_3.4.19)(64bit) -
libstdc++.so.6(GLIBCXX_3.4.21)(64bit) -
libstdc++.so.6(GLIBCXX_3.4.22)(64bit) -

Provides

Name Value
lib64javascriptcoregtk4.0_18 = 2.26.3-1.mga7
lib64javascriptcoregtk4.0_18(x86-64) = 2.26.3-1.mga7
libjavascriptcoregtk-4.0.so.18()(64bit) -

Download

Type URL
Mirror distrib-coffee.ipsl.jussieu.fr
Binary Package lib64javascriptcoregtk4.0_18-2.26.3-1.mga7.x86_64.rpm
Source Package webkit2-2.26.3-1.mga7.src.rpm

Install Howto

  1. Enable the repository in Software Management
  2. Install lib64javascriptcoregtk4.0_18 rpm package:
    # dnf install lib64javascriptcoregtk4.0_18

Files

Path
/usr/lib/.build-id/
/usr/lib/.build-id/ec/c52528199f2597a99aad6a7212e008923990a4
/usr/lib64/libjavascriptcoregtk-4.0.so.18
/usr/lib64/libjavascriptcoregtk-4.0.so.18.14.8

Changelog

2020-01-23 - ns80 <ns80> 2.26.3-1.mga7
+ Revision: 1482353
- new version 2.26.3
+ wally <wally>
- fix webkit2-plugin-process-gtk2 obsoletes (mga#25699)
2019-11-06 - ns80 <ns80> 2.26.2-1.mga7
+ Revision: 1458368
- new version 2.26.2 (mga#25657)
2019-11-05 - ns80 <ns80> 2.26.1-1.mga7
+ Revision: 1458149
- new version 2.26.1 (mga#25657)
2019-08-29 - ns80 <ns80> 2.24.4-1.mga7
+ Revision: 1435021
- new version 2.24.4 (mga#25377)
2019-05-22 - ns80 <ns80> 2.24.2-2.mga7
+ Revision: 1398852
- add again patch revert-sse2-requirement
2019-05-21 - ns80 <ns80> 2.24.2-1.mga7
+ Revision: 1398749
- remove patch that reverted SSE2 requirement
+ luigiwalser <luigiwalser>
- 2.24.2
2019-04-10 - ns80 <ns80> 2.24.1-1.mga7
+ Revision: 1387875
- add patch revert-sse2-requirement to allow builing for i586
- new version 2.24.1 that contains bug and security fixes (CVE-2019-6251)
2019-03-29 - wally <wally> 2.24.0-3.mga7
+ Revision: 1381087
- split out WebKitPluginProcess2 to webkit2-plugin-process-gtk2 sub pkg to not not pull GTK2 stuff with main pkg (the whole WebKitPluginProcess2 could be dropped as only dying Flash seems to be using it)
- recommend webkit2-plugin-process-gtk2 with main pkg
- use RelWithDebInfo build type
2019-03-21 - luigiwalser <luigiwalser> 2.24.0-2.mga7
+ Revision: 1379476
- 2.24.0
- switch to python3 (with patch from fedora)
2019-03-20 - luigiwalser <luigiwalser> 2.22.7-1.mga7
+ Revision: 1379168
- 2.22.7

See Also

Package Description
lib64jpeg-devel-2.0.3-1.mga7.x86_64.rpm Development tools for programs which will use the libjpeg library
lib64jpeg-devel-2.0.4-1.mga7.x86_64.rpm Development tools for programs which will use the libjpeg library
lib64jpeg-static-devel-2.0.3-1.mga7.x86_64.rpm Static libraries for programs which will use the libjpeg library
lib64jpeg-static-devel-2.0.4-1.mga7.x86_64.rpm Static libraries for programs which will use the libjpeg library
lib64jpeg62-2.0.3-1.mga7.x86_64.rpm A MMX/SSE2 accelerated library for manipulating JPEG image files
lib64jpeg62-2.0.4-1.mga7.x86_64.rpm A MMX/SSE2 accelerated library for manipulating JPEG image files
lib64jpeg8-2.0.3-1.mga7.x86_64.rpm A MMX/SSE2 accelerated library for manipulating JPEG image files
lib64jpeg8-2.0.4-1.mga7.x86_64.rpm A MMX/SSE2 accelerated library for manipulating JPEG image files
lib64kaccounts-devel-19.04.0-1.1.mga7.x86_64.rpm Devel stuff for kaccounts-integration
lib64kaccounts-devel-19.04.0-1.2.mga7.x86_64.rpm Devel stuff for kaccounts-integration
lib64kaccounts1-19.04.0-1.1.mga7.x86_64.rpm Small system to administer web accounts across the KDE desktop
lib64kaccounts1-19.04.0-1.2.mga7.x86_64.rpm Small system to administer web accounts across the KDE desktop
lib64kcmkwincommon5-5.15.4-1.1.mga7.x86_64.rpm Plasma 5 Window Manager
lib64kcmutils4-4.14.38-7.1.mga7.x86_64.rpm Utility classes for KCModule
lib64kconfig-devel-5.57.0-1.1.mga7.x86_64.rpm Devel stuff for kconfig
Advertisement
Advertisement