apache-mod_auth_kerb-5.4-7.mga6.i586.rpm


Advertisement

Description

apache-mod_auth_kerb - Apache module to provides authentifation against a Kerberos server

Property Value
Distribution Mageia Cauldron
Repository Mageia Core i586
Package name apache-mod_auth_kerb
Package version 5.4
Package release 7.mga6
Package architecture i586
Package type rpm
Installed size 63.24 KB
Download size 31.99 KB
Official Mirror distrib-coffee.ipsl.jussieu.fr
Mod_auth_kerb is an apache module designed to provide Kerberos
user authentication to the Apache web server. Using the Basic
Auth mechanism, it retrieves a username/password pair from the
browser and checks them against a Kerberos server as set up by
your particular organization. It also supports mutual ticket
authentication, but most browsers do not support that natively.
I might look into writing a netscape plugin for it at some point.
Some browsers also require being told that they are to use Basic
Auth as opposed to seeing KerberosV* and handling that as basic
auth. The module accounts for this and 'tricks' the browser into
thinking it's normal basic auth.
If you are using the Basic Auth mechanmism, the module does not
do any special encryption of any sort. The passing of the
username and password is done with the same Base64 encoding that
Basic Auth uses. This can easily be converted to plain text. To
counter this, I would suggest also using mod_ssl.

Alternatives

Package Version Architecture Repository
apache-mod_auth_kerb-5.4-7.mga6.x86_64.rpm 5.4 x86_64 Mageia Core
apache-mod_auth_kerb - - -

Requires

Name Value
apache -
config(apache-mod_auth_kerb) == 5.4-7.mga6
libc.so.6 -
libc.so.6(GLIBC_2.0) -
libc.so.6(GLIBC_2.1.3) -
libc.so.6(GLIBC_2.3.4) -
libc.so.6(GLIBC_2.4) -
libc.so.6(GLIBC_2.8) -
libcom_err.so.2 -
libgssapi_krb5.so.2 -
libgssapi_krb5.so.2(gssapi_krb5_2_MIT) -
libkrb5.so.3 -
libkrb5.so.3(krb5_3_MIT) -

Provides

Name Value
apache-mod_auth_kerb == 5.4-7.mga6
apache-mod_auth_kerb(x86-32) == 5.4-7.mga6
config(apache-mod_auth_kerb) == 5.4-7.mga6

Download

Type URL
Binary Package apache-mod_auth_kerb-5.4-7.mga6.i586.rpm
Source Package apache-mod_auth_kerb-5.4-7.mga6.src.rpm

Install Howto

  1. Enable Mageia Core repository on "Install and Remove Software"
  2. Update packages list:
    # urpmi.update -a
  3. Install apache-mod_auth_kerb rpm package:
    # urpmi apache-mod_auth_kerb

Files

Path
/etc/httpd/conf/modules.d/10_mod_auth_kerb.conf
/usr/lib/httpd/modules/mod_auth_kerb.so
/usr/share/doc/apache-mod_auth_kerb/INSTALL
/usr/share/doc/apache-mod_auth_kerb/LICENSE
/usr/share/doc/apache-mod_auth_kerb/README
/usr/share/doc/apache-mod_auth_kerb/example.conf

Changelog

2016-02-04 - umeabot <umeabot> 5.4-7.mga6
+ Revision: 935749
- Mageia 6 Mass Rebuild
2014-10-15 - umeabot <umeabot> 5.4-6.mga5
+ Revision: 741288
- Second Mageia 5 Mass Rebuild
2014-09-16 - umeabot <umeabot> 5.4-5.mga5
+ Revision: 677834
- Mageia 5 Mass Rebuild
2013-10-19 - umeabot <umeabot> 5.4-4.mga4
+ Revision: 523546
- Mageia 4 Mass Rebuild
2013-05-23 - guillomovitch <guillomovitch> 5.4-3.mga4
+ Revision: 424815
- fix typo in configuration file (#10225)

See Also

Package Description
apache-mod_auth_openidc-2.3.2-1.mga7.i586.rpm OpenID Connect Relying Party and OAuth 2.0 Resource Server for Apache HTTP Server 2.x
apache-mod_auth_pam-1.1.1-4.mga6.i586.rpm Pam authorisation for Apache
apache-mod_authnz_external-3.3.2-1.mga6.i586.rpm An apache authentication DSO using external programs
apache-mod_autoindex_mb-2.18.1-6.mga6.i586.rpm Apache module generating directory indexes for MirrorBrain
apache-mod_brotli-2.4.33-1.mga7.i586.rpm Google Brotli compression for apache
apache-mod_bw-0.92-6.mga6.i586.rpm Bandwidth administration module for Apache HTTPD
apache-mod_cache-2.4.33-1.mga7.i586.rpm Content cache keyed to URIs
apache-mod_dav-2.4.33-1.mga7.i586.rpm Distributed Authoring and Versioning (WebDAV)
apache-mod_dav_svn-1.10.0-1.mga7.i586.rpm Subversion server DSO module for apache
apache-mod_dbd-2.4.33-1.mga7.i586.rpm Manages SQL database connections
apache-mod_fcgid-2.3.9-6.mga6.i586.rpm Apache module for FastCGI
apache-mod_form-0.1-5.mga6.i586.rpm mod_form is an Apache module to decode data submitted from Web forms
apache-mod_geoip-1.2.10-1.mga6.i586.rpm GeoIP module for the Apache HTTP Server
apache-mod_http2-2.4.33-1.mga7.i586.rpm This module provides HTTP/2 (RFC 7540) support
apache-mod_jk-1.2.42-1.mga7.i586.rpm Tomcat mod_jk connector for Apache
Advertisement
Advertisement