libboost_graph1.72.0-1.72.0-1.mga8.i586.rpm


Advertisement

Description

libboost_graph1.72.0 - Boost graph shared library

Property Value
Distribution Mageia Cauldron
Repository Mageia Core i586
Package filename libboost_graph1.72.0-1.72.0-1.mga8.i586.rpm
Package name libboost_graph1.72.0
Package version 1.72.0
Package release 1.mga8
Package architecture i586
Package type rpm
Category System/Libraries
Homepage http://www.boost.org
License Boost and MIT and Python
Maintainer -
Download size 192.88 KB
Installed size 563.92 KB
Boost is a collection of free peer-reviewed portable C++ source
libraries. The emphasis is on libraries which work well with the C++
Standard Library. This package contains the shared library needed for
running programs dynamically linked against Boost graph.

Alternatives

Package Version Architecture Repository
libboost_graph1.72.0 - - -

Requires

Name Value
libboost_mpi.so.1.72.0 -
libboost_regex.so.1.72.0 -
libboost_serialization.so.1.72.0 -
libc.so.6 -
libc.so.6(GLIBC_2.0) -
libc.so.6(GLIBC_2.1.3) -
libc.so.6(GLIBC_2.3.4) -
libc.so.6(GLIBC_2.4) -
libgcc_s.so.1 -
libgcc_s.so.1(GCC_3.0) -
libmpi.so.40 -
libmpi_cxx.so.40 -
libstdc++.so.6 -
libstdc++.so.6(CXXABI_1.3) -
libstdc++.so.6(CXXABI_1.3.8) -
libstdc++.so.6(CXXABI_1.3.9) -
libstdc++.so.6(GLIBCXX_3.4) -
libstdc++.so.6(GLIBCXX_3.4.11) -
libstdc++.so.6(GLIBCXX_3.4.15) -
libstdc++.so.6(GLIBCXX_3.4.21) -
libstdc++.so.6(GLIBCXX_3.4.26) -
libstdc++.so.6(GLIBCXX_3.4.9) -

Provides

Name Value
boost == 1.72.0-1.mga8
libboost_graph.so.1.72.0 -
libboost_graph1.72.0 == 1.72.0-1.mga8
libboost_graph1.72.0(x86-32) == 1.72.0-1.mga8
libboost_graph_parallel.so.1.72.0 -

Download

Type URL
Mirror distrib-coffee.ipsl.jussieu.fr
Binary Package libboost_graph1.72.0-1.72.0-1.mga8.i586.rpm
Source Package boost-1.72.0-1.mga8.src.rpm

Install Howto

  1. Enable Mageia Core repository on Install and Remove Software
  2. Update packages list:
    # urpmi.update -a
  3. Install libboost_graph1.72.0 rpm package:
    # urpmi libboost_graph1.72.0

Files

Path
/usr/lib/libboost_graph.so.1
/usr/lib/libboost_graph.so.1.72
/usr/lib/libboost_graph.so.1.72.0
/usr/lib/libboost_graph_parallel.so.1
/usr/lib/libboost_graph_parallel.so.1.72
/usr/lib/libboost_graph_parallel.so.1.72.0
/usr/lib/.build-id/
/usr/lib/.build-id/8d/596751135ff62d9054ab4e2c8ff3f295d8ba4f
/usr/lib/.build-id/f0/2972affe47ca49b7138673b34259db305f78df
/usr/share/licenses/libboost_graph1.72.0/LICENSE_1_0.txt

Changelog

2020-01-26 - wally <wally> 1.72.0-1.mga8
+ Revision: 1483313
- new version 1.72.0
- add lzma and zstd support
- rediff patches
- add patch originally from openSUSE to build shared libs
- add patch to fix overlinking and mysterious mpi build error
2019-10-05 - daviddavid <daviddavid> 1.68.0-7.mga8
+ Revision: 1449434
- rebuild for new icu 65.1
2019-09-04 - wally <wally> 1.68.0-6.mga8
+ Revision: 1437125
- turn off the brp-python-bytecompile automagic
- fix python requires
- rebuild for python3.8
- disable python2 support
+ tmb <tmb>
- lib(64)boost-devel: only recommend lib(64)boost_python2-devel
2019-01-07 - tv <tv> 1.68.0-4.mga7
+ Revision: 1350502
- rebuild with python 3.7
2018-12-29 - luigiwalser <luigiwalser> 1.68.0-3.mga7
+ Revision: 1346086
- rebuild for icu
2018-10-17 - wally <wally> 1.68.0-2.mga7
+ Revision: 1321690
- remove precompiled code from examples
2018-10-16 - wally <wally> 1.68.0-1.mga7
+ Revision: 1320999
- add conflicts for OpenMPI/MPICH Parallel BGL graph libraries
- update descriptions/summaries
- update libboost_graph_parallel lib pkg names
- split out openmpi/mpich python modules
- install openmpi/mpich libs to /usr/lib{,64}
- update openmpi/mpich pkg descriptions and summaries
2018-10-13 - wally <wally> 1.68.0-0.3.mga7
+ Revision: 1320082
- rely on autogenerated requires in openmpi and mpich pkgs
2018-10-13 - wally <wally> 1.68.0-0.2.mga7
+ Revision: 1320074
- fix Parallel BGL graph library pkg names
2018-10-13 - wally <wally> 1.68.0-0.1.mga7
+ Revision: 1320042
- new version 1.68.0
- sync .spec and patches with Fedora where appropriate
- disable mpich support as we can't have both mpich and openmpi devel pkgs installed at the same time

See Also

Package Description
libboost_graph_parallel-openmpi1.72.0-1.72.0-1.mga8.i586.rpm Run-time component of parallel boost graph library
libboost_iostreams1.72.0-1.72.0-1.mga8.i586.rpm Boost iostreams shared library
libboost_locale1.72.0-1.72.0-1.mga8.i586.rpm Boost locale shared library
libboost_log1.72.0-1.72.0-1.mga8.i586.rpm Boost log shared library
libboost_math1.72.0-1.72.0-1.mga8.i586.rpm Boost math shared library
libboost_mpi_python3-devel-1.72.0-1.mga8.i586.rpm Development files for Boost.MPI-OpenMPI Python 3 component
libboost_mpi_python38_1.72.0-1.72.0-1.mga8.i586.rpm Python 3 run-time component of Boost.MPI-OpenMPI library
libboost_numpy38_1.72.0-1.72.0-1.mga8.i586.rpm Boost numpy38 shared library
libboost_openmpi-devel-1.72.0-1.mga8.i586.rpm Development files for Boost.MPI-OpenMPI
libboost_openmpi1.72.0-1.72.0-1.mga8.i586.rpm Run-time component of Boost.MPI-OpenMPI library
libboost_prg_exec_monitor1.72.0-1.72.0-1.mga8.i586.rpm Boost prg_exec_monitor shared library
libboost_program_options1.72.0-1.72.0-1.mga8.i586.rpm Boost program_options shared library
libboost_python3-devel-1.72.0-1.mga8.i586.rpm Development files for Boost.Python 3
libboost_python38_1.72.0-1.72.0-1.mga8.i586.rpm Boost python38 shared library
libboost_random1.72.0-1.72.0-1.mga8.i586.rpm Boost random shared library
Advertisement
Advertisement