libcourier-unicode4-2.0-1.mga7.i586.rpm


Advertisement

Description

libcourier-unicode4 - A library implementing algorithms related to the Unicode Standard

Property Value
Distribution Mageia Cauldron
Repository Mageia Core i586
Package name libcourier-unicode4
Package version 2.0
Package release 1.mga7
Package architecture i586
Package type rpm
Installed size 257.17 KB
Download size 65.69 KB
Official Mirror distrib-coffee.ipsl.jussieu.fr
This library implements several algorithms related to the Unicode Standard:
* Look up uppercase, lowercase, and titlecase equivalents of a unicode
character.
* Implementation of grapheme and work breaking rules.
* Implementation of line breaking rules.
Several ancillary functions, like looking up the unicode character that
corresponds to some HTML 4.0 entity (such as “&”, for example), and
determining the normal width or a double-width status of a unicode character.
Also, an adaptation of the iconv(3) API for this unicode library.
This library also implements C++ bindings for these algorithms.
The current release of the Courier Unicode library is based on the Unicode
6.3.0 standard.

Alternatives

Package Version Architecture Repository
libcourier-unicode4 - - -

Requires

Name Value
libc.so.6 -
libc.so.6(GLIBC_2.0) -
libc.so.6(GLIBC_2.1) -
libc.so.6(GLIBC_2.1.3) -
libc.so.6(GLIBC_2.3) -
libc.so.6(GLIBC_2.3.4) -
libc.so.6(GLIBC_2.4) -
libgcc_s.so.1 -
libgcc_s.so.1(GCC_3.0) -
libstdc++.so.6 -
libstdc++.so.6(CXXABI_1.3) -
libstdc++.so.6(CXXABI_1.3.9) -
libstdc++.so.6(GLIBCXX_3.4) -
libstdc++.so.6(GLIBCXX_3.4.15) -
libstdc++.so.6(GLIBCXX_3.4.20) -
libstdc++.so.6(GLIBCXX_3.4.21) -

Provides

Name Value
libcourier-unicode.so.4 -
libcourier-unicode4 == 2.0-1.mga7
libcourier-unicode4(x86-32) == 2.0-1.mga7

Download

Type URL
Binary Package libcourier-unicode4-2.0-1.mga7.i586.rpm
Source Package courier-unicode-2.0-1.mga7.src.rpm

Install Howto

  1. Enable Mageia Core repository on Install and Remove Software
  2. Update packages list:
    # urpmi.update -a
  3. Install libcourier-unicode4 rpm package:
    # urpmi libcourier-unicode4

Files

Path
/usr/lib/libcourier-unicode.so.4
/usr/lib/libcourier-unicode.so.4.0.0
/usr/lib/.build-id/
/usr/lib/.build-id/c1/dc8a64952bebbd77f81f7d9fe01f759c6e7da5
/usr/share/doc/libcourier-unicode4/AUTHORS
/usr/share/doc/libcourier-unicode4/ChangeLog
/usr/share/doc/libcourier-unicode4/README
/usr/share/licenses/libcourier-unicode4/COPYING

Changelog

2017-10-14 - wally <wally> 2.0-1.mga7
+ Revision: 1171806
- new version 2.0
- new lib major 4
2016-02-06 - wally <wally> 1.4-1.mga6
+ Revision: 942123
- Import courier-unicode based on .spec from Fedora to fix maildrop build
2016-02-04 - Brian C. Lane <bcl@redhat.com> 1.4-1
- Upstream v1.4
Note that the library name changed to libcourier-unicode
2016-02-03 - Fedora Release Engineering <releng@fedoraproject.org> - 1.1-6
- Rebuilt for https://fedoraproject.org/wiki/Fedora_24_Mass_Rebuild
2015-06-17 - Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.1-5
- Rebuilt for https://fedoraproject.org/wiki/Fedora_23_Mass_Rebuild
2015-05-02 - Kalev Lember <kalevlember@gmail.com> - 1.1-4
- Rebuilt for GCC 5 C++11 ABI change
2015-02-18 - Brian C. Lane <bcl@redhat.com> 1.1-3
- Update with suggestions from the review
- Run make check
2015-02-17 - Brian C. Lane <bcl@redhat.com> 1.1-2
- Changed package name to courier-unicode
2015-01-28 - Brian C. Lane <bcl@redhat.com> 1.1-1
- Initial build

See Also

Package Description
libcp_dbms_mysql0-0.1.12-15.mga7.i586.rpm MySQL (MariaDB) dbms driver for libcprops
libcp_dbms_postgres0-0.1.12-15.mga7.i586.rpm PostgreSQL dbms driver for libcprops
libcpl-devel-7.0-3.mga7.i586.rpm Libraries, includes, etc. used to develop an application with cpl
libcpl26-7.0-3.mga7.i586.rpm ESO library for automated astronomical data-reduction tasks
libcpprest-devel-2.10.6-1.mga7.i586.rpm Development package for cpprest
libcpprest2.10-2.10.6-1.mga7.i586.rpm C++ Rest library
libcppunit-devel-1.14.0-1.mga7.i586.rpm Development files for cppunit
libcppunit1.14_0-1.14.0-1.mga7.i586.rpm C++ port of JUnit Testing Framework
libcppzmq-devel-4.2.1-4.mga7.i586.rpm C++ binding for 0MQ
libcprops-devel-0.1.12-15.mga7.i586.rpm Development files for libcprops
libcprops15-0.1.12-15.mga7.i586.rpm C Prototyping Tools
libcpufreq-devel-008-10.mga6.i586.rpm Development files for cpufrequtils
libcpufreq0-008-10.mga6.i586.rpm Main library for cpufrequtils
libcpufreqd-2.4.2-13.mga6.i586.rpm Library for cpufreqd
libcpuinfo-devel-1.0-0.20090313.24.mga7.i586.rpm Development files for cpuinfo
Advertisement
Advertisement