libcryptopp7-7.0.0-1.mga7.i586.rpm


Advertisement

Description

libcryptopp7 - Base shared library part of libcryptopp

Property Value
Distribution Mageia Cauldron
Repository Mageia Core i586
Package filename libcryptopp7-7.0.0-1.mga7.i586.rpm
Package name libcryptopp7
Package version 7.0.0
Package release 1.mga7
Package architecture i586
Package type rpm
Category System/Libraries
Homepage http://www.cryptopp.com
License Boost Software License 1.0
Maintainer -
Download size 1.07 MB
Installed size 4.15 MB
Crypto++ Library is a free C++ class library of cryptographic schemes.
This package contains the library needed to run programs dynamically
linked with libcryptopp.

Alternatives

Package Version Architecture Repository
libcryptopp7 - - -

Requires

Name Value
libc.so.6 -
libc.so.6(GLIBC_2.0) -
libc.so.6(GLIBC_2.1.3) -
libc.so.6(GLIBC_2.11) -
libc.so.6(GLIBC_2.15) -
libc.so.6(GLIBC_2.3.4) -
libc.so.6(GLIBC_2.4) -
libgcc_s.so.1 -
libgcc_s.so.1(GCC_3.0) -
libgcc_s.so.1(GLIBC_2.0) -
libm.so.6 -
libm.so.6(GLIBC_2.0) -
libpthread.so.0 -
libpthread.so.0(GLIBC_2.0) -
libstdc++.so.6 -
libstdc++.so.6(CXXABI_1.3) -
libstdc++.so.6(CXXABI_1.3.9) -
libstdc++.so.6(GLIBCXX_3.4) -
libstdc++.so.6(GLIBCXX_3.4.11) -
libstdc++.so.6(GLIBCXX_3.4.15) -
libstdc++.so.6(GLIBCXX_3.4.21) -
libstdc++.so.6(GLIBCXX_3.4.9) -

Provides

Name Value
libcryptopp == 7.0.0-1.mga7
libcryptopp.so.7 -
libcryptopp7 == 7.0.0-1.mga7
libcryptopp7(x86-32) == 7.0.0-1.mga7

Download

Type URL
Mirror distrib-coffee.ipsl.jussieu.fr
Binary Package libcryptopp7-7.0.0-1.mga7.i586.rpm
Source Package libcryptopp-7.0.0-1.mga7.src.rpm

Install Howto

  1. Enable Mageia Core repository on Install and Remove Software
  2. Update packages list:
    # urpmi.update -a
  3. Install libcryptopp7 rpm package:
    # urpmi libcryptopp7

Files

Path
/usr/lib/libcryptopp.so.7
/usr/lib/libcryptopp.so.7.0.0
/usr/lib/.build-id/
/usr/lib/.build-id/31/70df02f4e2d2469ca913fad7a3aef47022614f
/usr/share/doc/libcryptopp7/License.txt
/usr/share/doc/libcryptopp7/Readme.txt

Changelog

2018-09-16 - daviddavid <daviddavid> 7.0.0-1.mga7
(not released yet)
+ Revision: 1259204
- new version: 7.0.0
- now libmajor is 7
- use the upstream GNUmakefile
- remove merged upstream patches
2017-10-10 - daviddavid <daviddavid> 5.6.5-4.mga7
+ Revision: 1170699
- rebuild for new gcc7
2017-06-11 - wally <wally> 5.6.5-3.mga6
+ Revision: 1107534
- add patch from Gentoo to fix CVE-2017-9434 (mga#21029)
2017-01-02 - neoclust <neoclust> 5.6.5-2.mga6
+ Revision: 1079570
- Install trap.h
2016-12-29 - wally <wally> 5.6.5-1.mga6
+ Revision: 1078594
- new version 5.6.5
- drop upstreamed patches
- update autotools patch
2016-12-28 - wally <wally> 5.6.3-6.mga6
+ Revision: 1078523
- fix version in pkgconfig .pc file
- drop unneeded epoch
2016-12-16 - mrambo3501 <mrambo3501> 0:5.6.3-5.mga6
+ Revision: 1075708
- add upstream patch to fix CVE-2016-9939
2016-09-16 - luigiwalser <luigiwalser> 0:5.6.3-4.mga6
+ Revision: 1053356
- add -DNDEBUG to CXXFLAGS to fix CVE-2016-7420
2016-06-17 - daviddavid <daviddavid> 0:5.6.3-3.mga6
+ Revision: 1021845
- disable testsuite on ARM
2016-04-22 - luigiwalser <luigiwalser> 0:5.6.3-2.mga6
+ Revision: 1005384
- fix paths of test files
- add cryptest man page from debian

See Also

Package Description
libcryptsetup-devel-2.1.0-1.mga7.i586.rpm Development library for setting up encrypted filesystems
libcryptsetup12-2.1.0-1.mga7.i586.rpm Library for setting up encrypted filesystems
libcryptui-3.12.2-9.mga7.i586.rpm Interface components for OpenPGP
libcryptui-devel-3.12.2-9.mga7.i586.rpm Header files required to develop with libcryptui
libcryptui-gir0.0-3.12.2-9.mga7.i586.rpm GObject Introspection interface description for libcryptui
libcryptui0-3.12.2-9.mga7.i586.rpm Interface components for OpenPGP
libcrystalhd-common-0-0.20110315.12.mga7.i586.rpm udev rules for Broadcom Crystal HD decoder
libcrystalhd-devel-0-0.20110315.12.mga7.i586.rpm Headers for libcrystalhd development
libcrystalhd3-0-0.20110315.12.mga7.i586.rpm Broadcom Crystal HD decoder library
libcsiro0-5.14.0-6.mga8.i586.rpm Scientific plotting library (CSIRO libraries)
libcssparser-devel-0.87-1.mga7.i586.rpm These are the css_parser libraries
libcssparser0-0.87-1.mga7.i586.rpm These are the css_parser development files
libctemplate-devel-2.3-4.mga7.i586.rpm Development files for the ctemplate library
libctemplate3-2.3-4.mga7.i586.rpm Simple but powerful template language for C++
libctpl-devel-0.3.4-3.mga7.i586.rpm Devel package for the CTPL library
Advertisement
Advertisement