libcups2-2.3.1-3.mga8.i586.rpm


Advertisement

Description

libcups2 - CUPS printing system - CUPS library

Property Value
Distribution Mageia Cauldron
Repository Mageia Core i586
Package filename libcups2-2.3.1-3.mga8.i586.rpm
Package name libcups2
Package version 2.3.1
Package release 3.mga8
Package architecture i586
Package type rpm
Category System/Libraries
Homepage http://www.cups.org
License LGPLv2
Maintainer -
Download size 290.04 KB
Installed size 704.79 KB
The CUPS printing system provides a portable printing layer for
UNIX® operating systems. This package contains the CUPS API library
which contains common functions used by both the CUPS daemon and all
CUPS frontends (lpr-cups, xpp, qtcups, kups, ...).
This package you need for both CUPS clients and servers. It is also
needed by Samba.

Alternatives

Package Version Architecture Repository
libcups2 - - -

Requires

Name Value
hostname -
libavahi-client.so.3 -
libavahi-common.so.3 -
libc.so.6 -
libc.so.6(GLIBC_2.0) -
libc.so.6(GLIBC_2.1) -
libc.so.6(GLIBC_2.1.3) -
libc.so.6(GLIBC_2.16) -
libc.so.6(GLIBC_2.17) -
libc.so.6(GLIBC_2.2) -
libc.so.6(GLIBC_2.28) -
libc.so.6(GLIBC_2.3) -
libc.so.6(GLIBC_2.3.4) -
libc.so.6(GLIBC_2.4) -
libc.so.6(GLIBC_2.7) -
libcups.so.2 -
libgnutls.so.30 -
libgnutls.so.30(GNUTLS_3_4) -
libgssapi_krb5.so.2 -
libgssapi_krb5.so.2(gssapi_krb5_2_MIT) -
libm.so.6 -
libm.so.6(GLIBC_2.0) -
libpthread.so.0 -
libpthread.so.0(GLIBC_2.0) -
libpthread.so.0(GLIBC_2.1) -
libpthread.so.0(GLIBC_2.2) -
libpthread.so.0(GLIBC_2.3.2) -
libz.so.1 -
libz.so.1(ZLIB_1.2.0) -

Provides

Name Value
libcups.so.2 -
libcups1 == 2.3.1
libcups2 == 2.3.1-3.mga8
libcups2(x86-32) == 2.3.1-3.mga8
libcupsimage.so.2 -

Obsoletes

Name Value
libcups1 -

Download

Type URL
Mirror distrib-coffee.ipsl.jussieu.fr
Binary Package libcups2-2.3.1-3.mga8.i586.rpm
Source Package cups-2.3.1-3.mga8.src.rpm

Install Howto

  1. Enable Mageia Core repository on Install and Remove Software
  2. Update packages list:
    # urpmi.update -a
  3. Install libcups2 rpm package:
    # urpmi libcups2

Files

Path
/usr/lib/libcups.so.2
/usr/lib/libcupsimage.so.2
/usr/lib/.build-id/
/usr/lib/.build-id/5a/36d42975df72b2201d9a58ab4233d9631410d8
/usr/lib/.build-id/e5/98bcf9dc8d83b9c2081867d1e5f29b379d9985
/usr/share/licenses/libcups2/LICENSE
/usr/share/licenses/libcups2/NOTICE

Changelog

2020-01-24 - tv <tv> 2.3.1-3.mga8
+ Revision: 1482690
- rebuild for new p11-kit
+ wally <wally>
- replace deprecated %configure2_5x
- replace deprecated %setup_compile_flags
2019-12-16 - tv <tv> 2.3.1-2.mga8
+ Revision: 1468306
- fix file conflict
2019-12-16 - tv <tv> 2.3.1-1.mga8
+ Revision: 1468270
- 2.3.1
2019-11-30 - tv <tv> 2.3.0-2.mga8
+ Revision: 1463850
- /run files must be %ghost
- cups unit file makes systemd to complain (rhbz#1777921)
- 2.3.0 - new printerapp subpackage
2019-10-17 - tv <tv> 2.2.12-5.mga8
+ Revision: 1454243
- [abrt] cups: __strlen_avx2(): printers.cgi killed by SIGSEGV (rhbz#1720688)
- cups is unable to add ppd with custom/Custom option (rhbz#1750904)
2019-10-03 - tv <tv> 2.2.12-4.mga8
+ Revision: 1449100
- handle smb printing with cups' triggers (mga#21164)
2019-10-03 - tv <tv> 2.2.12-3.mga8
+ Revision: 1449048
- fix cupsctl usage
2019-09-11 - tv <tv> 2.2.12-2.mga8
+ Revision: 1439589
- switch to %configure2_5x
- rebuild for python-3.8
2019-08-30 - tv <tv> 2.2.12-1.mga8
+ Revision: 1435308
- new release
2019-07-23 - tv <tv> 2.2.11-3.mga8
+ Revision: 1423594
- Samsung ML-1676P Laser printer fails to print document (rhbz#1708988)

See Also

Package Description
libcups2-devel-2.3.1-3.mga8.i586.rpm CUPS printing system - Development environment "libcups"
libcurl-devel-7.68.0-1.mga8.i586.rpm Header files and static libraries for libcurl
libcurl4-7.68.0-1.mga8.i586.rpm A library of functions for file transfer
libcw-devel-3.5.1-5.mga8.i586.rpm Development files for unixcw
libcw6-3.5.1-5.mga8.i586.rpm Development files for unixcw
libcwiid-devel-0.6.02-15.mga8.i586.rpm Development headers and libraries for CWiid
libcwiid1-0.6.02-15.mga8.i586.rpm CWiid Wiimote library
libcxsparse3-4.4.6-4.mga8.i586.rpm Direct methods for sparse linear systems
libcxx-gtk-utils2.2-devel-2.2.19-1.mga8.i586.rpm Development files for c++-gtk-utils
libcxx-gtk-utils2.2_0-2.2.19-1.mga8.i586.rpm A library containing a number of classes and functions for programming GTK+ programs using C++
libcxxtools-devel-2.2.1-9.mga8.i586.rpm Headers and static library for cxxtools development
libcxxtools9-2.2.1-9.mga8.i586.rpm Shared library of cxxtools
libcyrus-imapd-devel-2.5.15-1.mga8.i586.rpm Cyrus IMAP server development files
libcyrus-imapd0-2.5.15-1.mga8.i586.rpm Cyrus IMAP server library files
libczmq-devel-4.2.0-2.mga8.i586.rpm Development files for the czmq package
Advertisement
Advertisement