libdigikam-devel-6.4.0-3.mga8.i586.rpm


Advertisement

Description

libdigikam-devel - Static libraries and headers for digikam

Property Value
Distribution Mageia Cauldron
Repository Mageia Core i586
Package filename libdigikam-devel-6.4.0-3.mga8.i586.rpm
Package name libdigikam-devel
Package version 6.4.0
Package release 3.mga8
Package architecture i586
Package type rpm
Category Development/C
Homepage https://www.digikam.org
License GPLv2+
Maintainer -
Download size 96.51 KB
Installed size 433.65 KB
libdigikam-devel contains the libraries and header files needed to
develop programs which make use of digikam.
The library documentation is available on header files.

Alternatives

Package Version Architecture Repository
libdigikam-devel - - -

Requires

Name Value
devel(libKF5ConfigCore) -
devel(libKF5ConfigGui) -
devel(libKF5ConfigWidgets) -
devel(libKF5CoreAddons) -
devel(libKF5I18n) -
devel(libKF5IconThemes) -
devel(libKF5KIOWidgets) -
devel(libKF5Notifications) -
devel(libKF5NotifyConfig) -
devel(libKF5Service) -
devel(libKF5Solid) -
devel(libKF5WidgetsAddons) -
devel(libKF5WindowSystem) -
devel(libKF5XmlGui) -
devel(libQt5Concurrent) -
devel(libQt5Core) -
devel(libQt5DBus) -
devel(libQt5Gui) -
devel(libQt5Network) -
devel(libQt5PrintSupport) -
devel(libQt5Sql) -
devel(libQt5WebKit) -
devel(libQt5WebKitWidgets) -
devel(libQt5Widgets) -
devel(libQt5X11Extras) -
devel(libQt5Xml) -
devel(libQtAV) -
devel(libQtAVWidgets) -
devel(libX11) -
devel(libavcodec) -
devel(libavfilter) -
devel(libavformat) -
devel(libavutil) -
devel(libdigikamcore) -
devel(libdigikamdatabase) -
devel(libexiv2) -
devel(libexpat) -
devel(libgcc_s) -
devel(libgomp) -
devel(libgphoto2) -
devel(libgphoto2_port) -
devel(libjasper) -
devel(libjpeg) -
devel(liblcms2) -
devel(liblensfun) -
devel(liblqr-1) -
devel(libm) -
devel(libmarblewidget-qt5) -
devel(libopencv_core) -
devel(libopencv_imgproc) -
devel(libopencv_objdetect) -
devel(libpng16) -
devel(libstdc++) -
devel(libswscale) -
libdigikamcore6 == 1:6.4.0-3.mga8
libdigikamdatabase6 == 1:6.4.0-3.mga8
libdigikamgui6 == 1:6.4.0-3.mga8

Provides

Name Value
cmake(DigikamCore) == 6.4.0
cmake(DigikamDatabase) == 6.4.0
cmake(DigikamGui) == 6.4.0
devel(libdigikamcore) -
devel(libdigikamdatabase) -
devel(libdigikamgui) -
digikam-devel == 1:6.4.0-3.mga8
libdigikam-devel == 1:6.4.0-3.mga8
libdigikam-devel(x86-32) == 1:6.4.0-3.mga8

Download

Type URL
Mirror distrib-coffee.ipsl.jussieu.fr
Binary Package libdigikam-devel-6.4.0-3.mga8.i586.rpm
Source Package digikam-6.4.0-3.mga8.src.rpm

Install Howto

  1. Enable Mageia Core repository on Install and Remove Software
  2. Update packages list:
    # urpmi.update -a
  3. Install libdigikam-devel rpm package:
    # urpmi libdigikam-devel

Files

Path
/usr/include/digikam/batchtool.h
/usr/include/digikam/bcgcontainer.h
/usr/include/digikam/coredbaccess.h
/usr/include/digikam/coredbalbuminfo.h
/usr/include/digikam/coredbconstants.h
/usr/include/digikam/coredbfields.h
/usr/include/digikam/coredburl.h
/usr/include/digikam/curvescontainer.h
/usr/include/digikam/dbengineaction.h
/usr/include/digikam/dbengineconfig.h
/usr/include/digikam/dbengineconfigsettings.h
/usr/include/digikam/dbengineerrorhandler.h
/usr/include/digikam/dbengineparameters.h
/usr/include/digikam/dcolor.h
/usr/include/digikam/dcolorblend.h
/usr/include/digikam/dcolorcomposer.h
/usr/include/digikam/dcolorpixelaccess.h
/usr/include/digikam/dhistoryview.h
/usr/include/digikam/digikam_config.h
/usr/include/digikam/digikam_core_export.h
/usr/include/digikam/digikam_database_export.h
/usr/include/digikam/digikam_export.h
/usr/include/digikam/digikam_globals.h
/usr/include/digikam/dimg.h
/usr/include/digikam/dimgbuiltinfilter.h
/usr/include/digikam/dimgloaderobserver.h
/usr/include/digikam/dimgpreviewitem.h
/usr/include/digikam/dimgthreadedanalyser.h
/usr/include/digikam/dimgthreadedfilter.h
/usr/include/digikam/dinfointerface.h
/usr/include/digikam/ditemslist.h
/usr/include/digikam/dmessagebox.h
/usr/include/digikam/dmetainfoiface.h
/usr/include/digikam/dplugin.h
/usr/include/digikam/dpluginaction.h
/usr/include/digikam/dpluginauthor.h
/usr/include/digikam/dpluginbqm.h
/usr/include/digikam/dplugindialog.h
/usr/include/digikam/dplugineditor.h
/usr/include/digikam/dplugingeneric.h
/usr/include/digikam/dpluginloader.h
/usr/include/digikam/dpluginrawimport.h
/usr/include/digikam/dpreviewimage.h
/usr/include/digikam/dpreviewmanager.h
/usr/include/digikam/drawdecoder.h
/usr/include/digikam/drawdecodersettings.h
/usr/include/digikam/drawdecoding.h
/usr/include/digikam/drawinfo.h
/usr/include/digikam/dsavesettingswidget.h
/usr/include/digikam/dshareddata.h
/usr/include/digikam/dwizarddlg.h
/usr/include/digikam/dwizardpage.h
/usr/include/digikam/editortool.h
/usr/include/digikam/filesaveconflictbox.h
/usr/include/digikam/filteraction.h
/usr/include/digikam/geocoordinates.h
/usr/include/digikam/geoifacetypes.h
/usr/include/digikam/gpsdatacontainer.h
/usr/include/digikam/gpsitemcontainer.h
/usr/include/digikam/graphicsdimgitem.h
/usr/include/digikam/graphicsdimgview.h
/usr/include/digikam/historyimageid.h
/usr/include/digikam/iccprofile.h
/usr/include/digikam/icctransform.h
/usr/include/digikam/imageiface.h
/usr/include/digikam/imageregionwidget.h
/usr/include/digikam/imagezoomsettings.h
/usr/include/digikam/iofilesettings.h
/usr/include/digikam/iteminfo.h
/usr/include/digikam/iteminfolist.h
/usr/include/digikam/loadingdescription.h
/usr/include/digikam/metaengine.h
/usr/include/digikam/metaengine_data.h
/usr/include/digikam/photoinfocontainer.h
/usr/include/digikam/previewlayout.h
/usr/include/digikam/previewsettings.h
/usr/include/digikam/previewtoolbar.h
/usr/include/digikam/queuesettings.h
/usr/include/digikam/rginfo.h
/usr/include/digikam/thumbnailinfo.h
/usr/include/digikam/wbcontainer.h
/usr/lib/libdigikamcore.so
/usr/lib/libdigikamdatabase.so
/usr/lib/libdigikamgui.so
/usr/lib/cmake/DigikamCore/DigikamCoreConfig-relwithdebinfo.cmake
/usr/lib/cmake/DigikamCore/DigikamCoreConfig.cmake
/usr/lib/cmake/DigikamCore/DigikamCoreConfigVersion.cmake
/usr/lib/cmake/DigikamDatabase/DigikamDatabaseConfig-relwithdebinfo.cmake
/usr/lib/cmake/DigikamDatabase/DigikamDatabaseConfig.cmake
/usr/lib/cmake/DigikamDatabase/DigikamDatabaseConfigVersion.cmake
/usr/lib/cmake/DigikamGui/DigikamGuiConfig-relwithdebinfo.cmake
/usr/lib/cmake/DigikamGui/DigikamGuiConfig.cmake
/usr/lib/cmake/DigikamGui/DigikamGuiConfigVersion.cmake

Changelog

2020-01-25 - daviddavid <daviddavid> 1:6.4.0-3.mga8
+ Revision: 1482895
- add patch to fix build with opencv 4.2.0
- rebuild for new opencv 4.2.0
2019-12-30 - kekepower <kekepower> 1:6.4.0-2.mga8
+ Revision: 1474950
- Rebuild for new imagemagick
+ wally <wally>
- build with new cmake macros
+ daviddavid <daviddavid>
- turn off default verbose build with appropriate macro
2019-11-17 - daviddavid <daviddavid> 1:6.4.0-1.mga8
+ Revision: 1461524
- new version: 6.4.0
2019-09-14 - daviddavid <daviddavid> 1:6.3.0-1.mga8
+ Revision: 1440844
- new version: 6.3.0
2019-08-01 - daviddavid <daviddavid> 1:6.2.0-1.mga8
+ Revision: 1426659
- new version: 6.2.0
2019-05-17 - daviddavid <daviddavid> 4.mga7-current
+ Revision: 1398100
- rebuild for new exiv2 0.27.1
2019-04-21 - daviddavid <daviddavid> 1:6.1.0-3.mga7
+ Revision: 1394160
- re-enable kvkontakte support
2019-04-20 - daviddavid <daviddavid> 1:6.1.0-2.mga7
+ Revision: 1393671
- do not obsolete/provide all kipi-plugins anymore as now in a separate pkg
2019-04-16 - daviddavid <daviddavid> 1:6.1.0-1.mga7
+ Revision: 1391588
- new version: 6.1.0
2019-03-30 - umeabot <umeabot> 1:6.0.0-2.mga7
+ Revision: 1381534
- Qt5 Rebuild

See Also

Package Description
libdigikamcore6-6.4.0-3.mga8.i586.rpm Runtime library for digikam
libdigikamdatabase6-6.4.0-3.mga8.i586.rpm Runtime library for digikam
libdigikamgui6-6.4.0-3.mga8.i586.rpm Runtime library for digikam
libdirac-devel-1.0.2-14.mga8.i586.rpm Development files of the Dirac Video codec
libdirac0-1.0.2-14.mga8.i586.rpm Shared library of the Dirac Video codec
libdiscid-devel-0.6.2-3.mga8.i586.rpm A Library for creating MusicBrainz DiscIDs
libdiscid0-0.6.2-3.mga8.i586.rpm A Library for creating MusicBrainz DiscIDs
libdistcache-devel-1.5.1-30.mga8.i586.rpm Libraries and header files for building distcache-compatible software
libdistcache1-1.5.1-30.mga8.i586.rpm Shared libraries for distcache
libdivecomputer-0.6.0-3.mga8.i586.rpm Library for communication with dive computers
libdivecomputer-devel-0.6.0-3.mga8.i586.rpm Header files and development libraries for libdivecomputer
libdivecomputer-subsurface-devel-4.9.3-2.mga8.i586.rpm Header files and development libraries for libdivecomputer-subsurface
libdivecomputer0-0.6.0-3.mga8.i586.rpm Libraries for libdivecomputer
libdjconsole-0.1.3-12.mga8.i586.rpm Libdjconsole - Support for hardware dj consoles
libdjconsole-devel-0.1.3-12.mga8.i586.rpm Libdjconsole - Support for hardware dj consoles
Advertisement
Advertisement