libdistcache-devel-1.5.1-28.mga7.i586.rpm


Advertisement

Description

libdistcache-devel - Libraries and header files for building distcache-compatible software

Property Value
Distribution Mageia Cauldron
Repository Mageia Core i586
Package name libdistcache-devel
Package version 1.5.1
Package release 28.mga7
Package architecture i586
Package type rpm
Installed size 361.02 KB
Download size 181.57 KB
Official Mirror distrib-coffee.ipsl.jussieu.fr
This package includes the libraries and header files from the distcache project
that are required to compile
distcache-compatible software.

Alternatives

Package Version Architecture Repository
libdistcache-devel - - -

Requires

Name Value
devel(libcrypto) -
devel(libdistcache) -
devel(libdl) -
devel(libnal) -
devel(libnsl) -
devel(libssl) -
libdistcache1 == 1.5.1

Provides

Name Value
devel(libdistcache) -
devel(libdistcacheserver) -
devel(libnal) -
devel(libnalssl) -
distcache-devel == 1.5.1
libdistcache-devel == 1.5.1-28.mga7
libdistcache-devel(x86-32) == 1.5.1-28.mga7
libdistcache1-devel == 1.5.1
libtool(/usr/lib/libdistcache.la) -
libtool(/usr/lib/libdistcacheserver.la) -
libtool(/usr/lib/libnal.la) -
libtool(/usr/lib/libnalssl.la) -

Obsoletes

Name Value
distcache-devel -
libdistcache1-devel -

Download

Type URL
Binary Package libdistcache-devel-1.5.1-28.mga7.i586.rpm
Source Package distcache-1.5.1-28.mga7.src.rpm

Install Howto

  1. Enable Mageia Core repository on "Install and Remove Software"
  2. Update packages list:
    # urpmi.update -a
  3. Install libdistcache-devel rpm package:
    # urpmi libdistcache-devel

Files

Path
/usr/include/distcache/dc_client.h
/usr/include/distcache/dc_plug.h
/usr/include/distcache/dc_server.h
/usr/include/libnal/nal.h
/usr/include/libnal/nal_devel.h
/usr/include/libnal/nal_ssl.h
/usr/lib/libdistcache.a
/usr/lib/libdistcache.la
/usr/lib/libdistcache.so
/usr/lib/libdistcacheserver.a
/usr/lib/libdistcacheserver.la
/usr/lib/libdistcacheserver.so
/usr/lib/libnal.a
/usr/lib/libnal.la
/usr/lib/libnal.so
/usr/lib/libnalssl.a
/usr/lib/libnalssl.la
/usr/lib/libnalssl.so
/usr/share/man/man2/DC_CTX_new.2.xz
/usr/share/man/man2/DC_PLUG_new.2.xz
/usr/share/man/man2/DC_PLUG_read.2.xz
/usr/share/man/man2/DC_SERVER_new.2.xz
/usr/share/man/man2/NAL_ADDRESS_new.2.xz
/usr/share/man/man2/NAL_BUFFER_new.2.xz
/usr/share/man/man2/NAL_CONNECTION_new.2.xz
/usr/share/man/man2/NAL_LISTENER_new.2.xz
/usr/share/man/man2/NAL_SELECTOR_new.2.xz
/usr/share/man/man2/NAL_decode_uint32.2.xz

Changelog

2017-10-15 - cjw <cjw> 1.5.1-28.mga7
+ Revision: 1172235
- patch6: fix build with openssl 1.1
2016-03-02 - luigiwalser <luigiwalser> 1.5.1-27.mga6
+ Revision: 983717
- add patch from David Geiger to fix build with openssl with sslv2 disabled
+ umeabot <umeabot>
- Rebuild for openssl
2016-02-08 - umeabot <umeabot> 1.5.1-26.mga6
+ Revision: 942953
- Mageia 6 Mass Rebuild

See Also

Package Description
libdistcache1-1.5.1-28.mga7.i586.rpm Shared libraries for distcache
libdivecomputer-0.6.0-1.mga7.i586.rpm Library for communication with dive computers
libdivecomputer-devel-0.6.0-1.mga7.i586.rpm Header files and development libraries for libdivecomputer
libdivecomputer-subsurface-devel-4.7.8-1.mga7.i586.rpm Header files and development libraries for libdivecomputer-subsurface
libdivecomputer0-0.6.0-1.mga7.i586.rpm Libraries for libdivecomputer
libdjconsole-0.1.3-10.mga6.i586.rpm Libdjconsole - Support for hardware dj consoles
libdjconsole-devel-0.1.3-10.mga6.i586.rpm Libdjconsole - Support for hardware dj consoles
libdjconsole0-0.1.3-10.mga6.i586.rpm Libdjconsole - Support for hardware dj consoles
libdjvulibre-devel-3.5.27-4.mga7.i586.rpm DjVulibre development files
libdjvulibre21-3.5.27-4.mga7.i586.rpm DjVulibre library
libdleyna-connector-dbus-0.2.0-2.mga6.i586.rpm D-Bus connector for dLeyna services
libdleyna-connector-dbus-devel-0.2.0-2.mga6.i586.rpm Development files for dleyna-connector-dbus
libdleyna-core1.0-devel-0.5.0-2.mga6.i586.rpm Development files for dleyna-core
libdleyna-core1.0_4-0.5.0-2.mga6.i586.rpm Utilities for higher level dLeyna libraries
libdlm-devel-4.0.7-1.mga6.i586.rpm Development files for dlm
Advertisement
Advertisement