libgnuradio-uhd-devel-3.8.0.0-6.mga8.i586.rpm


Advertisement

Description

libgnuradio-uhd-devel - Uhd devel files

Property Value
Distribution Mageia Cauldron
Repository Mageia Core i586
Package filename libgnuradio-uhd-devel-3.8.0.0-6.mga8.i586.rpm
Package name libgnuradio-uhd-devel
Package version 3.8.0.0
Package release 6.mga8
Package architecture i586
Package type rpm
Category Development/Other
Homepage http://www.gnuradio.org
License GPLv3+
Maintainer -
Download size 16.69 KB
Installed size 41.30 KB
This package contains header files needed by developers.

Alternatives

Package Version Architecture Repository
libgnuradio-uhd-devel - - -

Requires

Name Value
devel(libboost_thread) -
devel(libgcc_s) -
devel(libgnuradio-pmt) -
devel(libgnuradio-runtime) -
devel(liblog4cpp) -
devel(libstdc++) -
devel(libuhd) -
libgnuradio-runtime-devel == 3.8.0.0-6.mga8
libgnuradio-uhd3 == 3.8.0.0-6.mga8
pkgconfig -
pkgconfig(gnuradio-runtime) -

Provides

Name Value
devel(libgnuradio-uhd) -
gnuradio-uhd-devel == 3.8.0.0-6.mga8
libgnuradio-uhd-devel == 3.8.0.0-6.mga8
libgnuradio-uhd-devel(x86-32) == 3.8.0.0-6.mga8
pkgconfig(gnuradio-uhd) == 3.8.0

Download

Type URL
Mirror distrib-coffee.ipsl.jussieu.fr
Binary Package libgnuradio-uhd-devel-3.8.0.0-6.mga8.i586.rpm
Source Package gnuradio-3.8.0.0-6.mga8.src.rpm

Install Howto

  1. Enable Mageia Core repository on Install and Remove Software
  2. Update packages list:
    # urpmi.update -a
  3. Install libgnuradio-uhd-devel rpm package:
    # urpmi libgnuradio-uhd-devel

Files

Path
/usr/include/gnuradio/uhd/amsg_source.h
/usr/include/gnuradio/uhd/api.h
/usr/include/gnuradio/uhd/usrp_block.h
/usr/include/gnuradio/uhd/usrp_sink.h
/usr/include/gnuradio/uhd/usrp_source.h
/usr/lib/libgnuradio-uhd.so
/usr/lib/pkgconfig/gnuradio-uhd.pc

Changelog

2020-01-26 - wally <wally> 3.8.0.0-6.mga8
+ Revision: 1483372
- rebuild for boost 1.72.0
2020-01-04 - barjac <barjac> 3.8.0.0-5.mga8
+ Revision: 1476040
- require new uhd-3.15
- rebuild for uhd
+ wally <wally>
- build with new cmake macros
2019-11-22 - barjac <barjac> 3.8.0.0-4.mga8
+ Revision: 1462169
- really skip qa_fecapi_ldpc ctest in i586 build as it hangs due
to https://github.com/gnuradio/gnuradio/issues/989 reported in 2016
- new BRs python3-click-plugins, python3-sphinx
- reinstate python-gnuradio-modtool
- drop qa_qtgui ctest
- Fix for Mga#25667 (gnuradio-companion fails to run)
- Correct %files lists and some white space
2019-11-07 - barjac <barjac> 3.8.0.0-2.mga8
+ Revision: 1458620
- add BRs texlive gmp-devel
- add BRs texlive gmp-devel
- new version 3.8.0.0
- move to python3 and qt5
- drop obsolete modules
- new major (was not used previously upstream)
2019-04-18 - barjac <barjac> 3.7.13.4-3.mga7
+ Revision: 1393304
- Rebuild for uhd-3.14.0.0
2019-01-18 - barjac <barjac> 3.7.13.4-2.mga7
+ Revision: 1357915
- rebuild for uhd in armv7hl
2019-01-17 - barjac <barjac> 3.7.13.4-1.mga7
+ Revision: 1357841
- new version 3.7.13.4
2018-10-16 - wally <wally> 3.7.13.3-4.mga7
+ Revision: 1321038
- rebuild for new boost 1.68.0
2018-10-02 - wally <wally> 3.7.13.3-3.mga7
+ Revision: 1314599
- rebuild for aarch64
2018-09-23 - umeabot <umeabot> 3.7.13.3-2.mga7
+ Revision: 1297999
- Mageia 7 Mass Rebuild

See Also

Package Description
libgnuradio-uhd3-3.8.0.0-6.mga8.i586.rpm uhd
libgnuradio-video-sdl-devel-3.8.0.0-6.mga8.i586.rpm GNU Radio C++ block implementing video-sdl-coded modulation
libgnuradio-video-sdl3-3.8.0.0-6.mga8.i586.rpm GNU Radio C++ block implementing video-sdl-coded modulation
libgnuradio-vocoder-devel-3.8.0.0-6.mga8.i586.rpm GNU Radio vocoder devel files
libgnuradio-vocoder3-3.8.0.0-6.mga8.i586.rpm GNU Radio C++ vocoder blocks
libgnuradio-wavelet-devel-3.8.0.0-6.mga8.i586.rpm GnuRadio Wavelet development files
libgnuradio-wavelet3-3.8.0.0-6.mga8.i586.rpm GnuRadio Wavelet
libgnuradio-zeromq-devel-3.8.0.0-6.mga8.i586.rpm GnuRadio zeromq development files
libgnuradio-zeromq3-3.8.0.0-6.mga8.i586.rpm GnuRadio zeromq
libgnusocialapihelper1-1.7.0-2.mga8.i586.rpm choqok library
libgnustep-base-devel-1.26.0-2.mga8.i586.rpm Header of the GNUstep Base library packes
libgnustep-base1.26-1.26.0-2.mga8.i586.rpm GNUStep Base Libraries
libgnustep-gui-devel-0.27.0-2.mga8.i586.rpm Header files for the gnustep-gui package
libgnustep-gui0.27-0.27.0-2.mga8.i586.rpm Libraries for gnustep-gui
libgnutls-devel-3.6.11-1.mga8.i586.rpm Development files for gnutls
Advertisement
Advertisement