libgvnc1.0-devel-0.9.0-3.mga7.i586.rpm


Advertisement

Description

libgvnc1.0-devel - Header files for core library of gtk-vnc

Property Value
Distribution Mageia Cauldron
Repository Mageia Core i586
Package filename libgvnc1.0-devel-0.9.0-3.mga7.i586.rpm
Package name libgvnc1.0-devel
Package version 0.9.0
Package release 3.mga7
Package architecture i586
Package type rpm
Category Development/C
Homepage http://gtk-vnc.sourceforge.net/
License LGPLv2+
Maintainer -
Download size 29.19 KB
Installed size 196.67 KB
Development files for core library of gtk-vnc.

Alternatives

Package Version Architecture Repository
libgvnc1.0-devel - - -

Requires

Name Value
devel(libgcrypt) -
devel(libgdk_pixbuf-2.0) -
devel(libgio-2.0) -
devel(libglib-2.0) -
devel(libgnutls) -
devel(libgobject-2.0) -
devel(libgvnc-1.0) -
devel(libpulse) -
devel(libpulse-simple) -
devel(libsasl2) -
devel(libz) -
libgvnc-gir1.0 == 0.9.0-3.mga7
libgvnc1.0_0 == 0.9.0-3.mga7
pkgconfig -
pkgconfig(gobject-2.0) >= 2.42.0
pkgconfig(gvnc-1.0) == 0.9.0

Provides

Name Value
devel(libgvnc-1.0) -
devel(libgvncpulse-1.0) -
libgvnc1.0-devel == 0.9.0-3.mga7
libgvnc1.0-devel(x86-32) == 0.9.0-3.mga7
pkgconfig(gvnc-1.0) == 0.9.0
pkgconfig(gvncpulse-1.0) == 0.9.0

Download

Type URL
Mirror distrib-coffee.ipsl.jussieu.fr
Binary Package libgvnc1.0-devel-0.9.0-3.mga7.i586.rpm
Source Package gtk-vnc-0.9.0-3.mga7.src.rpm

Install Howto

  1. Enable Mageia Core repository on Install and Remove Software
  2. Update packages list:
    # urpmi.update -a
  3. Install libgvnc1.0-devel rpm package:
    # urpmi libgvnc1.0-devel

Files

Path
/usr/include/gvnc-1.0/gvnc.h
/usr/include/gvnc-1.0/vncaudio.h
/usr/include/gvnc-1.0/vncaudioformat.h
/usr/include/gvnc-1.0/vncaudiosample.h
/usr/include/gvnc-1.0/vncbaseaudio.h
/usr/include/gvnc-1.0/vncbaseframebuffer.h
/usr/include/gvnc-1.0/vnccolormap.h
/usr/include/gvnc-1.0/vncconnection.h
/usr/include/gvnc-1.0/vncconnectionenums.h
/usr/include/gvnc-1.0/vnccursor.h
/usr/include/gvnc-1.0/vncframebuffer.h
/usr/include/gvnc-1.0/vncpixelformat.h
/usr/include/gvnc-1.0/vncutil.h
/usr/include/gvncpulse-1.0/gvncpulse.h
/usr/include/gvncpulse-1.0/vncaudiopulse.h
/usr/lib/libgvnc-1.0.so
/usr/lib/libgvncpulse-1.0.so
/usr/lib/pkgconfig/gvnc-1.0.pc
/usr/lib/pkgconfig/gvncpulse-1.0.pc
/usr/share/gir-1.0/GVnc-1.0.gir
/usr/share/gir-1.0/GVncPulse-1.0.gir
/usr/share/vala/vapi/gvnc-1.0.deps
/usr/share/vala/vapi/gvnc-1.0.vapi
/usr/share/vala/vapi/gvncpulse-1.0.deps
/usr/share/vala/vapi/gvncpulse-1.0.vapi

Changelog

2018-09-04 - tv <tv> 0.9.0-3.mga7
(not released yet)
+ Revision: 1257142
- Fix gvnc-1.0.pc file version dep
2018-08-28 - tv <tv> 0.9.0-2.mga7
+ Revision: 1255261
- Fix crash if connection fails early (rhbz#1620203)
2018-08-19 - tv <tv> 0.9.0-1.mga7
+ Revision: 1252839
- new release
2018-08-02 - daviddavid <daviddavid> 0.8.0-1.mga7
+ Revision: 1246807
- new version: 0.8.0
- deleted the python2 binding in favour of GObject introspection (upstream)
2018-05-09 - tv <tv> 0.7.2-2.mga7
+ Revision: 1227863
- rename python-gtk-vnc as python2-gtk-vnc
2018-03-29 - tv <tv> 0.7.2-1.mga7
+ Revision: 1213396
- BR pulseaudio-devel & uncomment gvncpulse
- new release
2017-02-10 - mrambo3501 <mrambo3501> 0.6.0-3.mga6
+ Revision: 1085640
- Add upstream patches which fix CVE-2017-5884 and CVE-2017-5885
Add patch to fix the connection test code based upon upstream code
- Add upstream patches which fix CVE-2017-5884 and CVE-2017-5885
Add patch to fix the connection test code based upon upstream code
2016-09-26 - tv <tv> 0.6.0-2.mga6
+ Revision: 1056886
- rebuild with fixed rpm-mageia-setup for missing generating typelib() requires (mga#19454)
2016-09-18 - ovitters <ovitters> 0.6.0-1.mga6
+ Revision: 1053842
- new version 0.6.0
2016-01-11 - luigiwalser <luigiwalser> 0.5.4-5.mga6
+ Revision: 921915
- add patch to fix python linking error
- rebuild for gnutls

See Also

Package Description
libgvnc1.0_0-0.9.0-3.mga7.i586.rpm Core library for gtk-vnc
libgvpr2-2.40.1-17.mga7.i586.rpm Shared library for graphviz
libgweather-3.32.1-2.mga7.i586.rpm GNOME Weather applet library
libgweather-devel-3.32.1-2.mga7.i586.rpm GNOME Weather applet library
libgweather-gir3.0-3.32.1-2.mga7.i586.rpm GObject Introspection interface description for libgweather
libgweather3_15-3.32.1-2.mga7.i586.rpm GNOME Weather applet library
libgwengui-cpp0-4.20.0-3.mga7.i586.rpm A multi-platform helper library for other libraries
libgwengui-gtk2_0-4.20.0-3.mga7.i586.rpm A GTK multi-platform helper library for other libraries
libgwengui-qt4_0-4.20.0-3.mga7.i586.rpm A Qt4 multi-platform helper library for other libraries
libgwengui-qt5_0-4.20.0-3.mga7.i586.rpm A Qt5 multi-platform helper library for other libraries
libgwenhywfar-devel-4.20.0-3.mga7.i586.rpm Gwenhywfar development kit
libgwenhywfar60-4.20.0-3.mga7.i586.rpm A multi-platform helper library for other libraries
libgwenviewlib5-19.04.0-2.mga7.i586.rpm Gwenview library
libgxps-devel-0.3.1-2.mga7.i586.rpm Development libraries, header files and utilities for libgxps
libgxps-gir0.1-0.3.1-2.mga7.i586.rpm GObject Introspection interface library for libgxps
Advertisement
Advertisement