libncursesw6-6.1-20190817.1.mga8.i586.rpm


Advertisement

Description

libncursesw6 - Ncurses libraries which support UTF8

Property Value
Distribution Mageia Cauldron
Repository Mageia Core i586
Package filename libncursesw6-6.1-20190817.1.mga8.i586.rpm
Package name libncursesw6
Package version 6.1
Package release 20190817.1.mga8
Package architecture i586
Package type rpm
Category System/Libraries
Homepage http://www.gnu.org/software/ncurses/ncurses.html
License MIT
Maintainer -
Download size 184.63 KB
Installed size 487.65 KB
The curses library routines are a terminal-independent method of updating
character screens with reasonalble optimization. The ncurses (new curses)
library is a freely distributable replacement for the discontinued 4.4BSD
classic curses library.
This package contains ncurses libraries which support wide char (UTF8),
and is not compatible with those without.

Alternatives

Package Version Architecture Repository
libncursesw6 - - -

Requires

Name Value
filesystem >= 2.1.9-18
libc.so.6 -
libc.so.6(GLIBC_2.0) -
libc.so.6(GLIBC_2.1) -
libc.so.6(GLIBC_2.1.3) -
libc.so.6(GLIBC_2.2) -
libc.so.6(GLIBC_2.3) -
libc.so.6(GLIBC_2.3.4) -
libc.so.6(GLIBC_2.4) -
libc.so.6(GLIBC_2.7) -
libdl.so.2 -
libdl.so.2(GLIBC_2.0) -
libdl.so.2(GLIBC_2.1) -
libformw.so.6 -
libgcc_s.so.1 -
libgcc_s.so.1(GCC_3.0) -
libmenuw.so.6 -
libncursesw.so.6 -
libpanelw.so.6 -
libstdc++.so.6 -
libstdc++.so.6(CXXABI_1.3) -
libstdc++.so.6(CXXABI_1.3.8) -
libstdc++.so.6(CXXABI_1.3.9) -
libstdc++.so.6(GLIBCXX_3.4) -
libstdc++.so.6(GLIBCXX_3.4.9) -
libtinfo.so.6 -

Provides

Name Value
libformw.so.6 -
libmenuw.so.6 -
libncurses++w.so.6 -
libncursesw.so.6 -
libncursesw6 == 6.1-20190817.1.mga8
libncursesw6(x86-32) == 6.1-20190817.1.mga8
libpanelw.so.6 -

Download

Type URL
Mirror distrib-coffee.ipsl.jussieu.fr
Binary Package libncursesw6-6.1-20190817.1.mga8.i586.rpm
Source Package ncurses-6.1-20190817.1.mga8.src.rpm

Install Howto

  1. Enable Mageia Core repository on Install and Remove Software
  2. Update packages list:
    # urpmi.update -a
  3. Install libncursesw6 rpm package:
    # urpmi libncursesw6

Files

Path
/usr/lib/libformw.so.6
/usr/lib/libformw.so.6.1
/usr/lib/libmenuw.so.6
/usr/lib/libmenuw.so.6.1
/usr/lib/libncurses++w.so.6
/usr/lib/libncurses++w.so.6.1
/usr/lib/libncursesw.so.6
/usr/lib/libncursesw.so.6.1
/usr/lib/libpanelw.so.6
/usr/lib/libpanelw.so.6.1
/usr/lib/.build-id/
/usr/lib/.build-id/10/805548f0cc2d690ee652878ef6fc59ab4fdc8e
/usr/lib/.build-id/1a/727e18ead2dbe1d644dc53cb456f0c4beb9e95
/usr/lib/.build-id/5e/87abf6e1039befadb558c57f3d926f715a87cb
/usr/lib/.build-id/b6/4c5f79baaf58a0e2fcdb142d18d04013bfb4d2
/usr/lib/.build-id/f1/6cd2b403d4ae1f26b7d221750f9dd2c118558f

Changelog

2019-08-25 - wally <wally> 6.1-20190817.1.mga8
+ Revision: 1432094
- new version 6.1-20190817
2018-12-01 - wally <wally> 6.1-20181117.3.mga7
+ Revision: 1337082
- drop --disable-relink configure switch
- install wide-character versions of libtinfo and libtic
- drop static build
- don't strip binaries
2018-11-25 - wally <wally> 6.1-20181117.2.mga7
+ Revision: 1334185
- disable shared lib relinking during install (when building the pkg)
2018-11-25 - daviddavid <daviddavid> 6.1-20181117.1.mga7
+ Revision: 1333979
- new version 6.1-20181117
2018-09-23 - umeabot <umeabot> 6.1-20180728.2.mga7
+ Revision: 1299686
- Mageia 7 Mass Rebuild
2018-08-04 - wally <wally> 6.1-20180728.1.mga7
+ Revision: 1247246
- new version 6.1-20180728
2018-05-28 - wally <wally> 6.1-20180526.1.mga7
+ Revision: 1232790
- update to 6.1-20180526
2018-04-12 - kekepower <kekepower> 6.1-20180407.1.mga7
+ Revision: 1218021
- Update to 6.1-20180407
- Fix make commands
2018-03-18 - joequant <joequant> 6.1-20180317.1.mga7
+ Revision: 1210288
- upgrade to 6.1
+ wally <wally>
- fix also ncursesw devel provides on aarch64
2018-02-27 - wally <wally> 6.0-20171223.4.mga7
+ Revision: 1205482
- fix devel pkg provides on aarch64

See Also

Package Description
libndctl-devel-63-3.mga7.i586.rpm Development files for libndctl
libndctl6-63-3.mga7.i586.rpm Management library for "libnvdimm" subsystem devices (Non-volatile Memory)
libndp-devel-1.6-3.mga7.i586.rpm Libraries and header files for libndp development
libndp0-1.6-3.mga7.i586.rpm Library for Neighbor Discovery Protocol
libndpi-devel-2.6-1.mga7.i586.rpm Header files and libraries for developing applications for nDPI
libndpi-static-devel-2.6-1.mga7.i586.rpm Open source deep packet inspection static library
libndpi2-2.6-1.mga7.i586.rpm Open source deep packet inspection library
libnemo-devel-4.2.3-1.mga8.i586.rpm Support for developing nemo extensions
libnemo-extension-4.2.3-1.mga8.i586.rpm Nemo extensions library
libnemo-gir3.0-4.2.3-1.mga8.i586.rpm GObject Introspection interface description for nemo
libneon-devel-0.30.2-2.mga7.i586.rpm Headers for developing programs that will use libneon
libneon-i18n-0.30.2-2.mga7.noarch.rpm Internationalization and locale data for libneon
libneon-static-devel-0.30.2-2.mga7.i586.rpm Static libneon library
libneon27-0.30.2-2.mga7.i586.rpm Shared libraries for libneon
libnet-devel-1.1.6-8.mga7.i586.rpm Development library and header files for the libnet library
Advertisement
Advertisement