libopenssl-static-devel-1.1.1c-1.mga8.i586.rpm


Advertisement

Description

libopenssl-static-devel - Secure Sockets Layer communications static libs

Property Value
Distribution Mageia Cauldron
Repository Mageia Core i586
Package filename libopenssl-static-devel-1.1.1c-1.mga8.i586.rpm
Package name libopenssl-static-devel
Package version 1.1.1c
Package release 1.mga8
Package architecture i586
Package type rpm
Category Development/Other
Homepage http://www.openssl.org/
License BSD-like
Maintainer -
Download size 6.77 MB
Installed size 13.48 MB
The static libraries needed to compile apps with support for various
cryptographic algorithms and protocols, including DES, RC4, RSA and SSL.

Alternatives

Package Version Architecture Repository
libopenssl-static-devel - - -

Requires

Name Value
libopenssl-devel == 1.1.1c-1.mga8

Provides

Name Value
libopenssl-static-devel -
libopenssl-static-devel == 1.1.1c-1.mga8
libopenssl-static-devel(x86-32) == 1.1.1c-1.mga8
openssl-static-devel == 1.1.1c-1.mga8

Obsoletes

Name Value
libopenssl1.0.0-static-devel -

Download

Type URL
Mirror distrib-coffee.ipsl.jussieu.fr
Binary Package libopenssl-static-devel-1.1.1c-1.mga8.i586.rpm
Source Package openssl-1.1.1c-1.mga8.src.rpm

Install Howto

  1. Enable Mageia Core repository on Install and Remove Software
  2. Update packages list:
    # urpmi.update -a
  3. Install libopenssl-static-devel rpm package:
    # urpmi libopenssl-static-devel

Files

Path
/usr/lib/libcrypto.a
/usr/lib/libssl.a

Changelog

2019-08-24 - guillomovitch <guillomovitch> 1.1.1c-1.mga8
+ Revision: 1431659
- new version 1.1.1
- sync patch set with Fedora
- drop unappliable patch#6 (Brazilian government OTHERNAME X509v3 field)
- add sctp support
2018-11-22 - ns80 <ns80> 1.1.0j-1.mga7
+ Revision: 1333303
- new version 1.1.0j for CVE-2018-073[45] and CVE-2018-5407 (mga#23870)
2018-09-03 - ns80 <ns80> 1.1.0i-3.mga7
+ Revision: 1256516
- disable tests for i586 as it fails on BS
- new version 1.1.0i for CVE-2018-073[27] (mga#22934)
2018-05-13 - wally <wally> 1.1.0h-2.mga7
+ Revision: 1228710
- add patch from upstream to fix missing quotes in c_rehash (mga#23024)
2018-03-31 - luigiwalser <luigiwalser> 1.1.0h-1.mga7
+ Revision: 1213922
- 1.1.0h
- rediff patches 32, 39, and 40 (from fedora)
2018-03-02 - daviddavid <daviddavid> 1.1.0g-3.mga7
+ Revision: 1206027
- fix more dangling link (mga#22666)
2018-02-25 - daviddavid <daviddavid> 1.1.0g-2.mga7
+ Revision: 1204885
- fix dangling link (mga#22228)
2017-11-05 - luigiwalser <luigiwalser> 1.1.0g-1.mga7
+ Revision: 1176041
- 1.1.0g
- rediff patches 1, 23, 36, and 38
- remove upstreamed patches 43, 70, and 71
- do not enable sctp

See Also

Package Description
libopenssl1.1-1.1.1c-1.mga8.i586.rpm Secure Sockets Layer communications libs
libopensubdiv-devel-3.3.3-6.mga7.i586.rpm Development files for the OpenSubdiv library
libopensubdiv-static-devel-3.3.3-6.mga7.i586.rpm Static libraries for linking to OpenSubdiv
libopensubdiv3-3.3.3-6.mga7.i586.rpm High performance subdivision surface libraries
libopenthreads-devel-3.6.3-1.mga7.i586.rpm Development package for OpenThreads
libopenthreads20-3.4.1-8.mga7.i586.rpm A lightweight C++ thread API
libopenthreads21-3.6.3-1.mga7.i586.rpm A lightweight C++ thread API
libopenthreads34-devel-3.4.1-8.mga7.i586.rpm Development package for OpenThreads
libopenvas-devel-10.0.0-1.mga8.i586.rpm Development files for openvas-libraries
libopenvas10-10.0.0-1.mga8.i586.rpm Support libraries for Open Vulnerability Assessment (OpenVAS) Server
libopenvdb-devel-6.2.1-1.mga8.i586.rpm Development files for openvdb
libopenvdb6.2-6.2.1-1.mga8.i586.rpm Core OpenVDB libraries
libopenvpn-devel-2.4.7-1.mga7.i586.rpm Development package for OpenVPN plugins
libopenzwave-devel-1.2.919-3.mga7.i586.rpm Open-ZWave header files
libopenzwave1-1.2.919-3.mga7.i586.rpm Shared Open-ZWave library
Advertisement
Advertisement