libpackagekit-devel-1.1.12-3.mga7.i586.rpm


Advertisement

Description

libpackagekit-devel - Libraries and headers for PackageKit

Property Value
Distribution Mageia Cauldron
Repository Mageia Core i586
Package filename libpackagekit-devel-1.1.12-3.mga7.i586.rpm
Package name libpackagekit-devel
Package version 1.1.12
Package release 3.mga7
Package architecture i586
Package type rpm
Category Development/Other
Homepage http://www.packagekit.org
License GPLv2+
Maintainer -
Download size 87.74 KB
Installed size 1.19 MB
Headers and libraries for PackageKit.

Alternatives

Package Version Architecture Repository
libpackagekit-devel - - -

Requires

Name Value
devel(libgio-2.0) -
devel(libglib-2.0) -
devel(libgobject-2.0) -
libpackagekit-glib18 == 1.1.12-3.mga7
libpackagekitglib-gir1.0 == 1.1.12-3.mga7
pkgconfig -
pkgconfig(glib-2.0) -
pkgconfig(gobject-2.0) -
pkgconfig(gthread-2.0) -
pkgconfig(sqlite3) -

Provides

Name Value
devel(libpackagekit-glib2) -
libpackagekit-devel == 1.1.12-3.mga7
libpackagekit-devel(x86-32) == 1.1.12-3.mga7
packagekit-devel == 1.1.12-3.mga7
pkgconfig(packagekit-glib2) == 1.1.12

Conflicts

Name Value
libpackagekit-glib14 < 0.6.17-2

Download

Type URL
Mirror distrib-coffee.ipsl.jussieu.fr
Binary Package libpackagekit-devel-1.1.12-3.mga7.i586.rpm
Source Package packagekit-1.1.12-3.mga7.src.rpm

Install Howto

  1. Enable Mageia Core repository on Install and Remove Software
  2. Update packages list:
    # urpmi.update -a
  3. Install libpackagekit-devel rpm package:
    # urpmi libpackagekit-devel

Files

Path
/usr/include/PackageKit/
/usr/include/PackageKit/packagekit-glib2/packagekit.h
/usr/include/PackageKit/packagekit-glib2/pk-bitfield.h
/usr/include/PackageKit/packagekit-glib2/pk-category.h
/usr/include/PackageKit/packagekit-glib2/pk-client-helper.h
/usr/include/PackageKit/packagekit-glib2/pk-client-sync.h
/usr/include/PackageKit/packagekit-glib2/pk-client.h
/usr/include/PackageKit/packagekit-glib2/pk-common.h
/usr/include/PackageKit/packagekit-glib2/pk-control-sync.h
/usr/include/PackageKit/packagekit-glib2/pk-control.h
/usr/include/PackageKit/packagekit-glib2/pk-desktop.h
/usr/include/PackageKit/packagekit-glib2/pk-details.h
/usr/include/PackageKit/packagekit-glib2/pk-distro-upgrade.h
/usr/include/PackageKit/packagekit-glib2/pk-enum-types.h
/usr/include/PackageKit/packagekit-glib2/pk-enum.h
/usr/include/PackageKit/packagekit-glib2/pk-error.h
/usr/include/PackageKit/packagekit-glib2/pk-eula-required.h
/usr/include/PackageKit/packagekit-glib2/pk-files.h
/usr/include/PackageKit/packagekit-glib2/pk-item-progress.h
/usr/include/PackageKit/packagekit-glib2/pk-media-change-required.h
/usr/include/PackageKit/packagekit-glib2/pk-offline.h
/usr/include/PackageKit/packagekit-glib2/pk-package-id.h
/usr/include/PackageKit/packagekit-glib2/pk-package-ids.h
/usr/include/PackageKit/packagekit-glib2/pk-package-sack-sync.h
/usr/include/PackageKit/packagekit-glib2/pk-package-sack.h
/usr/include/PackageKit/packagekit-glib2/pk-package.h
/usr/include/PackageKit/packagekit-glib2/pk-progress.h
/usr/include/PackageKit/packagekit-glib2/pk-repo-detail.h
/usr/include/PackageKit/packagekit-glib2/pk-repo-signature-required.h
/usr/include/PackageKit/packagekit-glib2/pk-require-restart.h
/usr/include/PackageKit/packagekit-glib2/pk-results.h
/usr/include/PackageKit/packagekit-glib2/pk-source.h
/usr/include/PackageKit/packagekit-glib2/pk-task-sync.h
/usr/include/PackageKit/packagekit-glib2/pk-task.h
/usr/include/PackageKit/packagekit-glib2/pk-transaction-list.h
/usr/include/PackageKit/packagekit-glib2/pk-transaction-past.h
/usr/include/PackageKit/packagekit-glib2/pk-update-detail.h
/usr/include/PackageKit/packagekit-glib2/pk-version.h
/usr/lib/libpackagekit-glib2.so
/usr/lib/pkgconfig/packagekit-glib2.pc
/usr/share/gir-1.0/PackageKitGlib-1.0.gir
/usr/share/vala/vapi/packagekit-glib2.vapi

Changelog

2019-05-05 - ngompa <ngompa> 1.1.12-3.mga7
+ Revision: 1396400
- Backport patch to mark aarch64 repos as supported and drop marking armv5tl repos as supported
2019-04-01 - ngompa <ngompa> 1.1.12-2.mga7
+ Revision: 1384547
- Backport fix to support reading system-release(releasever) Provides from mageia-release on offline upgrades
2018-12-29 - luigiwalser <luigiwalser> 1.1.12-1.mga7
+ Revision: 1345913
- 1.1.12
- add upstream patch via fedora
2018-10-16 - ngompa <ngompa> 1.1.11-1.mga7
+ Revision: 1320752
- Update to 1.1.11 and drop backported fixes
2018-09-13 - tmb <tmb> 1.1.10-3.mga7
+ Revision: 1258905
- fix build with newer libdnf
2018-06-30 - ngompa <ngompa> 1.1.10-2.mga7
+ Revision: 1240923
- Fix libdnf runtime dependency
2018-06-30 - ngompa <ngompa> 1.1.10-1.mga7
+ Revision: 1240922
- Update to 1.1.10
- Backport patches from upstream for compiling with libdnf 0.15.0+
- Fix typo in Provides for "PackageKit" name
2018-03-23 - kekepower <kekepower> 1.1.9-1.mga7
+ Revision: 1211475
- Update to version 1.1.9
- Remove merged patch
2017-06-15 - ngompa <ngompa> 1.1.6-2.mga6
+ Revision: 1107735
- Add patch to fix metadata refresh to stop crashes (rhbz#1460825)
2017-06-08 - ngompa <ngompa> 1.1.6-1.mga6
+ Revision: 1107267
- Update to v1.1.6

See Also

Package Description
libpackagekit-glib18-1.1.12-3.mga7.i586.rpm Libraries for accessing PackageKit
libpackagekit-qt5-devel-1.0.1-3.mga7.i586.rpm Libraries and headers for PackageKit-Qt5
libpackagekitglib-gir1.0-1.1.12-3.mga7.i586.rpm GObject Introspection interface description for PackageKit
libpackagekitqt5_1-1.0.1-3.mga7.i586.rpm Libraries for accessing PackageKit-Qt5
libpadthv10-0.9.7-1.mga7.i586.rpm Synthesizer library for padthv1
libpagemaker-devel-0.0.4-2.mga7.i586.rpm Development files for libpagemaker
libpagemaker-doc-0.0.4-2.mga7.noarch.rpm Documentation of libpagemaker API
libpagemaker-tools-0.0.4-2.mga7.i586.rpm Tools to transform Adobe PageMaker documents into other formats
libpagemaker0-0.0.4-2.mga7.i586.rpm A library for import of Adobe PageMaker documents
libpala0-19.04.0-1.mga7.i586.rpm Runtime library for Palapeli
libpam-devel-1.3.1-1.mga7.i586.rpm Development headers and libraries for pam
libpam0-1.3.1-1.mga7.i586.rpm Libraries for pam
libpam4j-1.8-10.mga7.noarch.rpm Java binding for libpam.so
libpam4j-javadoc-1.8-10.mga7.noarch.rpm Javadoc for libpam4j
libpam_userpass-devel-1.0.2-14.mga7.i586.rpm Libraries and header files for developing pam_userpass-aware applications
Advertisement
Advertisement