libpam-devel-1.3.1-2.mga8.i586.rpm


Advertisement

Description

libpam-devel - Development headers and libraries for pam

Property Value
Distribution Mageia Cauldron
Repository Mageia Core i586
Package filename libpam-devel-1.3.1-2.mga8.i586.rpm
Package name libpam-devel
Package version 1.3.1
Package release 2.mga8
Package architecture i586
Package type rpm
Category Development/Other
Homepage http://www.linux-pam.org/
License BSD and GPLv2+
Maintainer -
Download size 76.02 KB
Installed size 99.73 KB
PAM (Pluggable Authentication Modules) is a system security tool that
allows system administrators to set authentication policy without
having to recompile programs that handle authentication.
This package contains the development librairies for pam.

Alternatives

Package Version Architecture Repository
libpam-devel - - -

Requires

Name Value
devel(libaudit) -
devel(libdl) -
devel(libpam) -
filesystem >= 2.1.9-18
libpam0 == 1.3.1

Provides

Name Value
devel(libpam) -
devel(libpam_misc) -
devel(libpamc) -
libpam-devel == 1.3.1-2.mga8
libpam-devel(x86-32) == 1.3.1-2.mga8
pam-devel == 1.3.1-2.mga8

Download

Type URL
Mirror distrib-coffee.ipsl.jussieu.fr
Binary Package libpam-devel-1.3.1-2.mga8.i586.rpm
Source Package pam-1.3.1-2.mga8.src.rpm

Install Howto

  1. Enable Mageia Core repository on Install and Remove Software
  2. Update packages list:
    # urpmi.update -a
  3. Install libpam-devel rpm package:
    # urpmi libpam-devel

Files

Path
/usr/include/security/_pam_compat.h
/usr/include/security/_pam_macros.h
/usr/include/security/_pam_types.h
/usr/include/security/pam_appl.h
/usr/include/security/pam_client.h
/usr/include/security/pam_ext.h
/usr/include/security/pam_filter.h
/usr/include/security/pam_misc.h
/usr/include/security/pam_modules.h
/usr/include/security/pam_modutil.h
/usr/lib/libpam.so
/usr/lib/libpam_misc.so
/usr/lib/libpamc.so
/usr/share/doc/libpam-devel/Copyright
/usr/share/man/man3/misc_conv.3.xz
/usr/share/man/man3/pam.3.xz
/usr/share/man/man3/pam_acct_mgmt.3.xz
/usr/share/man/man3/pam_authenticate.3.xz
/usr/share/man/man3/pam_chauthtok.3.xz
/usr/share/man/man3/pam_close_session.3.xz
/usr/share/man/man3/pam_conv.3.xz
/usr/share/man/man3/pam_end.3.xz
/usr/share/man/man3/pam_error.3.xz
/usr/share/man/man3/pam_fail_delay.3.xz
/usr/share/man/man3/pam_get_authtok.3.xz
/usr/share/man/man3/pam_get_authtok_noverify.3.xz
/usr/share/man/man3/pam_get_authtok_verify.3.xz
/usr/share/man/man3/pam_get_data.3.xz
/usr/share/man/man3/pam_get_item.3.xz
/usr/share/man/man3/pam_get_user.3.xz
/usr/share/man/man3/pam_getenv.3.xz
/usr/share/man/man3/pam_getenvlist.3.xz
/usr/share/man/man3/pam_info.3.xz
/usr/share/man/man3/pam_misc_drop_env.3.xz
/usr/share/man/man3/pam_misc_paste_env.3.xz
/usr/share/man/man3/pam_misc_setenv.3.xz
/usr/share/man/man3/pam_open_session.3.xz
/usr/share/man/man3/pam_prompt.3.xz
/usr/share/man/man3/pam_putenv.3.xz
/usr/share/man/man3/pam_set_data.3.xz
/usr/share/man/man3/pam_set_item.3.xz
/usr/share/man/man3/pam_setcred.3.xz
/usr/share/man/man3/pam_sm_acct_mgmt.3.xz
/usr/share/man/man3/pam_sm_authenticate.3.xz
/usr/share/man/man3/pam_sm_chauthtok.3.xz
/usr/share/man/man3/pam_sm_close_session.3.xz
/usr/share/man/man3/pam_sm_open_session.3.xz
/usr/share/man/man3/pam_sm_setcred.3.xz
/usr/share/man/man3/pam_start.3.xz
/usr/share/man/man3/pam_strerror.3.xz
/usr/share/man/man3/pam_syslog.3.xz
/usr/share/man/man3/pam_verror.3.xz
/usr/share/man/man3/pam_vinfo.3.xz
/usr/share/man/man3/pam_vprompt.3.xz
/usr/share/man/man3/pam_vsyslog.3.xz
/usr/share/man/man3/pam_xauth_data.3.xz

Changelog

2019-08-06 - wally <wally> 1.3.1-2.mga8
+ Revision: 1427766
- build pam_userdb.so (mga#25226)
- drop some trailing spaces
2018-12-29 - luigiwalser <luigiwalser> 1.3.1-1.mga7
+ Revision: 1346262
- limit documentation included in the package
- fix generation of faillock docs
- 1.3.1
- update pam-redhat to 1.0.0
- update URLs
- rediff patch 521
- install /var/log/tallylog and /run/motd via tmpfiles
- add pam_umask.so to postlogin
- remove patches 4, 5, 701 (fixed upstream)
- rediffed patches 1 and 9 from fedora
- add various upstream patches via fedora
- disable patch 37 which changes hash id for blowfish
- pam_tally2 is obsolete
- add /etc/motd.d and /usr/lib/motd.d directories
2018-09-06 - tv <tv> 1.3.0-8.mga7
+ Revision: 1257540
- remove useless "Requires(pre): rpm-helper"
2018-08-12 - tmb <tmb> 1.3.0-7.mga7
+ Revision: 1251145
- switch to libxcrypt
2017-09-05 - tv <tv> 1.3.0-6.mga7
+ Revision: 1151455
- rebuild without db5_nss-devel

See Also

Package Description
libpam0-1.3.1-2.mga8.i586.rpm Libraries for pam
libpam4j-1.8-10.mga7.noarch.rpm Java binding for libpam.so
libpam4j-javadoc-1.8-10.mga7.noarch.rpm Javadoc for libpam4j
libpam_userpass-devel-1.0.2-14.mga7.i586.rpm Libraries and header files for developing pam_userpass-aware applications
libpam_userpass1-1.0.2-14.mga7.i586.rpm PAM module for USER/PASS-style protocols
libpango-gir1.0-1.44.6-1.mga8.i586.rpm GObject Introspection interface description for pango
libpango1.0-devel-1.44.6-1.mga8.i586.rpm System for layout and rendering of internationalized text
libpango1.0_0-1.44.6-1.mga8.i586.rpm System for layout and rendering of internationalized text
libpangomm1.4-devel-2.42.0-1.mga7.i586.rpm Headers and development files of pangomm1.4
libpangomm1.4-static-devel-2.42.0-1.mga7.i586.rpm Static libraries of pangomm1.4
libpangomm1.4_1-2.42.0-1.mga7.i586.rpm C++ interface for the pango library
libpangomm2.44-devel-2.43.1-3.mga8.i586.rpm Headers and development files of pangomm
libpangomm2.44_1-2.43.1-3.mga8.i586.rpm C++ interface for the pango library
libpangox-devel-0.0.2-7.mga7.i586.rpm Compatibility library providing the obsolete pangox library
libpangox1.0_0-0.0.2-7.mga7.i586.rpm Compatibility library providing the obsolete pangox library
Advertisement
Advertisement