libpng-devel-1.6.34-1.mga7.i586.rpm


Advertisement

Description

libpng-devel - Development tools for programs to manipulate PNG image format files

Property Value
Distribution Mageia Cauldron
Repository Mageia Core i586
Package name libpng-devel
Package version 1.6.34
Package release 1.mga7
Package architecture i586
Package type rpm
Installed size 1.03 MB
Download size 282.88 KB
Official Mirror distrib-coffee.ipsl.jussieu.fr
The libpng-devel package contains the header files and libraries
necessary for developing programs using the PNG (Portable Network
Graphics) library.
If you want to develop programs which will manipulate PNG image format
files, you should install libpng-devel.  You'll also need to install the
libpng package.

Alternatives

Package Version Architecture Repository
libpng-devel - - -

Requires

Name Value
devel(libm) -
devel(libz) -
libc.so.6 -
libc.so.6(GLIBC_2.0) -
libc.so.6(GLIBC_2.1) -
libc.so.6(GLIBC_2.11) -
libc.so.6(GLIBC_2.2) -
libc.so.6(GLIBC_2.3) -
libc.so.6(GLIBC_2.3.4) -
libc.so.6(GLIBC_2.4) -
libpng16.so.16 -
libpng16.so.16(PNG16_0) -
libpng16_16 == 2:1.6.34
libz.so.1 -
libz.so.1(ZLIB_1.2.3.4) -
multiarch-utils -
pkgconfig -
pkgconfig(zlib) -
zlib-devel -

Provides

Name Value
devel(libpng16) -
libpng-devel == 2:1.6.34-1.mga7
libpng-devel(x86-32) == 2:1.6.34-1.mga7
pkgconfig(libpng) == 1.6.34
pkgconfig(libpng16) == 1.6.34
png-devel == 2:1.6.34-1.mga7

Obsoletes

Name Value
libpng3-devel < 1.2.30

Download

Type URL
Binary Package libpng-devel-1.6.34-1.mga7.i586.rpm
Source Package libpng-1.6.34-1.mga7.src.rpm

Install Howto

  1. Enable Mageia Core repository on "Install and Remove Software"
  2. Update packages list:
    # urpmi.update -a
  3. Install libpng-devel rpm package:
    # urpmi libpng-devel

Files

Path
/usr/bin/libpng-config
/usr/bin/libpng16-config
/usr/bin/png-fix-itxt
/usr/bin/pngfix
/usr/bin/multiarch-i386-linux/libpng16-config
/usr/include/png.h
/usr/include/pngconf.h
/usr/include/pnglibconf.h
/usr/include/libpng16/png.h
/usr/include/libpng16/pngconf.h
/usr/include/libpng16/pnglibconf.h
/usr/lib/libpng.so
/usr/lib/libpng16.so
/usr/lib/.build-id/
/usr/lib/.build-id/03/024c1d8f9759cae3a4d6216dac7d0f4043ee1b
/usr/lib/.build-id/be/86ba3b067ee63c271e287f396aa27e4fe238d7
/usr/lib/pkgconfig/libpng.pc
/usr/lib/pkgconfig/libpng16.pc
/usr/share/doc/libpng-devel/CHANGES
/usr/share/doc/libpng-devel/README
/usr/share/doc/libpng-devel/TODO
/usr/share/doc/libpng-devel/example.c
/usr/share/doc/libpng-devel/libpng-manual.txt
/usr/share/man/man3/libpng.3.xz
/usr/share/man/man3/libpngpf.3.xz
/usr/share/man/man5/png.5.xz

Changelog

2017-10-28 - tv <tv> 2:1.6.34-1.mga7
+ Revision: 1174349
- new release
2017-03-26 - akien <akien> 2:1.6.29-1.mga6
+ Revision: 1094889
- Version 1.6.29
2017-03-24 - akien <akien> 2:1.6.28-1.mga6
+ Revision: 1094709
- Version 1.6.28
2016-12-29 - tv <tv> 2:1.6.27-1.mga6
+ Revision: 1078607
- 1.6.27
2016-11-02 - luigiwalser <luigiwalser> 2:1.6.26-1.mga6
+ Revision: 1064761
- 1.6.26
2016-09-23 - luigiwalser <luigiwalser> 2:1.6.25-1.mga6
+ Revision: 1055588
- 1.6.25
2016-08-18 - luigiwalser <luigiwalser> 2:1.6.24-1.mga6
+ Revision: 1046920
- 1.6.24
2016-06-03 - luigiwalser <luigiwalser> 2:1.6.22-1.mga6
+ Revision: 1020136
- 1.6.22
2016-01-25 - luigiwalser <luigiwalser> 2:1.6.21-1.mga6
+ Revision: 927167
- 1.6.21
2015-12-07 - luigiwalser <luigiwalser> 2:1.6.20-1.mga6
+ Revision: 908674
- 1.6.20 (fixes CVE-2015-8472)

See Also

Package Description
libpng12-devel-1.2.57-2.mga6.i586.rpm Development tools for programs to manipulate PNG image format files
libpng12_0-1.2.57-2.mga6.i586.rpm A library of functions for manipulating PNG image format files
libpng16_16-1.6.34-1.mga7.i586.rpm A library of functions for manipulating PNG image format files
libpnglite-devel-0.1.17-7.mga6.i586.rpm Files needed to build and link programs with pnglite
libpnglite0-0.1.17-7.mga6.i586.rpm A lightweight C library for loading PNG images
libpocketsphinx-devel-0.9-0.0.5prealpha.2.mga7.i586.rpm Header files for developing with pocketsphinx
libpocketsphinx3-0.9-0.0.5prealpha.2.mga7.i586.rpm Shared libraries for pocketsphinx executables
libpodofo-devel-0.9.6-0.r1855.3.mga7.i586.rpm Development files for podofo library
libpodofo0.9.6-0.9.6-0.r1855.3.mga7.i586.rpm Runtime library for podofo
libpoldiff1-3.3.8-15.mga6.i586.rpm Semantic policy difference library for SETools
libpolicycoreutils-devel-2.5-11.mga7.i586.rpm SELinux policy core policy devel utilities
libpolkit-gir1.0-0.114-1.mga7.i586.rpm GObject Introspection interface library for polkit
libpolkit-qt-agent-1_1-0.112.0-7.mga6.i586.rpm Polkit-Qt core library
libpolkit-qt-core-1_1-0.112.0-7.mga6.i586.rpm Polkit-Qt core library
libpolkit-qt-gui-1_1-0.112.0-7.mga6.i586.rpm Polkit-Qt core library
Advertisement
Advertisement