libqt5gui5-5.11.2-2.mga7.i586.rpm


Advertisement

Description

libqt5gui5 - Qt5 GUI Library

Property Value
Distribution Mageia Cauldron
Repository Mageia Core i586
Package name libqt5gui5
Package version 5.11.2
Package release 2.mga7
Package architecture i586
Package type rpm
Installed size 13.43 MB
Download size 2.14 MB
Official Mirror distrib-coffee.ipsl.jussieu.fr
Qt5 Component Library.
The QtGui module extends QtCore with GUI functionality.

Alternatives

Package Version Architecture Repository
libqt5gui5 - - -

Requires

Name Value
glxinfo -
libEGL.so.1 -
libGL.so.1 -
libQt5Core.so.5 -
libQt5Core.so.5(Qt_5) -
libQt5Core.so.5(Qt_5.11) -
libQt5Core.so.5(Qt_5_PRIVATE_API) -
libQt5DBus.so.5 -
libQt5DBus.so.5(Qt_5) -
libQt5EglFSDeviceIntegration.so.5 -
libQt5Gui.so.5 -
libQt5Gui.so.5(Qt_5) -
libQt5Gui.so.5(Qt_5_PRIVATE_API) -
libQt5Network.so.5 -
libQt5Network.so.5(Qt_5) -
libQt5XcbQpa.so.5 -
libQt5XcbQpa.so.5(Qt_5_PRIVATE_API) -
libX11.so.6 -
libc.so.6 -
libc.so.6(GLIBC_2.0) -
libc.so.6(GLIBC_2.1.3) -
libc.so.6(GLIBC_2.11) -
libc.so.6(GLIBC_2.2) -
libc.so.6(GLIBC_2.3.4) -
libc.so.6(GLIBC_2.4) -
libdl.so.2 -
libdl.so.2(GLIBC_2.0) -
libdrm.so.2 -
libfontconfig.so.1 -
libfreetype.so.6 -
libgcc_s.so.1 -
libgcc_s.so.1(GCC_3.4) -
libgcc_s.so.1(GCC_7.0.0) -
libgcc_s.so.1(GLIBC_2.0) -
libharfbuzz.so.0 -
libinput.so.10 -
libinput.so.10(LIBINPUT_0.12.0) -
libjpeg.so.8 -
libjpeg.so.8(LIBJPEG_8.0) -
libm.so.6 -
libm.so.6(GLIBC_2.0) -
libm.so.6(GLIBC_2.1) -
libmtdev.so.1 -
libpng16.so.16 -
libpng16.so.16(PNG16_0) -
libpthread.so.0 -
libpthread.so.0(GLIBC_2.0) -
libpthread.so.0(GLIBC_2.2) -
libstdc++.so.6 -
libstdc++.so.6(CXXABI_1.3) -
libstdc++.so.6(CXXABI_1.3.9) -
libstdc++.so.6(GLIBCXX_3.4) -
libstdc++.so.6(GLIBCXX_3.4.14) -
libts.so.0 -
libudev.so.1 -
libudev.so.1(LIBUDEV_183) -
libxkbcommon.so.0 -
libxkbcommon.so.0(V_0.5.0) -
libz.so.1 -
qtbase5-common == 5.11.2

Provides

Name Value
libQt5Gui.so.5 -
libQt5Gui.so.5(Qt_5) -
libQt5Gui.so.5(Qt_5.0) -
libQt5Gui.so.5(Qt_5.1) -
libQt5Gui.so.5(Qt_5.10) -
libQt5Gui.so.5(Qt_5.11) -
libQt5Gui.so.5(Qt_5.2) -
libQt5Gui.so.5(Qt_5.3) -
libQt5Gui.so.5(Qt_5.4) -
libQt5Gui.so.5(Qt_5.5) -
libQt5Gui.so.5(Qt_5.6) -
libQt5Gui.so.5(Qt_5.7) -
libQt5Gui.so.5(Qt_5.8) -
libQt5Gui.so.5(Qt_5.9) -
libQt5Gui.so.5(Qt_5_PRIVATE_API) -
libcomposeplatforminputcontextplugin.so -
libibusplatforminputcontextplugin.so -
libqeglfs.so -
libqflatpak.so -
libqgif.so -
libqgtk3.so -
libqico.so -
libqjpeg.so -
libqlinuxfb.so -
libqminimal.so -
libqminimalegl.so -
libqoffscreen.so -
libqt5gui5 == 5.11.2-2.mga7
libqt5gui5(x86-32) == 5.11.2-2.mga7
libqvnc.so -
libqxcb.so -

Download

Type URL
Binary Package libqt5gui5-5.11.2-2.mga7.i586.rpm
Source Package qtbase5-5.11.2-2.mga7.src.rpm

Install Howto

  1. Enable Mageia Core repository on Install and Remove Software
  2. Update packages list:
    # urpmi.update -a
  3. Install libqt5gui5 rpm package:
    # urpmi libqt5gui5

Files

Path
/etc/X11/xinit.d/qt5-check-opengl2.sh
/usr/lib/libQt5Gui.so.5
/usr/lib/libQt5Gui.so.5.11
/usr/lib/libQt5Gui.so.5.11.2
/usr/lib/.build-id/
/usr/lib/.build-id/04/01871be74c7f5775c2ce4f94c494c90b4952a6
/usr/lib/.build-id/1a/780a4132e16db2184da7997420ad88d70183e5
/usr/lib/.build-id/1c/3ba0e89f609fa92c272d4d107e7207ffcebc06
/usr/lib/.build-id/1d/700c38e7f2068c9211d0bad5051da661bb362f
/usr/lib/.build-id/20/f1c968a012dfe61c3d8a350f45e7217b0abe64
/usr/lib/.build-id/44/259921cdd2de9b4a81d94f7683818477c199eb
/usr/lib/.build-id/4a/bc55d31e81efd8a270d2a30cfe631e5607927c
/usr/lib/.build-id/6e/f82fdb2500229b6b3e140f32e0644f8d615c6a
/usr/lib/.build-id/7a/864ee8588bba2dec1e97e5c382a0879084a3e7
/usr/lib/.build-id/9a/5577cecc99cddc7373165c8f3cc399f4cea86c
/usr/lib/.build-id/a9/acae415e4ef6baab7d152ad13e16b6d315d77f
/usr/lib/.build-id/b8/270f5d7b3dddb88fa3abf466088c2baa0c8983
/usr/lib/.build-id/cd/c3e5abbbc042ca3821c3e3f181fb2ccf008ec8
/usr/lib/.build-id/d4/264fd005dd94c2b5d97ef7e2c07daf92d45d51
/usr/lib/.build-id/eb/54a912828899ffb9fc147d32719aff7e007ef3
/usr/lib/.build-id/ec/a4c79c144b5180fdc467678c5c9634f5b1f842
/usr/lib/qt5/plugins/imageformats/libqgif.so
/usr/lib/qt5/plugins/imageformats/libqico.so
/usr/lib/qt5/plugins/imageformats/libqjpeg.so
/usr/lib/qt5/plugins/platforminputcontexts/libcomposeplatforminputcontextplugin.so
/usr/lib/qt5/plugins/platforminputcontexts/libibusplatforminputcontextplugin.so
/usr/lib/qt5/plugins/platforms/libqeglfs.so
/usr/lib/qt5/plugins/platforms/libqlinuxfb.so
/usr/lib/qt5/plugins/platforms/libqminimal.so
/usr/lib/qt5/plugins/platforms/libqminimalegl.so
/usr/lib/qt5/plugins/platforms/libqoffscreen.so
/usr/lib/qt5/plugins/platforms/libqvnc.so
/usr/lib/qt5/plugins/platforms/libqxcb.so
/usr/lib/qt5/plugins/platformthemes/libqflatpak.so
/usr/lib/qt5/plugins/platformthemes/libqgtk3.so
/usr/lib/sse2/libQt5Gui.so.5
/usr/lib/sse2/libQt5Gui.so.5.11
/usr/lib/sse2/libQt5Gui.so.5.11.2

Changelog

2018-11-18 - tv <tv> 5.11.2-2.mga7
+ Revision: 1330684
- link moc & co in /bin with -qt5 prefix the FC way (needed for LO)
2018-10-15 - neoclust <neoclust> 5.11.2-1.mga7
+ Revision: 1320464
- New version 5.11.2
2018-09-23 - umeabot <umeabot> 5.11.1-3.mga7
+ Revision: 1300693
- Mageia 7 Mass Rebuild
2018-08-21 - tv <tv> 5.11.1-2.mga7
+ Revision: 1253270
- rebuild with latest icu
2018-07-29 - neoclust <neoclust> 5.11.1-1.mga7
+ Revision: 1245802
- New version 5.11.1
2018-06-26 - daviddavid <daviddavid> 5.11.0-3.mga7
+ Revision: 1239750
- compile against openssl 1.1
2018-05-28 - neoclust <neoclust> 5.11.0-2.mga7
+ Revision: 1232799
- Non bootstrap build
2018-05-25 - neoclust <neoclust> 5.11.0-1.mga7
+ Revision: 1232155
- New version 5.11.0
2018-04-21 - daviddavid <daviddavid> 5.10.1-5.mga7
+ Revision: 1220660
- non bootstrap build
2018-04-20 - daviddavid <daviddavid> 5.10.1-4.mga7
+ Revision: 1220513
- bootstrap build for arm now (because of broken tslib)

See Also

Package Description
libqt5help-devel-5.11.2-2.mga7.i586.rpm Devel files needed to build apps based on QtJsonDbCompat
libqt5help5-5.11.2-2.mga7.i586.rpm Qt5 Component Library
libqt5imageformats-devel-5.11.2-1.mga7.i586.rpm Devel files needed to build apps based on QtImageFormats
libqt5inputsupport-static-devel-5.11.2-2.mga7.i586.rpm Devel files needed to build apps based on InputSupport
libqt5keychain-devel-0.9.1-1.mga7.i586.rpm Development tools for programs which will use the qt5keychain
libqt5keychain1-0.9.1-1.mga7.i586.rpm Platform-independent Qt5 API for storing passwords securely
libqt5kmssupport-static-devel-5.11.2-2.mga7.i586.rpm Devel files needed to build apps based on KmsSupport
libqt5labstemplates-devel-5.11.2-1.mga7.i586.rpm Devel files needed to build apps based on QtEnginio
libqt5labstemplates5-5.11.2-1.mga7.i586.rpm Qt5 Component Library
libqt5linuxaccessibilitysupport-static-devel-5.11.2-2.mga7.i586.rpm Devel files needed to build apps based on AccessibilitySupport
libqt5location-devel-5.11.2-1.mga7.i586.rpm Devel files needed to build apps based on QtLocation
libqt5location5-5.11.2-1.mga7.i586.rpm Qt5 Location Component Library
libqt5lockedfile-devel-2.4.1-15.mga7.i586.rpm Development files for qtlockedfile
libqt5lockedfile1-2.4.1-15.mga7.i586.rpm QFile extension with advisory locking functions
libqt5multimedia-devel-5.11.2-1.mga7.i586.rpm Devel files needed to build apps based on QtMultimedia
Advertisement
Advertisement