libqtsinglecoreapplication-qt5_1-2.6.1-16.mga6.i586.rpm


Advertisement

Description

libqtsinglecoreapplication-qt5_1 - Qt5 library to start applications only once per user

Distribution: Mageia Cauldron
Repository: Mageia Core i586
Package name: libqtsinglecoreapplication-qt5_1
Package version: 2.6.1
Package release: 16.mga6
Package architecture: i586
Package type: rpm
Installed size: 26.80 KB
Download size: 19.10 KB
Official Mirror: distrib-coffee.ipsl.jussieu.fr
For some applications it is useful or even critical that they are started only once by any user. Future attempts to start the application should activate any already running instance, and possibly perform requested actions, e.g. loading a file, in that instance. For console (non-GUI) applications, the QtSingleCoreApplication variant is provided, which avoids dependency on QtGui. This is a special build against Qt5.

Alternatives

Provides

  • libQt5Solutions_SingleCoreApplication-2.6.so.1
  • libqtsinglecoreapplication-qt5_1 == 2.6.1-16.mga6
  • libqtsinglecoreapplication-qt5_1(x86-32) == 2.6.1-16.mga6

Obsoletes

  • libqtsinglecoreapplication-qt51 < 2.6.1-14
  • libqtsinglecoreapplication1-qt5 < 2.6.1-13

    Install Howto

    1. Enable Mageia Core repository on "Install and Remove Software"
    2. Update packages list:
      # urpmi.update -a
    3. Install libqtsinglecoreapplication-qt5_1 rpm package:
      # urpmi libqtsinglecoreapplication-qt5_1

    Files

    • /usr/lib/libQt5Solutions_SingleCoreApplication-2.6.so.1
    • /usr/lib/libQt5Solutions_SingleCoreApplication-2.6.so.1.0
    • /usr/lib/libQt5Solutions_SingleCoreApplication-2.6.so.1.0.0

    Changelog

    2016-04-24 - daviddavid <daviddavid> 2.6.1-16.mga6 + Revision: 1005847 - add patch from fedora to add features for Qupzilla * https://github.com/QupZilla/qupzilla/issues/1503

    2016-01-08 - daviddavid <daviddavid> 2.6.1-15.mga6 + Revision: 920630 - do not install Qt5 libraries into libqtsingleapplication1 Qt4 subpackage

    2016-01-07 - daviddavid <daviddavid> 2.6.1-14.mga6 + Revision: 920372 - rename libqtsingleapplication-qt51 to libqtsingleapplication-qt5_1 - rename libqtsinglecoreapplication-qt51 to libqtsinglecoreapplication-qt5_1

    2016-01-07 - daviddavid <daviddavid> 2.6.1-13.mga6 + Revision: 920307 - fix Requires, Provides and BuildRequires list - update some descriptions - use a better libification for Qt5 subpackages

    2016-01-07 - dglent <dglent> 2.6.1-12.mga6 + Revision: 920165 + rebuild (emptylog)

    2016-01-06 - dglent <dglent> 2.6.1-11.mga6 + Revision: 920160 - Add qt5 support mga#16523

    2015-12-28 - pterjan <pterjan> 2.6.1-10.mga6 + Revision: 916618 - Fix buildRequires

    2014-10-15 - umeabot <umeabot> 2.6.1-9.mga5 + Revision: 746341 - Second Mageia 5 Mass Rebuild

    2014-09-16 - umeabot <umeabot> 2.6.1-8.mga5 + Revision: 688559 - Mageia 5 Mass Rebuild

    2013-10-18 - umeabot <umeabot> 2.6.1-7.mga4 + Revision: 521228 - Mageia 4 Mass Rebuild

    Advertisement
    Advertisement