libsmbclient-devel-4.10.12-2.mga8.i586.rpm


Advertisement

Description

libsmbclient-devel - Developer tools for the SMB client library

Property Value
Distribution Mageia Cauldron
Repository Mageia Core i586
Package filename libsmbclient-devel-4.10.12-2.mga8.i586.rpm
Package name libsmbclient-devel
Package version 4.10.12
Package release 2.mga8
Package architecture i586
Package type rpm
Category Development/C
Homepage http://www.samba.org/
License GPLv3+ and LGPLv3+
Maintainer -
Download size 32.70 KB
Installed size 123.47 KB
The libsmbclient-devel package contains the header files and libraries needed to
develop programs that link against the SMB client library in the Samba suite.

Alternatives

Package Version Architecture Repository
libsmbclient-devel - - -

Requires

Name Value
devel(libbsd) -
devel(libcap) -
devel(libcrypt) -
devel(libcups) -
devel(libdcerpc-binding) -
devel(libdl) -
devel(libgcrypt) -
devel(libgnutls) -
devel(libjansson) -
devel(liblber-2.4) -
devel(libldap-2.4) -
devel(libldb) -
devel(libndr) -
devel(libndr-krb5pac) -
devel(libndr-nbt) -
devel(libndr-standard) -
devel(libnsl) -
devel(libresolv) -
devel(libsamba-credentials) -
devel(libsamba-errors) -
devel(libsamba-hostconfig) -
devel(libsamba-util) -
devel(libsamdb) -
devel(libsmbconf) -
devel(libsystemd) -
devel(libtalloc) -
devel(libtdb) -
devel(libtevent) -
devel(libtevent-util) -
devel(libutil) -
devel(libwbclient) -
devel(libz) -
libsmbclient0 == 4.10.12-2.mga8
pkgconfig -

Provides

Name Value
devel(libsmbclient) -
libsmbclient-devel == 4.10.12-2.mga8
libsmbclient-devel(x86-32) == 4.10.12-2.mga8
pkgconfig(smbclient) == 0.5.0
smbclient-devel == 4.10.12-2.mga8

Obsoletes

Name Value
libsamba4-smbclient-devel < 4.1.17-12

Download

Type URL
Mirror distrib-coffee.ipsl.jussieu.fr
Binary Package libsmbclient-devel-4.10.12-2.mga8.i586.rpm
Source Package samba-4.10.12-2.mga8.src.rpm

Install Howto

  1. Enable Mageia Core repository on Install and Remove Software
  2. Update packages list:
    # urpmi.update -a
  3. Install libsmbclient-devel rpm package:
    # urpmi libsmbclient-devel

Files

Path
/usr/include/samba-4.0/libsmbclient.h
/usr/lib/libsmbclient.so
/usr/lib/pkgconfig/smbclient.pc
/usr/share/man/man7/libsmbclient.7.xz

Changelog

2020-01-22 - buchan <buchan> 4.10.12-2.mga8
+ Revision: 1482039
- Update to 4.10.12
+ wally <wally>
- replace deprecated %configure2_5x
2020-01-04 - luigiwalser <luigiwalser> 4.10.11-2.mga8
+ Revision: 1476010
- rebuild for readline
2019-12-14 - buchan <buchan> 4.10.11-1.mga8
+ Revision: 1467229
- Update to 4.10.11 mga#25644
2019-10-03 - tv <tv> 4.10.8-7.mga8
+ Revision: 1449101
- remove bogus triggers (mga#25518)
+ daviddavid <daviddavid>
- use system python3-iso8601
2019-09-16 - daviddavid <daviddavid> 4.10.8-6.mga8
+ Revision: 1442036
- fix one more file conflict with python3-talloc
2019-09-14 - tv <tv> 4.10.8-5.mga8
+ Revision: 1440634
- fix file conflict with python3-talloc
2019-09-12 - tv <tv> 4.10.8-4.mga8
+ Revision: 1439998
- bump release so that we're newer than the core/release's build
- adjust file list (why BS behaves differently than local iurt?)
- fix building with python-3.8
- drop python2 subpkg
2019-09-10 - buchan <buchan> 4.10.8-3.mga8
+ Revision: 1439462
- Also forcefully remove the remaining alternatives file (mga#21164)
2019-09-10 - buchan <buchan> 4.10.8-2.mga8
+ Revision: 1439385
- Install symlinks for CUPS smb backend via triggers (mga#21164)
- Also clean up old alternatives from samba 3.x
2019-09-03 - buchan <buchan> 4.10.8-1.mga8
+ Revision: 1436819
- New version 4.10.8

See Also

Package Description
libsmbclient0-4.10.12-2.mga8.i586.rpm The SMB client library
libsmbios-devel-2.4.3-1.mga8.i586.rpm Development files for libsmios
libsmbios2-2.4.3-1.mga8.i586.rpm Libraries to get information from standard BIOS tables
libsmesh-devel-6.7.6-3.mga8.i586.rpm Development files for smesh
libsmesh3-6.7.6-3.mga8.i586.rpm OpenCascade based MESH framework
libsmi-devel-0.5.0-4.mga8.i586.rpm Development tools for LibSMI
libsmi-mibs-ext-0.5.0-4.mga8.i586.rpm Extended MIB files for LibSMI
libsmi-mibs-std-0.5.0-4.mga8.i586.rpm Standard MIB files for LibSMI
libsmi-yang-0.5.0-4.mga8.i586.rpm YANG files for LibSMI
libsmi2-0.5.0-4.mga8.i586.rpm LibSMI deals with SNMP MIBS definitions
libsmltk0-1.5.3-6.mga8.i586.rpm Smltk library
libsmm-local6-0.20.0-1.mga8.i586.rpm Secure Messaging 'local' module for OpenSC
libsmpeg-devel-0.4.5-11.mga8.i586.rpm Headers for developing programs that will use smpeg
libsmpeg0.4_0-0.4.5-11.mga8.i586.rpm Main library for smpeg
libsnapper-devel-0.5.6-2.mga8.i586.rpm Header files and documentation for libsnapper
Advertisement
Advertisement