nettle-3.4-1.mga7.i586.rpm


Advertisement

Description

nettle - Nettle cryptographic library

Property Value
Distribution Mageia Cauldron
Repository Mageia Core i586
Package name nettle
Package version 3.4
Package release 1.mga7
Package architecture i586
Package type rpm
Installed size 113.98 KB
Download size 81.84 KB
Official Mirror distrib-coffee.ipsl.jussieu.fr
Nettle is a cryptographic library that is designed to fit easily in more or less any context:
In crypto toolkits for object-oriented languages (C++, Python, Pike, ...), in applications
like LSH or GNUPG, or even in kernel space.

Alternatives

Package Version Architecture Repository
nettle-3.4-1.mga7.x86_64.rpm 3.4 x86_64 Mageia Core
nettle - - -

Requires

Name Value
libc.so.6 -
libc.so.6(GLIBC_2.0) -
libc.so.6(GLIBC_2.1) -
libc.so.6(GLIBC_2.3.4) -
libc.so.6(GLIBC_2.4) -
libgmp.so.10 -
libhogweed.so.4 -
libhogweed.so.4(HOGWEED_4) -
libhogweed4 == 1:3.4-1.mga7
libnettle.so.6 -
libnettle.so.6(NETTLE_6) -
libnettle6 == 1:3.4-1.mga7

Provides

Name Value
nettle == 1:3.4-1.mga7
nettle(x86-32) == 1:3.4-1.mga7

Obsoletes

Name Value
nettle2.7 < 1:2.7.1-7

Download

Type URL
Binary Package nettle-3.4-1.mga7.i586.rpm
Source Package nettle-3.4-1.mga7.src.rpm

Install Howto

  1. Enable Mageia Core repository on Install and Remove Software
  2. Update packages list:
    # urpmi.update -a
  3. Install nettle rpm package:
    # urpmi nettle

Files

Path
/usr/bin/nettle-hash
/usr/bin/nettle-lfib-stream
/usr/bin/nettle-pbkdf2
/usr/bin/pkcs1-conv
/usr/bin/sexp-conv
/usr/lib/.build-id/
/usr/lib/.build-id/0c/3d3b378772a95f22478dede98002986627e798
/usr/lib/.build-id/48/85091753a60a3da5a760d2d6eb92635e3db71b
/usr/lib/.build-id/56/eedb9d938527a6aa2d3a64d0719334e57de645
/usr/lib/.build-id/7c/29b29e82727904655450749d0db67077d8eb81
/usr/lib/.build-id/96/5e39c0339bd7598a3133da513406f9242ee282
/usr/share/info/nettle.info.xz

Changelog

2018-04-13 - kekepower <kekepower> 1:3.4-1.mga7
(not released yet)
+ Revision: 1218103
- Update to version 3.4
2016-10-03 - luigiwalser <luigiwalser> 1:3.3-1.mga6
+ Revision: 1058218
- 3.3
- remove upstream patches
2016-08-09 - luigiwalser <luigiwalser> 1:3.2-5.mga6
+ Revision: 1045192
- add more upstream bugfixes related to CVE-2016-6489
2016-07-29 - luigiwalser <luigiwalser> 1:3.2-4.mga6
+ Revision: 1043883
- add upstream patch to fix CVE-2016-6489
2016-02-12 - luigiwalser <luigiwalser> 1:3.2-3.mga6
+ Revision: 956085
- add epochs on nettle2.7 obsoletes
2016-02-05 - luigiwalser <luigiwalser> 1:3.2-2.mga6
+ Revision: 938260
- obsolete nettle2.7
2016-02-02 - luigiwalser <luigiwalser> 1:3.2-1.mga6
+ Revision: 931906
- 3.2
2015-08-21 - tmb <tmb> 1:3.1.1-2.mga6
+ Revision: 867603
- rebuild for new gcc
2015-08-15 - fwang <fwang> 1:3.1.1-1.mga6
+ Revision: 864879
- bump libmajor
- 3.1.1

See Also

Package Description
netty-4.0.28-3.mga6.i586.rpm An asynchronous event-driven network application framework and tools for Java
netty-javadoc-4.0.28-3.mga6.i586.rpm API documentation for netty
netty-tcnative-1.1.30-9.mga7.i586.rpm Fork of Tomcat Native with improved OpenSSL and mavenized build
netty-tcnative-javadoc-1.1.30-9.mga7.noarch.rpm API documentation for netty-tcnative
netty-xnio-transport-0.1.1-1.mga6.noarch.rpm Netty Transport powered by XNIO
netty-xnio-transport-javadoc-0.1.1-1.mga6.noarch.rpm Javadoc for netty-xnio-transport
netty3-3.10.6-1.mga6.noarch.rpm An asynchronous event-driven network application framework and tools for Java
netty3-javadoc-3.10.6-1.mga6.noarch.rpm API documentation for netty3
networkmanager-1.12.4-1.mga7.i586.rpm Network connection manager and user applications
networkmanager-adsl-1.12.4-1.mga7.i586.rpm ADSL device plugin for NetworkManager
networkmanager-applet-1.8.18-1.mga7.i586.rpm Network connection manager system tray applet
networkmanager-bluetooth-1.12.4-1.mga7.i586.rpm Bluetooth device plugin for NetworkManager
networkmanager-l2tp-1.2.10-2.mga7.i586.rpm L2TP and L2TP/IPsec support for NetworkManager
networkmanager-libreswan-1.2.6-2.mga7.i586.rpm NetworkManager VPN integration for LibreSWAN
networkmanager-openconnect-1.2.4-3.mga7.i586.rpm NetworkManager VPN integration for openconnect
Advertisement
Advertisement