perl-Devel-Declare-0.6.19-7.mga8.i586.rpm


Advertisement

Description

perl-Devel-Declare - Adding keywords to perl, in perl

Property Value
Distribution Mageia Cauldron
Repository Mageia Core i586
Package filename perl-Devel-Declare-0.6.19-7.mga8.i586.rpm
Package name perl-Devel-Declare
Package version 0.6.19
Package release 7.mga8
Package architecture i586
Package type rpm
Category Development/Perl
Homepage http://metacpan.org/release/Devel-Declare
License GPL+ or Artistic
Maintainer -
Download size 45.23 KB
Installed size 103.16 KB
Devel::Declare can install subroutines called declarators which locally
take over Perl's parser, allowing the creation of new syntax.

Alternatives

Package Version Architecture Repository
perl-Devel-Declare-0.6.19-7.mga8.x86_64.rpm 0.6.19 x86_64 Mageia Core
perl-Devel-Declare - - -

Requires

Name Value
libc.so.6 -
libc.so.6(GLIBC_2.0) -
libc.so.6(GLIBC_2.1.3) -
libc.so.6(GLIBC_2.3.4) -
libc.so.6(GLIBC_2.4) -
libperl.so.5.30 -
perl >= 0:5.008001
perl(B::Hooks::EndOfScope) >= 0.50.0
perl(B::Hooks::OP::Check) >= 0.190.0
perl(Carp) -
perl(Devel::Declare) -
perl(Devel::Declare::Context::Simple) -
perl(DynaLoader) -
perl(Scalar::Util) >= 1.110.0
perl(Sub::Name) -
perl(base) -
perl(constant) -
perl(strict) -
perl(vars) -
perl(warnings) -
perl-base >= 2:5.30.0

Provides

Name Value
perl(Devel::Declare) == 0.6.19
perl(Devel::Declare::Context::Simple) == 0.6.19
perl(Devel::Declare::MethodInstaller::Simple) == 0.6.19
perl-Devel-Declare == 1:0.6.19-7.mga8
perl-Devel-Declare(x86-32) == 1:0.6.19-7.mga8

Download

Type URL
Mirror distrib-coffee.ipsl.jussieu.fr
Binary Package perl-Devel-Declare-0.6.19-7.mga8.i586.rpm
Source Package perl-Devel-Declare-0.6.19-7.mga8.src.rpm

Install Howto

  1. Enable Mageia Core repository on Install and Remove Software
  2. Update packages list:
    # urpmi.update -a
  3. Install perl-Devel-Declare rpm package:
    # urpmi perl-Devel-Declare

Files

Path
/usr/lib/.build-id/
/usr/lib/.build-id/04/b8ba7cc04d713758eadeab72cfc692b56bfd7a
/usr/lib/perl5/vendor_perl/Devel/Declare.pm
/usr/lib/perl5/vendor_perl/Devel/Declare/
/usr/lib/perl5/vendor_perl/Devel/Declare/Context/Simple.pm
/usr/lib/perl5/vendor_perl/Devel/Declare/MethodInstaller/Simple.pm
/usr/lib/perl5/vendor_perl/auto/Devel/
/usr/lib/perl5/vendor_perl/auto/Devel/Declare/Declare.so
/usr/share/doc/perl-Devel-Declare/Changes
/usr/share/doc/perl-Devel-Declare/META.json
/usr/share/doc/perl-Devel-Declare/META.yml
/usr/share/doc/perl-Devel-Declare/MYMETA.yml
/usr/share/doc/perl-Devel-Declare/README
/usr/share/man/man3/Devel::Declare.3pm.xz

Changelog

2019-08-27 - tmb <tmb> 1:0.6.19-7.mga8
+ Revision: 1433512
- rebuild for perl 5.30
2018-09-21 - umeabot <umeabot> 1:0.6.19-6.mga7
+ Revision: 1292759
- Mageia 7 Mass Rebuild
2018-08-08 - pterjan <pterjan> 1:0.6.19-5.mga7
+ Revision: 1250090
- Rebuild for perl 5.28
+ shlomif <shlomif>
- Rebuild for new perl 5.28.0
2017-10-02 - tv <tv> 1:0.6.19-3.mga7
+ Revision: 1164057
- rebuild with fixed rpm for missing autodeps
2017-08-31 - pterjan <pterjan> 1:0.6.19-2.mga7
+ Revision: 1149615
- Rebuild for perl ABI changes

See Also

Package Description
perl-Devel-DumpTrace-0.290.0-1.mga8.noarch.rpm PPI-based version of Devel::DumpTrace
perl-Devel-Dumpvar-1.60.0-11.mga7.noarch.rpm A pure-OO reimplementation of dumpvar.pl
perl-Devel-FindPerl-0.15.0-1.mga7.noarch.rpm Find the path to your perl
perl-Devel-GlobalDestruction-0.140.0-2.mga7.noarch.rpm Expose PL_dirty, the flag which marks global
perl-Devel-GlobalPhase-0.3.3-2.mga7.noarch.rpm Detect perl's global phase on older perls
perl-Devel-Hide-0.1.0-2.mga7.noarch.rpm Forces the unavailability of specified Perl modules (for testing)
perl-Devel-Leak-0.30.0-14.mga8.i586.rpm Utility for looking for perl objects that are not reclaimed
perl-Devel-Leak-Object-1.10.0-9.mga7.noarch.rpm Detect leaks of objects
perl-Devel-LeakGuard-Object-0.80.0-4.mga7.noarch.rpm Scoped object leak checking
perl-Devel-LexAlias-0.50.0-17.mga8.i586.rpm Alias lexical variables
perl-Devel-NYTProf-6.60.0-4.mga8.i586.rpm Powerful feature-rich perl source code profiler
perl-Devel-OverloadInfo-0.5.0-2.mga7.noarch.rpm Introspect overloaded operators
perl-Devel-OverrideGlobalRequire-0.1.0-2.mga7.noarch.rpm Override CORE::GLOBAL::require safely
perl-Devel-PPPort-3.540.0-1.mga8.i586.rpm Portability aid for your XS code
perl-Devel-PartialDump-0.200.0-3.mga7.noarch.rpm Partial dumping of data structures, optimized for argument
Advertisement
Advertisement