perl-Dist-Zilla-Plugin-BumpVersionAfterRelease-0.18.0-2.mga7.noarch.rpm


Advertisement

Description

perl-Dist-Zilla-Plugin-BumpVersionAfterRelease - Bump module versions after distribution release

Property Value
Distribution Mageia Cauldron
Repository Mageia Core i586
Package filename perl-Dist-Zilla-Plugin-BumpVersionAfterRelease-0.18.0-2.mga7.noarch.rpm
Package name perl-Dist-Zilla-Plugin-BumpVersionAfterRelease
Package version 0.18.0
Package release 2.mga7
Package architecture noarch
Package type rpm
Category Development/Perl
Homepage http://search.cpan.org/dist/Dist-Zilla-Plugin-BumpVersionAfterRelease
License ASL 2.0
Maintainer -
Download size 30.14 KB
Installed size 61.61 KB
After a release, this module modifies your original source code to
replace an existing "our $VERSION = '1.23'" declaration with the next
number after the released version as determined by Version::Next. Only
the first occurrence is affected and it must exactly match this regular
expression:
qr{^our \s+ \$VERSION \s* = \s* '$version::LAX'}mx
It must be at the start of a line and any trailing comments are deleted.
The original may have double-quotes, but the re-written line will have
single quotes.
The very restrictive regular expression format is intentional to avoid
the various ways finding a version assignment could go wrong and to
avoid using PPI, which has similar complexity issues.
For most modules, this should work just fine.

Alternatives

Package Version Architecture Repository
perl-Dist-Zilla-Plugin-BumpVersionAfterRelease-0.18.0-2.mga7.noarch.rpm 0.18.0 noarch Mageia Core
perl-Dist-Zilla-Plugin-BumpVersionAfterRelease - - -

Requires

Name Value
perl >= 0:5.008001
perl(Dist::Zilla) >= 5.40.0
perl(Dist::Zilla::Role::AfterRelease) >= 5.0.0
perl(Dist::Zilla::Role::FileFinderUser) -
perl(Dist::Zilla::Role::FileMunger) >= 5.0.0
perl(Dist::Zilla::Role::VersionProvider) -
perl(Moose) -
perl(Moose::Role) -
perl(Path::Tiny) >= 0.61.0
perl(Version::Next) -
perl(namespace::autoclean) -
perl(strict) -
perl(version) -
perl(warnings) -
perl-base >= 2:5.28.0

Provides

Name Value
perl(Dist::Zilla::Plugin::BumpVersionAfterRelease) == 0.18.0
perl(Dist::Zilla::Plugin::BumpVersionAfterRelease::_Util) == 0.18.0
perl(Dist::Zilla::Plugin::RewriteVersion) == 0.18.0
perl-Dist-Zilla-Plugin-BumpVersionAfterRelease == 0.18.0-2.mga7

Download

Type URL
Mirror distrib-coffee.ipsl.jussieu.fr
Binary Package perl-Dist-Zilla-Plugin-BumpVersionAfterRelease-0.18.0-2.mga7.noarch.rpm
Source Package perl-Dist-Zilla-Plugin-BumpVersionAfterRelease-0.18.0-2.mga7.src.rpm

Install Howto

  1. Enable Mageia Core repository on Install and Remove Software
  2. Update packages list:
    # urpmi.update -a
  3. Install perl-Dist-Zilla-Plugin-BumpVersionAfterRelease rpm package:
    # urpmi perl-Dist-Zilla-Plugin-BumpVersionAfterRelease

Files

Path
/usr/share/doc/perl-Dist-Zilla-Plugin-BumpVersionAfterRelease/Changes
/usr/share/doc/perl-Dist-Zilla-Plugin-BumpVersionAfterRelease/LICENSE
/usr/share/doc/perl-Dist-Zilla-Plugin-BumpVersionAfterRelease/META.json
/usr/share/doc/perl-Dist-Zilla-Plugin-BumpVersionAfterRelease/META.yml
/usr/share/doc/perl-Dist-Zilla-Plugin-BumpVersionAfterRelease/MYMETA.yml
/usr/share/doc/perl-Dist-Zilla-Plugin-BumpVersionAfterRelease/README
/usr/share/man/man3/Dist::Zilla::Plugin::BumpVersionAfterRelease.3pm.xz
/usr/share/man/man3/Dist::Zilla::Plugin::RewriteVersion.3pm.xz
/usr/share/perl5/vendor_perl/Dist/
/usr/share/perl5/vendor_perl/Dist/Zilla/
/usr/share/perl5/vendor_perl/Dist/Zilla/Plugin/BumpVersionAfterRelease.pm
/usr/share/perl5/vendor_perl/Dist/Zilla/Plugin/RewriteVersion.pm
/usr/share/perl5/vendor_perl/Dist/Zilla/Plugin/BumpVersionAfterRelease/_Util.pm

Changelog

2018-09-20 - umeabot <umeabot> 0.18.0-2.mga7
(not released yet)
+ Revision: 1282990
- Mageia 7 Mass Rebuild
2018-04-22 - tv <tv> 0.18.0-1.mga7
+ Revision: 1221060
- update to 0.018
2017-12-29 - tv <tv> 0.17.0-1.mga7
+ Revision: 1186943
- update to 0.017
2017-11-30 - tv <tv> 0.16.0-1.mga7
+ Revision: 1180479
- update to 0.016
2016-06-19 - pterjan <pterjan> 0.15.0-2.mga6
+ Revision: 1025832
- Rebuild for perl 5.22.2
2016-04-28 - shlomif <shlomif> 0.15.0-1.mga6
+ Revision: 1007510
- update to 0.015
2016-03-13 - shlomif <shlomif> 0.14.0-1.mga6
+ Revision: 989810
- update to 0.014
2016-02-10 - shlomif <shlomif> 0.13.0-1.mga6
+ Revision: 953352
- update to 0.013

See Also

Package Description
perl-Dist-Zilla-Plugin-BumpVersionFromGit-0.10.0-4.mga7.noarch.rpm Provide a version number by bumping the last git release tag
perl-Dist-Zilla-Plugin-Catalyst-0.150.0-9.mga7.noarch.rpm A subclass of Catalyst::Helper
perl-Dist-Zilla-Plugin-ChangeStats-Git-0.6.0-3.mga7.noarch.rpm Provides an accessor for the changelog
perl-Dist-Zilla-Plugin-ChangelogFromGit-0.17.0-2.mga7.noarch.rpm Build CHANGES from git commits and tags
perl-Dist-Zilla-Plugin-CheckBin-0.8.0-2.mga7.noarch.rpm Require that our distribution has a particular command available
perl-Dist-Zilla-Plugin-CheckChangeLog-0.50.0-2.mga7.noarch.rpm Dist::Zilla with Changes check
perl-Dist-Zilla-Plugin-CheckChangesHasContent-0.11.0-2.mga7.noarch.rpm Ensure Changes has content before releasing
perl-Dist-Zilla-Plugin-CheckExtraTests-0.29.0-3.mga7.noarch.rpm Check xt tests before release
perl-Dist-Zilla-Plugin-CheckIssues-0.11.0-1.mga8.noarch.rpm Retrieve count of outstanding RT and github issues for your distribution
perl-Dist-Zilla-Plugin-CheckLib-0.7.0-2.mga7.noarch.rpm Require that our distribution has a particular library available
perl-Dist-Zilla-Plugin-CheckMetaResources-0.1.0-8.mga7.noarch.rpm Ensure META includes resources
perl-Dist-Zilla-Plugin-CheckPrereqsIndexed-0.20.0-3.mga7.noarch.rpm Prevent a release if you have prereqs not found on CPAN
perl-Dist-Zilla-Plugin-CheckSelfDependency-0.11.0-4.mga7.noarch.rpm Check if your distribution declares a dependency on itself
perl-Dist-Zilla-Plugin-CheckStrictVersion-0.1.0-3.mga7.noarch.rpm BeforeRelease plugin to check for a strict version number
perl-Dist-Zilla-Plugin-CheckVersionIncrement-0.121.750-8.mga7.noarch.rpm Prevent a release unless the version number is incremented
Advertisement
Advertisement