perl-Dist-Zilla-Plugin-LatestPrereqs-0.400.0-8.mga7.noarch.rpm


Advertisement

Description

perl-Dist-Zilla-Plugin-LatestPrereqs - Adjust prereqs to use latest version available

Property Value
Distribution Mageia Cauldron
Repository Mageia Core i586
Package filename perl-Dist-Zilla-Plugin-LatestPrereqs-0.400.0-8.mga7.noarch.rpm
Package name perl-Dist-Zilla-Plugin-LatestPrereqs
Package version 0.400.0
Package release 8.mga7
Package architecture noarch
Package type rpm
Category Development/Perl
Homepage http://search.cpan.org/dist/Dist-Zilla-Plugin-LatestPrereqs
License GPL+ or Artistic
Maintainer -
Download size 18.39 KB
Installed size 20.74 KB
This plugin will filter over all your declared or discovered prerequisites,
contact CPAN, and adjust the version to the latest one available.
This will make sure that your module will be installed with the latest
version available on CPAN at the time you built your package.
The most common use for this techinique is for the Task manpage modules.
You can rebuild your Task module on a regular basis to make sure it has the
latest versions of your dependencies.

Alternatives

Package Version Architecture Repository
perl-Dist-Zilla-Plugin-LatestPrereqs-0.400.0-8.mga7.noarch.rpm 0.400.0 noarch Mageia Core
perl-Dist-Zilla-Plugin-LatestPrereqs - - -

Requires

Name Value
perl(CPAN) >= 1.940.200
perl(CPAN::Meta::Prereqs) >= 2.101.670
perl(Dist::Zilla) >= 4.0.0
perl(Module::CoreList) -
perl(Moose) -
perl-base >= 2:5.28.0

Provides

Name Value
perl(Dist::Zilla::Plugin::LatestPrereqs) == 0.400.0
perl-Dist-Zilla-Plugin-LatestPrereqs == 0.400.0-8.mga7

Download

Type URL
Mirror distrib-coffee.ipsl.jussieu.fr
Binary Package perl-Dist-Zilla-Plugin-LatestPrereqs-0.400.0-8.mga7.noarch.rpm
Source Package perl-Dist-Zilla-Plugin-LatestPrereqs-0.400.0-8.mga7.src.rpm

Install Howto

  1. Enable Mageia Core repository on Install and Remove Software
  2. Update packages list:
    # urpmi.update -a
  3. Install perl-Dist-Zilla-Plugin-LatestPrereqs rpm package:
    # urpmi perl-Dist-Zilla-Plugin-LatestPrereqs

Files

Path
/usr/share/doc/perl-Dist-Zilla-Plugin-LatestPrereqs/Changes
/usr/share/doc/perl-Dist-Zilla-Plugin-LatestPrereqs/INSTALL
/usr/share/doc/perl-Dist-Zilla-Plugin-LatestPrereqs/LICENSE
/usr/share/doc/perl-Dist-Zilla-Plugin-LatestPrereqs/META.json
/usr/share/doc/perl-Dist-Zilla-Plugin-LatestPrereqs/META.yml
/usr/share/doc/perl-Dist-Zilla-Plugin-LatestPrereqs/README
/usr/share/man/man3/Dist::Zilla::Plugin::LatestPrereqs.3pm.xz
/usr/share/perl5/vendor_perl/Dist/
/usr/share/perl5/vendor_perl/Dist/Zilla/
/usr/share/perl5/vendor_perl/Dist/Zilla/Plugin/LatestPrereqs.pm

Changelog

2018-09-19 - umeabot <umeabot> 0.400.0-8.mga7
(not released yet)
+ Revision: 1267539
- Mageia 7 Mass Rebuild
2016-06-19 - pterjan <pterjan> 0.400.0-7.mga6
+ Revision: 1026273
- Rebuild for perl 5.22.2
2016-02-08 - umeabot <umeabot> 0.400.0-6.mga6
+ Revision: 947585
- Mageia 6 Mass Rebuild

See Also

Package Description
perl-Dist-Zilla-Plugin-LocaleMsgfmt-1.203.0-8.mga7.noarch.rpm Dist::Zilla plugin that compiles Local::Msgfmt .po files to .mo files
perl-Dist-Zilla-Plugin-MakeMaker-Awesome-0.480.0-1.mga8.noarch.rpm A more awesome MakeMaker plugin for Dist::Zilla
perl-Dist-Zilla-Plugin-MakeMaker-Fallback-0.30.0-2.mga7.noarch.rpm Generate a Makefile.PL containing a warning for legacy users
perl-Dist-Zilla-Plugin-MakeMaker-SkipInstall-1.201.0-3.mga7.noarch.rpm Skip the install rule of MakeMaker
perl-Dist-Zilla-Plugin-MatchManifest-6.0.0-2.mga7.noarch.rpm Ensure that MANIFEST is correct
perl-Dist-Zilla-Plugin-Mercurial-0.80.0-4.mga7.noarch.rpm Check for modified/removed/unknown files
perl-Dist-Zilla-Plugin-MetaData-BuiltWith-1.4.5-3.mga7.noarch.rpm Go overkill and report everything in all name-spaces
perl-Dist-Zilla-Plugin-MetaProvides-2.2.4-3.mga7.noarch.rpm In the event nothing else works, pull in hand-crafted metadata from a specified file
perl-Dist-Zilla-Plugin-MetaProvides-Class-2.1.1-3.mga7.noarch.rpm Scans Dist::Zilla's .pm files and tries to identify classes using Class::Discover
perl-Dist-Zilla-Plugin-MetaProvides-FromFile-2.1.2-3.mga7.noarch.rpm In the event nothing else works, pull in hand-crafted metadata from a specified file
perl-Dist-Zilla-Plugin-MetaProvides-Package-2.4.3-3.mga7.noarch.rpm Extract namespaces/version from traditional packages for provides
perl-Dist-Zilla-Plugin-MetaResourcesFromGit-1.103.620-8.mga7.noarch.rpm Metadata resource URLs from Git configuration
perl-Dist-Zilla-Plugin-MetaYAML-Minimal-0.1.1-2.mga7.noarch.rpm Generate a reductionist YAML META file for compatibility only
perl-Dist-Zilla-Plugin-MinimumPerl-1.6.0-4.mga7.noarch.rpm Detects the minimum version of Perl required for your dist
perl-Dist-Zilla-Plugin-ModuleBuild-XSOrPP-0.40.0-8.mga7.noarch.rpm Add a --pp option to your Build.PL to force an XS-less build
Advertisement
Advertisement