perl-Dist-Zilla-Plugin-MinimumPerl-1.6.0-4.mga7.noarch.rpm


Advertisement

Description

perl-Dist-Zilla-Plugin-MinimumPerl - Detects the minimum version of Perl required for your dist

Property Value
Distribution Mageia Cauldron
Repository Mageia Core i586
Package filename perl-Dist-Zilla-Plugin-MinimumPerl-1.6.0-4.mga7.noarch.rpm
Package name perl-Dist-Zilla-Plugin-MinimumPerl
Package version 1.6.0
Package release 4.mga7
Package architecture noarch
Package type rpm
Category Development/Perl
Homepage http://search.cpan.org/dist/Dist-Zilla-Plugin-MinimumPerl
License GPL+ or Artistic
Maintainer -
Download size 31.17 KB
Installed size 89.07 KB
This plugin uses the Perl::MinimumVersion manpage to automatically find the
minimum version of Perl required for your dist and adds it to the prereqs.
You can specify a version of Perl to override the scanning logic.
[MinimumPerl]
This plugin accepts the following options:

Alternatives

Package Version Architecture Repository
perl-Dist-Zilla-Plugin-MinimumPerl-1.6.0-4.mga7.noarch.rpm 1.6.0 noarch Mageia Core
perl-Dist-Zilla-Plugin-MinimumPerl - - -

Requires

Name Value
perl(Dist::Zilla::Role::FileFinderUser) >= 4.200.6
perl(Dist::Zilla::Role::PrereqSource) >= 5.6.0
perl(Moose) >= 1.30.0
perl(Moose::Util::TypeConstraints) >= 1.10.0
perl(MooseX::Types::Perl) >= 0.101.340
perl(Perl::MinimumVersion) >= 1.260.0
perl(strict) -
perl(warnings) -
perl-base >= 2:5.28.0

Provides

Name Value
perl(Dist::Zilla::Plugin::MinimumPerl) == 1.6.0
perl-Dist-Zilla-Plugin-MinimumPerl == 1.6.0-4.mga7

Download

Type URL
Mirror distrib-coffee.ipsl.jussieu.fr
Binary Package perl-Dist-Zilla-Plugin-MinimumPerl-1.6.0-4.mga7.noarch.rpm
Source Package perl-Dist-Zilla-Plugin-MinimumPerl-1.6.0-4.mga7.src.rpm

Install Howto

  1. Enable Mageia Core repository on Install and Remove Software
  2. Update packages list:
    # urpmi.update -a
  3. Install perl-Dist-Zilla-Plugin-MinimumPerl rpm package:
    # urpmi perl-Dist-Zilla-Plugin-MinimumPerl

Files

Path
/usr/share/doc/perl-Dist-Zilla-Plugin-MinimumPerl/Changes
/usr/share/doc/perl-Dist-Zilla-Plugin-MinimumPerl/INSTALL
/usr/share/doc/perl-Dist-Zilla-Plugin-MinimumPerl/LICENSE
/usr/share/doc/perl-Dist-Zilla-Plugin-MinimumPerl/META.json
/usr/share/doc/perl-Dist-Zilla-Plugin-MinimumPerl/META.yml
/usr/share/doc/perl-Dist-Zilla-Plugin-MinimumPerl/README
/usr/share/doc/perl-Dist-Zilla-Plugin-MinimumPerl/SIGNATURE
/usr/share/doc/perl-Dist-Zilla-Plugin-MinimumPerl/examples/dist.ini
/usr/share/man/man3/Dist::Zilla::Plugin::MinimumPerl.3pm.xz
/usr/share/perl5/vendor_perl/Dist/
/usr/share/perl5/vendor_perl/Dist/Zilla/
/usr/share/perl5/vendor_perl/Dist/Zilla/Plugin/MinimumPerl.pm

Changelog

2018-09-19 - umeabot <umeabot> 1.6.0-4.mga7
(not released yet)
+ Revision: 1267543
- Mageia 7 Mass Rebuild
2016-06-19 - pterjan <pterjan> 1.6.0-3.mga6
+ Revision: 1026385
- Rebuild for perl 5.22.2
2016-02-18 - umeabot <umeabot> 1.6.0-2.mga6
+ Revision: 966577
- Mageia 6 Mass Rebuild

See Also

Package Description
perl-Dist-Zilla-Plugin-ModuleBuild-XSOrPP-0.40.0-8.mga7.noarch.rpm Add a --pp option to your Build.PL to force an XS-less build
perl-Dist-Zilla-Plugin-ModuleBuildTiny-0.15.0-2.mga7.noarch.rpm Build a Build.PL that uses Module::Build::Tiny
perl-Dist-Zilla-Plugin-ModuleBuildTiny-Fallback-0.25.0-3.mga7.noarch.rpm Generate a Build.PL that uses Module::Build::Tiny, falling back to Module::Build as needed
perl-Dist-Zilla-Plugin-ModuleInstall-1.1.2-3.mga7.noarch.rpm Build Module::Install based Distributions with Dist::Zilla
perl-Dist-Zilla-Plugin-MojibakeTests-0.800.0-4.mga7.noarch.rpm Release tests for source encoding
perl-Dist-Zilla-Plugin-NextVersion-Semantic-0.2.5-4.mga7.noarch.rpm Extract previous version from changelog
perl-Dist-Zilla-Plugin-NoAutomatedTesting-0.80.0-6.mga7.noarch.rpm Avoid running under CPAN Testers
perl-Dist-Zilla-Plugin-NoSmartCommentsTests-0.9.0-3.mga7.noarch.rpm Make sure no Smart::Comments escape into the wild
perl-Dist-Zilla-Plugin-OSPrereqs-0.11.0-2.mga7.noarch.rpm List prereqs conditional on operating system
perl-Dist-Zilla-Plugin-OnlyCorePrereqs-0.24.0-4.mga7.noarch.rpm Check that no prerequisites are declared that are not part of core
perl-Dist-Zilla-Plugin-OurPkgVersion-0.210.0-1.mga8.noarch.rpm No line insertion and does Package version with our
perl-Dist-Zilla-Plugin-PerlTidy-0.210.0-4.mga7.noarch.rpm Perltidy your dist
perl-Dist-Zilla-Plugin-PkgVersion-Block-0.20.0-2.mga7.noarch.rpm PkgVersion for block packages
perl-Dist-Zilla-Plugin-Pod2Readme-0.4.0-2.mga7.noarch.rpm Generate README from Pod, as simply as possible
perl-Dist-Zilla-Plugin-PodLoom-5.1.0-4.mga7.noarch.rpm Process module documentation through Pod::Loom
Advertisement
Advertisement