perl-Dist-Zilla-Plugin-NextVersion-Semantic-0.2.5-3.mga6.noarch.rpm


Advertisement

Description

perl-Dist-Zilla-Plugin-NextVersion-Semantic - Extract previous version from changelog

Property Value
Distribution Mageia Cauldron
Repository Mageia Core i586
Package name perl-Dist-Zilla-Plugin-NextVersion-Semantic
Package version 0.2.5
Package release 3.mga6
Package architecture noarch
Package type rpm
Installed size 49.34 KB
Download size 28.39 KB
Official Mirror distrib-coffee.ipsl.jussieu.fr
Increases the distribution's version according to the semantic versioning
rules (see the http://semver.org/ manpage) by inspecting the changelog.
More specifically, the plugin performs the following actions:
* at build time

Alternatives

Package Version Architecture Repository
perl-Dist-Zilla-Plugin-NextVersion-Semantic-0.2.5-3.mga6.noarch.rpm 0.2.5 noarch Mageia Core
perl-Dist-Zilla-Plugin-NextVersion-Semantic - - -

Requires

Name Value
perl >= 1:5.10.0
perl(CPAN::Changes) >= 0.200.0
perl(Dist::Zilla::Role::AfterRelease) -
perl(Dist::Zilla::Role::BeforeRelease) -
perl(Dist::Zilla::Role::FileMunger) -
perl(Dist::Zilla::Role::Plugin) -
perl(Dist::Zilla::Role::TextTemplate) -
perl(Dist::Zilla::Role::VersionProvider) -
perl(List::AllUtils) -
perl(List::Util) -
perl(Moose) -
perl(Moose::Role) -
perl(Moose::Util::TypeConstraints) -
perl(Perl::Version) -
perl(strict) -
perl(warnings) -
perl-base >= 2:5.22.2

Provides

Name Value
perl(Dist::Zilla::Plugin::NextVersion::Semantic) == 0.2.5
perl(Dist::Zilla::Plugin::NextVersion::Semantic::Incrementer) == 0.2.5
perl(Dist::Zilla::Plugin::PreviousVersion::Changelog) == 0.2.5
perl(Dist::Zilla::Role::YANICK::PreviousVersionProvider) == 0.2.5
perl-Dist-Zilla-Plugin-NextVersion-Semantic == 0.2.5-3.mga6

Download

Type URL
Binary Package perl-Dist-Zilla-Plugin-NextVersion-Semantic-0.2.5-3.mga6.noarch.rpm
Source Package perl-Dist-Zilla-Plugin-NextVersion-Semantic-0.2.5-3.mga6.src.rpm

Install Howto

  1. Enable Mageia Core repository on Install and Remove Software
  2. Update packages list:
    # urpmi.update -a
  3. Install perl-Dist-Zilla-Plugin-NextVersion-Semantic rpm package:
    # urpmi perl-Dist-Zilla-Plugin-NextVersion-Semantic

Files

Path
/usr/lib/perl5/vendor_perl/5.22.2/Dist/
/usr/lib/perl5/vendor_perl/5.22.2/Dist/Zilla/
/usr/lib/perl5/vendor_perl/5.22.2/Dist/Zilla/Plugin/
/usr/lib/perl5/vendor_perl/5.22.2/Dist/Zilla/Plugin/NextVersion/Semantic.pm
/usr/lib/perl5/vendor_perl/5.22.2/Dist/Zilla/Plugin/PreviousVersion/Changelog.pm
/usr/lib/perl5/vendor_perl/5.22.2/Dist/Zilla/Role/
/usr/lib/perl5/vendor_perl/5.22.2/Dist/Zilla/Role/YANICK/PreviousVersionProvider.pm
/usr/share/doc/perl-Dist-Zilla-Plugin-NextVersion-Semantic/Changes
/usr/share/doc/perl-Dist-Zilla-Plugin-NextVersion-Semantic/INSTALL
/usr/share/doc/perl-Dist-Zilla-Plugin-NextVersion-Semantic/LICENSE
/usr/share/doc/perl-Dist-Zilla-Plugin-NextVersion-Semantic/META.json
/usr/share/doc/perl-Dist-Zilla-Plugin-NextVersion-Semantic/META.yml
/usr/share/doc/perl-Dist-Zilla-Plugin-NextVersion-Semantic/README
/usr/share/doc/perl-Dist-Zilla-Plugin-NextVersion-Semantic/SIGNATURE
/usr/share/man/man3/Dist::Zilla::Plugin::NextVersion::Semantic.3pm.xz
/usr/share/man/man3/Dist::Zilla::Plugin::PreviousVersion::Changelog.3pm.xz
/usr/share/man/man3/Dist::Zilla::Role::YANICK::PreviousVersionProvider.3pm.xz

Changelog

2016-06-19 - pterjan <pterjan> 0.2.5-3.mga6
+ Revision: 1026427
- Rebuild for perl 5.22.2
2016-02-19 - umeabot <umeabot> 0.2.5-2.mga6
+ Revision: 968145
- Mageia 6 Mass Rebuild
2015-07-05 - sander85 <sander85> 0.2.5-1.mga6
+ Revision: 851345
- update to 0.2.5
2014-10-15 - umeabot <umeabot> 0.2.0-3.mga5
+ Revision: 740859
- Second Mageia 5 Mass Rebuild
- Mageia 5 Mass Rebuild
2014-09-01 - sander85 <sander85> 0.2.0-1.mga5
+ Revision: 670630
- update to 0.2.0
2013-10-19 - umeabot <umeabot> 0.1.3-2.mga4
+ Revision: 530278
- Mageia 4 Mass Rebuild
2013-07-21 - sander85 <sander85> 0.1.3-1.mga4
+ Revision: 456996
- update to 0.1.3

See Also

Package Description
perl-Dist-Zilla-Plugin-NoAutomatedTesting-0.80.0-5.mga6.noarch.rpm Avoid running under CPAN Testers
perl-Dist-Zilla-Plugin-NoSmartCommentsTests-0.9.0-2.mga7.noarch.rpm Make sure no Smart::Comments escape into the wild
perl-Dist-Zilla-Plugin-OSPrereqs-0.11.0-1.mga7.noarch.rpm List prereqs conditional on operating system
perl-Dist-Zilla-Plugin-OnlyCorePrereqs-0.24.0-3.mga6.noarch.rpm Check that no prerequisites are declared that are not part of core
perl-Dist-Zilla-Plugin-OurPkgVersion-0.120.0-2.mga7.noarch.rpm No line insertion and does Package version with our
perl-Dist-Zilla-Plugin-PerlTidy-0.210.0-3.mga6.noarch.rpm Perltidy your dist
perl-Dist-Zilla-Plugin-PkgVersion-Block-0.10.700-3.mga6.noarch.rpm PkgVersion for block packages
perl-Dist-Zilla-Plugin-Pod2Readme-0.4.0-1.mga7.noarch.rpm Generate README from Pod, as simply as possible
perl-Dist-Zilla-Plugin-PodLoom-5.1.0-3.mga6.noarch.rpm Process module documentation through Pod::Loom
perl-Dist-Zilla-Plugin-PodPurler-0.93.401-6.mga6.noarch.rpm Like PodWeaver, but more erratic and amateurish
perl-Dist-Zilla-Plugin-PodWeaver-4.8.0-2.mga6.noarch.rpm Do horrible things to POD, producing better docs
perl-Dist-Zilla-Plugin-Prepender-2.4.0-2.mga7.noarch.rpm prepend lines at the top of your perl files
perl-Dist-Zilla-Plugin-Prereqs-AuthorDeps-0.6.0-1.mga6.noarch.rpm Add Dist::Zilla authordeps to META files as develop prereqs
perl-Dist-Zilla-Plugin-Prereqs-FromCPANfile-0.80.0-3.mga6.noarch.rpm Parse cpanfile for prereqs
perl-Dist-Zilla-Plugin-Prereqs-MatchInstalled-1.1.3-1.mga7.noarch.rpm Depend on versions of modules the same as you have installed
Advertisement
Advertisement