perl-Dist-Zilla-Plugin-NoAutomatedTesting-0.80.0-5.mga6.noarch.rpm


Advertisement

Description

perl-Dist-Zilla-Plugin-NoAutomatedTesting - Avoid running under CPAN Testers

Property Value
Distribution Mageia Cauldron
Repository Mageia Core i586
Package name perl-Dist-Zilla-Plugin-NoAutomatedTesting
Package version 0.80.0
Package release 5.mga6
Package architecture noarch
Package type rpm
Installed size 28.75 KB
Download size 19.68 KB
Official Mirror distrib-coffee.ipsl.jussieu.fr
CPAN Testers are great and do a worthy and thankless job, testing all the
distributions uploaded to CPAN. But sometimes we don't want a distribution
to be tested by these gallant individuals.
Dist::Zilla::Plugin::NoAutomatedTesting is a the Dist::Zilla manpage plugin
that mungles 'Makefile.PL' to detect that it is being run by a CPAN Tester
and 'exit 0' if it is.
As this plugin mungles the 'Makefile.PL' it is imperative that it is
specified in 'dist.ini' AFTER '[MakeMaker]'.

Alternatives

Package Version Architecture Repository
perl-Dist-Zilla-Plugin-NoAutomatedTesting-0.80.0-5.mga6.noarch.rpm 0.80.0 noarch Mageia Core
perl-Dist-Zilla-Plugin-NoAutomatedTesting - - -

Requires

Name Value
perl(Dist::Zilla) >= 4.101.582
perl(Moose) -
perl-base >= 2:5.22.2

Provides

Name Value
perl(Dist::Zilla::Plugin::NoAutomatedTesting) == 0.80.0
perl-Dist-Zilla-Plugin-NoAutomatedTesting == 0.80.0-5.mga6

Download

Type URL
Binary Package perl-Dist-Zilla-Plugin-NoAutomatedTesting-0.80.0-5.mga6.noarch.rpm
Source Package perl-Dist-Zilla-Plugin-NoAutomatedTesting-0.80.0-5.mga6.src.rpm

Install Howto

  1. Enable Mageia Core repository on Install and Remove Software
  2. Update packages list:
    # urpmi.update -a
  3. Install perl-Dist-Zilla-Plugin-NoAutomatedTesting rpm package:
    # urpmi perl-Dist-Zilla-Plugin-NoAutomatedTesting

Files

Path
/usr/lib/perl5/vendor_perl/5.22.2/Dist/
/usr/lib/perl5/vendor_perl/5.22.2/Dist/Zilla/
/usr/lib/perl5/vendor_perl/5.22.2/Dist/Zilla/Plugin/NoAutomatedTesting.pm
/usr/share/doc/perl-Dist-Zilla-Plugin-NoAutomatedTesting/Changes
/usr/share/doc/perl-Dist-Zilla-Plugin-NoAutomatedTesting/LICENSE
/usr/share/doc/perl-Dist-Zilla-Plugin-NoAutomatedTesting/META.json
/usr/share/doc/perl-Dist-Zilla-Plugin-NoAutomatedTesting/META.yml
/usr/share/doc/perl-Dist-Zilla-Plugin-NoAutomatedTesting/MYMETA.yml
/usr/share/doc/perl-Dist-Zilla-Plugin-NoAutomatedTesting/README
/usr/share/man/man3/Dist::Zilla::Plugin::NoAutomatedTesting.3pm.xz

Changelog

2016-06-19 - pterjan <pterjan> 0.80.0-5.mga6
+ Revision: 1026434
- Rebuild for perl 5.22.2
2016-02-04 - umeabot <umeabot> 0.80.0-4.mga6
+ Revision: 934209
- Mageia 6 Mass Rebuild
2014-10-15 - umeabot <umeabot> 0.80.0-3.mga5
+ Revision: 748803
- Second Mageia 5 Mass Rebuild
- Mageia 5 Mass Rebuild
2014-02-08 - sander85 <sander85> 0.80.0-1.mga5
+ Revision: 586413
- update to 0.08
2013-10-19 - umeabot <umeabot> 0.60.0-2.mga4
+ Revision: 526972
- Mageia 4 Mass Rebuild

See Also

Package Description
perl-Dist-Zilla-Plugin-NoSmartCommentsTests-0.9.0-2.mga7.noarch.rpm Make sure no Smart::Comments escape into the wild
perl-Dist-Zilla-Plugin-OSPrereqs-0.11.0-1.mga7.noarch.rpm List prereqs conditional on operating system
perl-Dist-Zilla-Plugin-OnlyCorePrereqs-0.24.0-3.mga6.noarch.rpm Check that no prerequisites are declared that are not part of core
perl-Dist-Zilla-Plugin-OurPkgVersion-0.120.0-2.mga7.noarch.rpm No line insertion and does Package version with our
perl-Dist-Zilla-Plugin-PerlTidy-0.210.0-3.mga6.noarch.rpm Perltidy your dist
perl-Dist-Zilla-Plugin-PkgVersion-Block-0.10.700-3.mga6.noarch.rpm PkgVersion for block packages
perl-Dist-Zilla-Plugin-Pod2Readme-0.4.0-1.mga7.noarch.rpm Generate README from Pod, as simply as possible
perl-Dist-Zilla-Plugin-PodLoom-5.1.0-3.mga6.noarch.rpm Process module documentation through Pod::Loom
perl-Dist-Zilla-Plugin-PodPurler-0.93.401-6.mga6.noarch.rpm Like PodWeaver, but more erratic and amateurish
perl-Dist-Zilla-Plugin-PodWeaver-4.8.0-2.mga6.noarch.rpm Do horrible things to POD, producing better docs
perl-Dist-Zilla-Plugin-Prepender-2.4.0-2.mga7.noarch.rpm prepend lines at the top of your perl files
perl-Dist-Zilla-Plugin-Prereqs-AuthorDeps-0.6.0-1.mga6.noarch.rpm Add Dist::Zilla authordeps to META files as develop prereqs
perl-Dist-Zilla-Plugin-Prereqs-FromCPANfile-0.80.0-3.mga6.noarch.rpm Parse cpanfile for prereqs
perl-Dist-Zilla-Plugin-Prereqs-MatchInstalled-1.1.3-1.mga7.noarch.rpm Depend on versions of modules the same as you have installed
perl-Dist-Zilla-Plugin-Prereqs-MatchInstalled-All-1.1.1-1.mga7.noarch.rpm Upgrade ALL your dependencies to the ones you have installed
Advertisement
Advertisement