perl-Dist-Zilla-Plugin-OnlyCorePrereqs-0.24.0-3.mga6.noarch.rpm


Advertisement

Description

perl-Dist-Zilla-Plugin-OnlyCorePrereqs - Check that no prerequisites are declared that are not part of core

Property Value
Distribution Mageia Cauldron
Repository Mageia Core i586
Package name perl-Dist-Zilla-Plugin-OnlyCorePrereqs
Package version 0.24.0
Package release 3.mga6
Package architecture noarch
Package type rpm
Installed size 104.94 KB
Download size 31.87 KB
Official Mirror distrib-coffee.ipsl.jussieu.fr
'[OnlyCorePrereqs]' is a the Dist::Zilla manpage plugin that checks at
build time if you have any declared prerequisites that are not shipped with
Perl.
You can specify the first Perl version to check against, and which
prerequisite phase(s) are significant.
If the check fails, the build is aborted.

Alternatives

Package Version Architecture Repository
perl-Dist-Zilla-Plugin-OnlyCorePrereqs-0.24.0-3.mga6.noarch.rpm 0.24.0 noarch Mageia Core
perl-Dist-Zilla-Plugin-OnlyCorePrereqs - - -

Requires

Name Value
perl(CPAN::DistnameInfo) -
perl(CPAN::Meta::Requirements) >= 2.121.0
perl(Dist::Zilla::Plugin::MetaResources) >= 4.300.39
perl(Dist::Zilla::Role::AfterBuild) -
perl(Encode) -
perl(HTTP::Headers) -
perl(HTTP::Tiny) -
perl(Module::CoreList) >= 5.201.502.140
perl(Moose) -
perl(Moose::Util::TypeConstraints) -
perl(MooseX::Types::Perl) >= 0.101.340
perl(YAML::Tiny) -
perl(namespace::autoclean) -
perl(strict) -
perl(version) -
perl(warnings) -
perl-base >= 2:5.22.2

Provides

Name Value
perl(Dist::Zilla::Plugin::OnlyCorePrereqs) == 0.24.0
perl-Dist-Zilla-Plugin-OnlyCorePrereqs == 0.24.0-3.mga6

Download

Type URL
Binary Package perl-Dist-Zilla-Plugin-OnlyCorePrereqs-0.24.0-3.mga6.noarch.rpm
Source Package perl-Dist-Zilla-Plugin-OnlyCorePrereqs-0.24.0-3.mga6.src.rpm

Install Howto

  1. Enable Mageia Core repository on Install and Remove Software
  2. Update packages list:
    # urpmi.update -a
  3. Install perl-Dist-Zilla-Plugin-OnlyCorePrereqs rpm package:
    # urpmi perl-Dist-Zilla-Plugin-OnlyCorePrereqs

Files

Path
/usr/lib/perl5/vendor_perl/5.22.2/Dist/
/usr/lib/perl5/vendor_perl/5.22.2/Dist/Zilla/
/usr/lib/perl5/vendor_perl/5.22.2/Dist/Zilla/Plugin/OnlyCorePrereqs.pm
/usr/share/doc/perl-Dist-Zilla-Plugin-OnlyCorePrereqs/CONTRIBUTING
/usr/share/doc/perl-Dist-Zilla-Plugin-OnlyCorePrereqs/Changes
/usr/share/doc/perl-Dist-Zilla-Plugin-OnlyCorePrereqs/INSTALL
/usr/share/doc/perl-Dist-Zilla-Plugin-OnlyCorePrereqs/LICENSE
/usr/share/doc/perl-Dist-Zilla-Plugin-OnlyCorePrereqs/META.json
/usr/share/doc/perl-Dist-Zilla-Plugin-OnlyCorePrereqs/META.yml
/usr/share/doc/perl-Dist-Zilla-Plugin-OnlyCorePrereqs/README
/usr/share/man/man3/Dist::Zilla::Plugin::OnlyCorePrereqs.3pm.xz

Changelog

2016-06-19 - pterjan <pterjan> 0.24.0-3.mga6
+ Revision: 1026452
- Rebuild for perl 5.22.2
2016-02-20 - umeabot <umeabot> 0.24.0-2.mga6
+ Revision: 971799
- Mageia 6 Mass Rebuild
2015-10-19 - shlomif <shlomif> 0.24.0-1.mga6
+ Revision: 892728
- imported package perl-Dist-Zilla-Plugin-OnlyCorePrereqs
2015-10-19 - cpan2dist 0.024-1mga
- initial mageia release, generated with cpan2dist

See Also

Package Description
perl-Dist-Zilla-Plugin-OurPkgVersion-0.120.0-2.mga7.noarch.rpm No line insertion and does Package version with our
perl-Dist-Zilla-Plugin-PerlTidy-0.210.0-3.mga6.noarch.rpm Perltidy your dist
perl-Dist-Zilla-Plugin-PkgVersion-Block-0.10.700-3.mga6.noarch.rpm PkgVersion for block packages
perl-Dist-Zilla-Plugin-Pod2Readme-0.4.0-1.mga7.noarch.rpm Generate README from Pod, as simply as possible
perl-Dist-Zilla-Plugin-PodLoom-5.1.0-3.mga6.noarch.rpm Process module documentation through Pod::Loom
perl-Dist-Zilla-Plugin-PodPurler-0.93.401-6.mga6.noarch.rpm Like PodWeaver, but more erratic and amateurish
perl-Dist-Zilla-Plugin-PodWeaver-4.8.0-2.mga6.noarch.rpm Do horrible things to POD, producing better docs
perl-Dist-Zilla-Plugin-Prepender-2.4.0-2.mga7.noarch.rpm prepend lines at the top of your perl files
perl-Dist-Zilla-Plugin-Prereqs-AuthorDeps-0.6.0-1.mga6.noarch.rpm Add Dist::Zilla authordeps to META files as develop prereqs
perl-Dist-Zilla-Plugin-Prereqs-FromCPANfile-0.80.0-3.mga6.noarch.rpm Parse cpanfile for prereqs
perl-Dist-Zilla-Plugin-Prereqs-MatchInstalled-1.1.3-1.mga7.noarch.rpm Depend on versions of modules the same as you have installed
perl-Dist-Zilla-Plugin-Prereqs-MatchInstalled-All-1.1.1-1.mga7.noarch.rpm Upgrade ALL your dependencies to the ones you have installed
perl-Dist-Zilla-Plugin-Prereqs-Plugins-1.3.3-1.mga7.noarch.rpm Add all Dist::Zilla plugins presently in use as prerequisites
perl-Dist-Zilla-Plugin-Prereqs-Recommend-MatchInstalled-0.3.3-2.mga7.noarch.rpm Advertise versions of things you have as soft dependencies
perl-Dist-Zilla-Plugin-Prereqs-Soften-0.6.3-2.mga7.noarch.rpm Downgrade listed dependencies to recommendations if present
Advertisement
Advertisement