perl-Dist-Zilla-Plugin-Prereqs-SyncVersions-0.3.2-2.mga7.noarch.rpm


Advertisement

Description

perl-Dist-Zilla-Plugin-Prereqs-SyncVersions - Homogenize prerequisites so dependency versions are consistent

Property Value
Distribution Mageia Cauldron
Repository Mageia Core i586
Package filename perl-Dist-Zilla-Plugin-Prereqs-SyncVersions-0.3.2-2.mga7.noarch.rpm
Package name perl-Dist-Zilla-Plugin-Prereqs-SyncVersions
Package version 0.3.2
Package release 2.mga7
Package architecture noarch
Package type rpm
Category Development/Perl
Homepage http://search.cpan.org/dist/Dist-Zilla-Plugin-Prereqs-SyncVersions
License GPL+ or Artistic
Maintainer -
Download size 27.68 KB
Installed size 84.25 KB
This module exists to pose mostly as a workaround for potential bugs in
downstream tool-chains.
Namely, "CPAN.pm" is confused when it sees:
runtime.requires : Foo >= 5.0
test.requires    : Foo >= 6.0
It doesn't know what to do.
This is an easy enough problem to solve if you're using "[Prereqs]"
directly, and "[AutoPrereqs]" already does the right thing, but it gets
messier when you're working with plugins that inject their own
prerequisites
<https://github.com/dagolden/Path-Tiny/commit/c620171db96597456a182ea608
8a24d8de5debf6>
So this plugin will homogenize dependencies to be the same version in
all phases which infer the dependency, matching the largest one found,
so the above becomes:
runtime.requires : Foo >= 6.0
test.requires    : Foo >= 6.0

Alternatives

Package Version Architecture Repository
perl-Dist-Zilla-Plugin-Prereqs-SyncVersions-0.3.2-2.mga7.noarch.rpm 0.3.2 noarch Mageia Core
perl-Dist-Zilla-Plugin-Prereqs-SyncVersions - - -

Requires

Name Value
perl >= 0:5.006
perl(Dist::Zilla::Role::PrereqSource) -
perl(Moose) -
perl(MooseX::Types::Moose) -
perl(strict) -
perl(version) -
perl(warnings) -
perl-base >= 2:5.28.0

Provides

Name Value
perl(Dist::Zilla::Plugin::Prereqs::SyncVersions) == 0.3.2
perl-Dist-Zilla-Plugin-Prereqs-SyncVersions == 0.3.2-2.mga7

Download

Type URL
Mirror distrib-coffee.ipsl.jussieu.fr
Binary Package perl-Dist-Zilla-Plugin-Prereqs-SyncVersions-0.3.2-2.mga7.noarch.rpm
Source Package perl-Dist-Zilla-Plugin-Prereqs-SyncVersions-0.3.2-2.mga7.src.rpm

Install Howto

  1. Enable Mageia Core repository on Install and Remove Software
  2. Update packages list:
    # urpmi.update -a
  3. Install perl-Dist-Zilla-Plugin-Prereqs-SyncVersions rpm package:
    # urpmi perl-Dist-Zilla-Plugin-Prereqs-SyncVersions

Files

Path
/usr/share/doc/perl-Dist-Zilla-Plugin-Prereqs-SyncVersions/Changes
/usr/share/doc/perl-Dist-Zilla-Plugin-Prereqs-SyncVersions/LICENSE
/usr/share/doc/perl-Dist-Zilla-Plugin-Prereqs-SyncVersions/META.json
/usr/share/doc/perl-Dist-Zilla-Plugin-Prereqs-SyncVersions/META.yml
/usr/share/doc/perl-Dist-Zilla-Plugin-Prereqs-SyncVersions/MYMETA.yml
/usr/share/doc/perl-Dist-Zilla-Plugin-Prereqs-SyncVersions/README
/usr/share/man/man3/Dist::Zilla::Plugin::Prereqs::SyncVersions.3pm.xz
/usr/share/perl5/vendor_perl/Dist/
/usr/share/perl5/vendor_perl/Dist/Zilla/
/usr/share/perl5/vendor_perl/Dist/Zilla/Plugin/
/usr/share/perl5/vendor_perl/Dist/Zilla/Plugin/Prereqs/SyncVersions.pm

Changelog

2018-09-20 - umeabot <umeabot> 0.3.2-2.mga7
(not released yet)
+ Revision: 1283251
- Mageia 7 Mass Rebuild
2017-07-21 - sander85 <sander85> 0.3.2-1.mga7
+ Revision: 1125975
- update to 0.003002
2016-06-19 - pterjan <pterjan> 0.3.1-3.mga6
+ Revision: 1026556
- Rebuild for perl 5.22.2
2016-02-18 - umeabot <umeabot> 0.3.1-2.mga6
+ Revision: 966492
- Mageia 6 Mass Rebuild

See Also

Package Description
perl-Dist-Zilla-Plugin-Prereqs-Upgrade-0.1.1-2.mga7.noarch.rpm Upgrade existing prerequisites in place
perl-Dist-Zilla-Plugin-PromptIfStale-0.55.0-2.mga7.noarch.rpm Check at build/release time if modules are out of date
perl-Dist-Zilla-Plugin-PurePerlTests-0.60.0-3.mga7.noarch.rpm Run all your tests twice, once with XS code and once with pure Perl
perl-Dist-Zilla-Plugin-Readme-Brief-0.3.2-2.mga7.noarch.rpm Provide a short simple README with just the essentials
perl-Dist-Zilla-Plugin-ReadmeAnyFromPod-0.163.250-2.mga7.noarch.rpm Automatically convert POD to a README in any format for Dist::Zilla
perl-Dist-Zilla-Plugin-ReadmeFromPod-0.370.0-1.mga7.noarch.rpm Automatically convert POD to a README for Dist::Zilla
perl-Dist-Zilla-Plugin-ReadmeMarkdownFromPod-0.141.140-6.mga7.noarch.rpm Automatically convert POD to a README.mkdn for Dist::Zilla
perl-Dist-Zilla-Plugin-RemovePrereqs-Provided-0.1.1-2.mga7.noarch.rpm Remove prerequisites that are already provided
perl-Dist-Zilla-Plugin-ReportPhase-0.30.0-8.mga7.noarch.rpm Report whats going on
perl-Dist-Zilla-Plugin-ReportVersions-1.110.730-8.mga7.noarch.rpm Write a test that reports used module versions
perl-Dist-Zilla-Plugin-ReportVersions-Tiny-1.120.0-4.mga7.noarch.rpm Reports dependency versions during testing
perl-Dist-Zilla-Plugin-Repository-0.240.0-1.mga7.noarch.rpm Automatically sets repository URL from svn/svk/Git checkout for Dist::Zilla
perl-Dist-Zilla-Plugin-RequiresExternal-1.8.0-2.mga7.noarch.rpm Make dists require external commands
perl-Dist-Zilla-Plugin-RewriteVersion-Sanitized-0.1.6-2.mga7.noarch.rpm RewriteVersion but force normalizing ENV{V} and other sources
perl-Dist-Zilla-Plugin-RewriteVersion-Transitional-0.9.0-2.mga7.noarch.rpm Ease the transition to [BumpVersionAfterRelease] in your distribution
Advertisement
Advertisement