perl-Dist-Zilla-Plugin-UploadToGoogleCode-0.4.0-4.mga7.noarch.rpm


Advertisement

Description

perl-Dist-Zilla-Plugin-UploadToGoogleCode - Upload your dist to Google Code (experimental)

Property Value
Distribution Mageia Cauldron
Repository Mageia Core i586
Package filename perl-Dist-Zilla-Plugin-UploadToGoogleCode-0.4.0-4.mga7.noarch.rpm
Package name perl-Dist-Zilla-Plugin-UploadToGoogleCode
Package version 0.4.0
Package release 4.mga7
Package architecture noarch
Package type rpm
Category Development/Perl
Homepage http://search.cpan.org/dist/Dist-Zilla-Plugin-UploadToGoogleCode
License GPL+ or Artistic
Maintainer -
Download size 20.85 KB
Installed size 33.24 KB
This plugin looks for the Google Code project name in _dist.ini_, and gets
your Google Code credentials from _~/.googlecode-identity_ (which can be
GnuPG-encrypted; see the Config::Identity manpage).
If any configuration is missing, it will prompt you to enter your username
and password during the BeforeRelease phase. Entering a blank username or
password will abort the release.

Alternatives

Package Version Architecture Repository
perl-Dist-Zilla-Plugin-UploadToGoogleCode-0.4.0-4.mga7.noarch.rpm 0.4.0 noarch Mageia Core
perl-Dist-Zilla-Plugin-UploadToGoogleCode - - -

Requires

Name Value
perl(CPAN::Changes) -
perl(Config::Identity) -
perl(Dist::Zilla::File::OnDisk) -
perl(Dist::Zilla::Role::BeforeRelease) -
perl(Dist::Zilla::Role::Releaser) -
perl(File::pushd) -
perl(Google::Code::Upload) >= 0.6.0
perl(Moose) -
perl(Moose::Util::TypeConstraints) -
perl(Try::Tiny) -
perl(namespace::autoclean) -
perl(strict) -
perl(warnings) -
perl-base >= 2:5.28.0

Provides

Name Value
perl(Dist::Zilla::Plugin::UploadToGoogleCode) == 0.4.0
perl-Dist-Zilla-Plugin-UploadToGoogleCode == 0.4.0-4.mga7

Download

Type URL
Mirror distrib-coffee.ipsl.jussieu.fr
Binary Package perl-Dist-Zilla-Plugin-UploadToGoogleCode-0.4.0-4.mga7.noarch.rpm
Source Package perl-Dist-Zilla-Plugin-UploadToGoogleCode-0.4.0-4.mga7.src.rpm

Install Howto

  1. Enable Mageia Core repository on Install and Remove Software
  2. Update packages list:
    # urpmi.update -a
  3. Install perl-Dist-Zilla-Plugin-UploadToGoogleCode rpm package:
    # urpmi perl-Dist-Zilla-Plugin-UploadToGoogleCode

Files

Path
/usr/share/doc/perl-Dist-Zilla-Plugin-UploadToGoogleCode/Changes
/usr/share/doc/perl-Dist-Zilla-Plugin-UploadToGoogleCode/LICENSE
/usr/share/doc/perl-Dist-Zilla-Plugin-UploadToGoogleCode/META.json
/usr/share/doc/perl-Dist-Zilla-Plugin-UploadToGoogleCode/META.yml
/usr/share/doc/perl-Dist-Zilla-Plugin-UploadToGoogleCode/README.mkdn
/usr/share/man/man3/Dist::Zilla::Plugin::UploadToGoogleCode.3pm.xz
/usr/share/perl5/vendor_perl/Dist/
/usr/share/perl5/vendor_perl/Dist/Zilla/
/usr/share/perl5/vendor_perl/Dist/Zilla/Plugin/UploadToGoogleCode.pm

Changelog

2018-09-19 - umeabot <umeabot> 0.4.0-4.mga7
(not released yet)
+ Revision: 1267723
- Mageia 7 Mass Rebuild
2016-06-19 - pterjan <pterjan> 0.4.0-3.mga6
+ Revision: 1026654
- Rebuild for perl 5.22.2
2016-02-18 - umeabot <umeabot> 0.4.0-2.mga6
+ Revision: 967369
- Mageia 6 Mass Rebuild

See Also

Package Description
perl-Dist-Zilla-Plugin-UseUnsafeInc-0.1.0-2.mga7.noarch.rpm Indicates the value of PERL_USE_UNSAFE_INC to use during installation
perl-Dist-Zilla-Plugin-VerifyPhases-0.16.0-3.mga7.noarch.rpm Compare data and files at different phases of the distribution build process
perl-Dist-Zilla-Plugin-VersionFromMainModule-0.40.0-2.mga7.noarch.rpm Set the distribution version from your main module's $VERSION
perl-Dist-Zilla-PluginBundle-AJGB-2.40.0-4.mga7.noarch.rpm Pod::Weaver configuration for AJGB
perl-Dist-Zilla-PluginBundle-AMD-0.11.0-9.mga7.noarch.rpm Build your distributions like AMD does
perl-Dist-Zilla-PluginBundle-AVAR-0.320.0-4.mga7.noarch.rpm Use L<Dist::Zilla> like AVAR does
perl-Dist-Zilla-PluginBundle-Author-CJM-6.0.0-2.mga7.noarch.rpm Get distribution version from its main_module
perl-Dist-Zilla-PluginBundle-Author-ETHER-0.150.0-1.mga8.noarch.rpm Mint distributions like ETHER does
perl-Dist-Zilla-PluginBundle-Author-JQUELIN-3.5.0-3.mga7.noarch.rpm Build & release a distribution like jquelin
perl-Dist-Zilla-PluginBundle-Author-KENTNL-Lite-2.1.1-3.mga7.noarch.rpm A Minimal Build-Only replacement for
perl-Dist-Zilla-PluginBundle-Author-LESPEA-1.8.0-6.mga7.noarch.rpm My Dist::Zilla configs
perl-Dist-Zilla-PluginBundle-Author-OLIVER-1.122.720-9.mga7.noarch.rpm Dists like OLIVER's
perl-Dist-Zilla-PluginBundle-Author-RTHOMPSON-0.161.990-2.mga7.noarch.rpm RTHOMPSON's Dist::Zilla Configuration
perl-Dist-Zilla-PluginBundle-Author-RWSTAUNER-6.2.0-2.mga7.noarch.rpm RWSTAUNER's Pod::Weaver config
perl-Dist-Zilla-PluginBundle-BINGOS-0.200.0-4.mga7.noarch.rpm BeLike::BINGOS when you build your dists
Advertisement
Advertisement