perl-Dist-Zilla-Util-ExpandINI-0.3.3-2.mga7.noarch.rpm


Advertisement

Description

perl-Dist-Zilla-Util-ExpandINI - Read an INI file and expand bundles as you go

Property Value
Distribution Mageia Cauldron
Repository Mageia Core i586
Package filename perl-Dist-Zilla-Util-ExpandINI-0.3.3-2.mga7.noarch.rpm
Package name perl-Dist-Zilla-Util-ExpandINI
Package version 0.3.3
Package release 2.mga7
Package architecture noarch
Package type rpm
Category Development/Perl
Homepage http://search.cpan.org/dist/Dist-Zilla-Util-ExpandINI
License GPL+ or Artistic
Maintainer -
Download size 31.87 KB
Installed size 97.79 KB
This module builds upon the previous work ":Util::BundleInfo" ( Which
can extract configuration from a bundle in a manner similar to how
"dzil" does it ) and integrates it with some *very* minimal "INI"
handling to provide a tool capable of generating bundle-free "dist.ini"
files from bundle-using "dist.ini" files!
At present its very naïve and only keeps semantic ordering, and I've
probably gotten something wrong due to cutting the complexity of
Config::MVP out of the loop.
But at this stage, bundles are the *only* thing modified in transit.

Alternatives

Package Version Architecture Repository
perl-Dist-Zilla-Util-ExpandINI-0.3.3-2.mga7.noarch.rpm 0.3.3 noarch Mageia Core
perl-Dist-Zilla-Util-ExpandINI - - -

Requires

Name Value
perl >= 0:5.006
perl(Carp) -
perl(Config::INI::Reader) -
perl(Config::INI::Writer) >= 0.24.0
perl(Dist::Zilla::Util::BundleInfo) >= 1.1.0
perl(Mixin::Linewise) -
perl(Module::Runtime) -
perl(Moo) >= 1.0.8
perl(Scalar::Util) -
perl(parent) -
perl(strict) -
perl(warnings) -
perl-base >= 2:5.28.0

Provides

Name Value
perl(Dist::Zilla::Util::ExpandINI) == 0.3.3
perl(Dist::Zilla::Util::ExpandINI::Reader) == 0.3.3
perl(Dist::Zilla::Util::ExpandINI::Writer) == 0.3.3
perl-Dist-Zilla-Util-ExpandINI == 0.3.3-2.mga7

Download

Type URL
Mirror distrib-coffee.ipsl.jussieu.fr
Binary Package perl-Dist-Zilla-Util-ExpandINI-0.3.3-2.mga7.noarch.rpm
Source Package perl-Dist-Zilla-Util-ExpandINI-0.3.3-2.mga7.src.rpm

Install Howto

  1. Enable Mageia Core repository on Install and Remove Software
  2. Update packages list:
    # urpmi.update -a
  3. Install perl-Dist-Zilla-Util-ExpandINI rpm package:
    # urpmi perl-Dist-Zilla-Util-ExpandINI

Files

Path
/usr/share/doc/perl-Dist-Zilla-Util-ExpandINI/Changes
/usr/share/doc/perl-Dist-Zilla-Util-ExpandINI/LICENSE
/usr/share/doc/perl-Dist-Zilla-Util-ExpandINI/META.json
/usr/share/doc/perl-Dist-Zilla-Util-ExpandINI/META.yml
/usr/share/doc/perl-Dist-Zilla-Util-ExpandINI/MYMETA.yml
/usr/share/doc/perl-Dist-Zilla-Util-ExpandINI/README
/usr/share/man/man3/Dist::Zilla::Util::ExpandINI.3pm.xz
/usr/share/man/man3/Dist::Zilla::Util::ExpandINI::Reader.3pm.xz
/usr/share/man/man3/Dist::Zilla::Util::ExpandINI::Writer.3pm.xz
/usr/share/perl5/vendor_perl/Dist/
/usr/share/perl5/vendor_perl/Dist/Zilla/
/usr/share/perl5/vendor_perl/Dist/Zilla/Util/ExpandINI.pm
/usr/share/perl5/vendor_perl/Dist/Zilla/Util/ExpandINI/Reader.pm
/usr/share/perl5/vendor_perl/Dist/Zilla/Util/ExpandINI/Writer.pm

Changelog

2018-09-20 - umeabot <umeabot> 0.3.3-2.mga7
(not released yet)
+ Revision: 1283503
- Mageia 7 Mass Rebuild
2017-07-21 - sander85 <sander85> 0.3.3-1.mga7
+ Revision: 1126043
- update to 0.003003
2016-06-19 - pterjan <pterjan> 0.3.2-2.mga6
+ Revision: 1026786
- Rebuild for perl 5.22.2
2016-04-29 - shlomif <shlomif> 0.3.2-1.mga6
+ Revision: 1007806
- update to 0.003002
2016-02-18 - umeabot <umeabot> 0.3.1-2.mga6
+ Revision: 966525
- Mageia 6 Mass Rebuild

See Also

Package Description
perl-Dist-Zilla-Util-FileGenerator-0.120.90-8.mga7.noarch.rpm Helper to generate files with little repetition in a PluginBundle
perl-Dist-Zilla-Util-Git-Wrapper-0.4.2-2.mga7.noarch.rpm A role to make adding a ->git method easy, and low-complexity
perl-Dist-Zilla-Util-Test-KENTNL-1.5.14-3.mga7.noarch.rpm KENTNL's DZil plugin testing tool
perl-Dist-Zilla-UtilRole-MaybeZilla-0.2.0-2.mga7.noarch.rpm Soft-dependency on Dist::Zilla for Utilities
perl-Dist-Zooky-0.240.0-2.mga7.noarch.rpm The other command that Dist::Zooky uses
perl-Domain-PublicSuffix-0.150.0-1.mga8.noarch.rpm Default PublicSuffix data file
perl-Dpkg-1.19.6-2.mga8.i586.rpm Package maintenance system for Debian Linux
perl-Dumbbench-0.111.0-3.mga7.noarch.rpm Benchmarks a string of Perl code
perl-EBook-EPUB-0.600.0-10.mga7.noarch.rpm Perl module for generating EPUB documents
perl-EBook-Tools-0.5.4-4.mga7.noarch.rpm E-Book creation, modification, and unpacking
perl-EV-4.270.0-2.mga8.i586.rpm Wrapper for the libev high-performance event loop library
perl-Emacs-Run-0.150.0-8.mga7.noarch.rpm Routines for just for writing tests of Emacs::Run
perl-Email-Abstract-3.8.0-4.mga7.noarch.rpm Unified interface to mail representations
perl-Email-Address-1.912.0-1.mga7.noarch.rpm RFC 2822 Address Parsing and Creation
perl-Email-Address-List-0.60.0-1.mga7.noarch.rpm RFC close address list parsing
Advertisement
Advertisement