perl-IO-Pipely-0.5.0-6.mga6.noarch.rpm


Advertisement

Description

perl-IO-Pipely - Portably create pipe() or pipe-like handles, one way or another

Property Value
Distribution Mageia Cauldron
Repository Mageia Core i586
Package name perl-IO-Pipely
Package version 0.5.0
Package release 6.mga6
Package architecture noarch
Package type rpm
Installed size 55.39 KB
Download size 27.17 KB
Official Mirror distrib-coffee.ipsl.jussieu.fr
Pipes are troublesome beasts because there are a few different,
incompatible ways to create them. Not all platforms support all ways,
and some platforms may have hidden difficulties like incomplete or buggy
support.
IO::Pipely provides a couple functions to portably create one- and
two-way pipes and pipe-like socket pairs. It acknowledges and works
around known platform issues so you don't have to.
On the other hand, it doesn't work around unknown issues, so please
report any problems early and often.
IO::Pipely currently understands pipe(), UNIX-domain socketpair() and
regular IPv4 localhost sockets. This covers every platform tested so
far, but it's hardly complete. Please help support other mechanisms,
such as INET-domain socketpair() and IPv6 localhost sockets.
IO::Pipely will use different kinds of pipes or sockets depending on the
operating system's capabilities and the number of directions requested.
The autodetection may be overridden by specifying a particular pipe
type.

Alternatives

Package Version Architecture Repository
perl-IO-Pipely-0.5.0-6.mga6.noarch.rpm 0.5.0 noarch Mageia Core
perl-IO-Pipely - - -

Requires

Name Value
perl(Errno) -
perl(Exporter) >= 5.680.0
perl(Fcntl) >= 1.60.0
perl(IO::Socket) >= 1.310.0
perl(Symbol) >= 1.60.0
perl(base) >= 2.180.0
perl(strict) -
perl(warnings) -
perl-base >= 2:5.22.2

Provides

Name Value
perl(IO::Pipely) == 0.5.0
perl-IO-Pipely == 0.5.0-6.mga6

Download

Type URL
Binary Package perl-IO-Pipely-0.5.0-6.mga6.noarch.rpm
Source Package perl-IO-Pipely-0.5.0-6.mga6.src.rpm

Install Howto

  1. Enable Mageia Core repository on Install and Remove Software
  2. Update packages list:
    # urpmi.update -a
  3. Install perl-IO-Pipely rpm package:
    # urpmi perl-IO-Pipely

Files

Path
/usr/lib/perl5/vendor_perl/5.22.2/IO/Pipely.pm
/usr/share/doc/perl-IO-Pipely/CHANGES
/usr/share/doc/perl-IO-Pipely/LICENSE
/usr/share/doc/perl-IO-Pipely/META.json
/usr/share/doc/perl-IO-Pipely/META.yml
/usr/share/doc/perl-IO-Pipely/MYMETA.yml
/usr/share/doc/perl-IO-Pipely/README
/usr/share/man/man3/IO::Pipely.3pm.xz

Changelog

2016-06-19 - pterjan <pterjan> 0.5.0-6.mga6
+ Revision: 1028765
- Rebuild for perl 5.22.2
2016-02-08 - umeabot <umeabot> 0.5.0-5.mga6
+ Revision: 944785
- Mageia 6 Mass Rebuild
2014-10-15 - umeabot <umeabot> 0.5.0-4.mga5
+ Revision: 743397
- Second Mageia 5 Mass Rebuild
2014-09-16 - umeabot <umeabot> 0.5.0-3.mga5
+ Revision: 685070
- Mageia 5 Mass Rebuild
2013-10-19 - umeabot <umeabot> 0.5.0-2.mga4
+ Revision: 532504
- Mageia 4 Mass Rebuild
2013-08-20 - sander85 <sander85> 0.5.0-1.mga4
+ Revision: 468548
- imported package perl-IO-Pipely

See Also

Package Description
perl-IO-Prompt-0.997.4-1.mga7.noarch.rpm Interactively prompt for user input
perl-IO-Prompt-Hooked-0.100.0-6.mga6.noarch.rpm Simple prompting with validation hooks
perl-IO-Prompt-Tiny-0.3.0-3.mga6.noarch.rpm Prompt for user input with a default option
perl-IO-Pty-Easy-0.100.0-1.mga7.noarch.rpm Easy interface to IO::Pty
perl-IO-SessionData-1.30.0-6.mga6.noarch.rpm Supporting module for SOAP::Lite
perl-IO-Socket-DNS-0.21.0-7.mga6.noarch.rpm IO::Socket like interface using DNS queries
perl-IO-Socket-INET6-2.720.0-6.mga6.noarch.rpm Object interface for AF_INET|AF_INET6 domain sockets
perl-IO-Socket-IP-0.390.0-1.mga7.noarch.rpm A drop-in replacement for C<IO::Socket::INET> supporting
perl-IO-Socket-Multicast-1.120.0-18.mga7.i586.rpm Send and receive multicast messages
perl-IO-Socket-PortState-0.30.0-6.mga6.noarch.rpm Perl extension for checking the open or closed status of a port
perl-IO-Socket-SSL-2.58.0-1.mga7.noarch.rpm Nearly transparent SSL encapsulation for IO::Socket::INET
perl-IO-Socket-Socks-0.740.0-1.mga7.noarch.rpm Provides a way to create socks client or server both 4 and 5 version
perl-IO-Socket-TIPC-1.80.0-14.mga7.i586.rpm Struct sockaddr_tipc class
perl-IO-Socket-Telnet-0.40.0-9.mga7.noarch.rpm Transparent telnet negotiation for IO::Socket::INET
perl-IO-Socket-Timeout-0.320.0-3.mga6.noarch.rpm IO::Socket with read/write timeout
Advertisement
Advertisement