perl-JavaScript-Minifier-1.140.0-3.mga6.noarch.rpm


Advertisement

Description

perl-JavaScript-Minifier - Perl extension for minifying JavaScript code

Property Value
Distribution Mageia Cauldron
Repository Mageia Core i586
Package name perl-JavaScript-Minifier
Package version 1.140.0
Package release 3.mga6
Package architecture noarch
Package type rpm
Installed size 61.27 KB
Download size 25.75 KB
Official Mirror distrib-coffee.ipsl.jussieu.fr
This module removes unnecessary whitespace from JavaScript code. The
primary requirement developing this module is to not break working code: if
working JavaScript is in input then working JavaScript is output. It is ok
if the input has missing semi-colons, snips like '++ +' or '12
.toString()', for example. Internet Explorer conditional comments are
copied to the output but the code inside these comments will not be
minified.
The ECMAScript specifications allow for many different whitespace
characters: space, horizontal tab, vertical tab, new line, carriage return,
form feed, and paragraph separator. This module understands all of these as
whitespace except for vertical tab and paragraph separator. These two types
of whitespace are not minimized.
For static JavaScript files, it is recommended that you minify during the
build stage of web deployment. If you minify on-the-fly then it might be a
good idea to cache the minified file. Minifying static files on-the-fly
repeatedly is wasteful.

Alternatives

Package Version Architecture Repository
perl-JavaScript-Minifier-1.140.0-3.mga6.noarch.rpm 1.140.0 noarch Mageia Core
perl-JavaScript-Minifier - - -

Requires

Name Value
perl(Exporter) -
perl(strict) -
perl(warnings) -
perl-base >= 2:5.22.2

Provides

Name Value
perl(JavaScript::Minifier) == 1.140.0
perl-JavaScript-Minifier == 1.140.0-3.mga6

Download

Type URL
Binary Package perl-JavaScript-Minifier-1.140.0-3.mga6.noarch.rpm
Source Package perl-JavaScript-Minifier-1.140.0-3.mga6.src.rpm

Install Howto

  1. Enable Mageia Core repository on Install and Remove Software
  2. Update packages list:
    # urpmi.update -a
  3. Install perl-JavaScript-Minifier rpm package:
    # urpmi perl-JavaScript-Minifier

Files

Path
/usr/lib/perl5/vendor_perl/5.22.2/JavaScript/Minifier.pm
/usr/share/doc/perl-JavaScript-Minifier/Changes
/usr/share/doc/perl-JavaScript-Minifier/INSTALL
/usr/share/doc/perl-JavaScript-Minifier/LICENSE
/usr/share/doc/perl-JavaScript-Minifier/META.yml
/usr/share/doc/perl-JavaScript-Minifier/MYMETA.yml
/usr/share/doc/perl-JavaScript-Minifier/README
/usr/share/doc/perl-JavaScript-Minifier/examples/minify.pl
/usr/share/man/man3/JavaScript::Minifier.3pm.xz

Changelog

2016-06-19 - pterjan <pterjan> 1.140.0-3.mga6
+ Revision: 1028818
- Rebuild for perl 5.22.2
2016-02-19 - umeabot <umeabot> 1.140.0-2.mga6
+ Revision: 968339
- Mageia 6 Mass Rebuild
2015-07-06 - sander85 <sander85> 1.140.0-1.mga6
+ Revision: 852029
- update to 1.14
2014-10-19 - umeabot <umeabot> 1.110.0-4.mga5
+ Revision: 789421
- Rebuild to potentially add missing dependencies
2014-10-15 - umeabot <umeabot> 1.110.0-3.mga5
+ Revision: 743948
- Second Mageia 5 Mass Rebuild
2014-09-16 - umeabot <umeabot> 1.110.0-2.mga5
+ Revision: 685149
- Mageia 5 Mass Rebuild
2014-02-04 - guillomovitch <guillomovitch> 1.110.0-1.mga5
+ Revision: 582130
- new version 1.11
2013-10-18 - umeabot <umeabot> 1.50.0-3.mga4
+ Revision: 512399
- Mageia 4 Mass Rebuild

See Also

Package Description
perl-JavaScript-Minifier-XS-0.110.0-8.mga7.i586.rpm XS based JavaScript minifier
perl-JavaScript-Packer-2.40.0-1.mga7.noarch.rpm Perl version of Dean Edwards' Packer.js
perl-Jcode-2.70.0-19.mga7.i586.rpm Japanese Charset Handle
perl-Jifty-DBI-0.780.0-4.mga7.noarch.rpm Ensure uniqueness of records in a collection
perl-KinoSearch1-1.10.0-17.mga7.i586.rpm Surround highlight bits with tags
perl-KiokuDB-0.570.0-5.mga6.noarch.rpm Common functionality for JSPON
perl-KiokuDB-Backend-DBI-1.230.0-5.mga6.noarch.rpm L<KiokuDB::TypeMap::Entry>
perl-KiokuDB-Cmd-0.30.0-7.mga6.noarch.rpm A role for command line tools which accept entry IDs as options
perl-KiokuX-Model-0.20.0-7.mga6.noarch.rpm A simple application specific wrapper for L<KiokuDB>
perl-KiokuX-User-0.20.0-10.mga6.noarch.rpm A role for users
perl-Kwalify-1.220.0-6.mga6.noarch.rpm Kwalify schema for data structures
perl-Kwiki-0.390.0-9.mga7.noarch.rpm The Kwiki Wiki Building Framework
perl-Kwiki-Archive-Rcs-0.160.0-8.mga7.noarch.rpm Kwiki Page Archival Using RCS
perl-Kwiki-Attachments-0.210.0-8.mga6.noarch.rpm Kwiki Page Attachments Plugin
perl-Kwiki-Cache-0.110.0-9.mga7.noarch.rpm Kwiki Cache Plugin
Advertisement
Advertisement