perl-Module-Extract-Use-1.43.0-4.mga7.noarch.rpm


Advertisement

Description

perl-Module-Extract-Use - Pull out the modules a module uses

Property Value
Distribution Mageia Cauldron
Repository Mageia Core i586
Package filename perl-Module-Extract-Use-1.43.0-4.mga7.noarch.rpm
Package name perl-Module-Extract-Use
Package version 1.43.0
Package release 4.mga7
Package architecture noarch
Package type rpm
Category Development/Perl
Homepage http://search.cpan.org/dist/Module-Extract-Use
License GPL+ or Artistic
Maintainer -
Download size 19.39 KB
Installed size 25.14 KB
Extract the names of the modules used in a file using a static analysis.
Since this module does not run code, it cannot find dynamic uses of
modules, such as 'eval "require $class"'.
* new
Makes an object. The object doesn't do anything just yet, but you need it
to call the methods.

Alternatives

Package Version Architecture Repository
perl-Module-Extract-Use-1.43.0-4.mga7.noarch.rpm 1.43.0 noarch Mageia Core
perl-Module-Extract-Use - - -

Requires

Name Value
perl(Getopt::Std) -
perl(PPI) -
perl(strict) -
perl(subs) -
perl(vars) -
perl(warnings) -
perl-base >= 2:5.28.0

Provides

Name Value
perl(Module::Extract::Use) == 1.43.0
perl(Module::Extract::Use::Item) -
perl-Module-Extract-Use == 1.43.0-4.mga7

Download

Type URL
Mirror distrib-coffee.ipsl.jussieu.fr
Binary Package perl-Module-Extract-Use-1.43.0-4.mga7.noarch.rpm
Source Package perl-Module-Extract-Use-1.43.0-4.mga7.src.rpm

Install Howto

  1. Enable Mageia Core repository on Install and Remove Software
  2. Update packages list:
    # urpmi.update -a
  3. Install perl-Module-Extract-Use rpm package:
    # urpmi perl-Module-Extract-Use

Files

Path
/usr/share/doc/perl-Module-Extract-Use/Changes
/usr/share/doc/perl-Module-Extract-Use/LICENSE
/usr/share/doc/perl-Module-Extract-Use/META.yml
/usr/share/doc/perl-Module-Extract-Use/MYMETA.yml
/usr/share/doc/perl-Module-Extract-Use/README.pod
/usr/share/doc/perl-Module-Extract-Use/examples/extract_modules
/usr/share/man/man3/Module::Extract::Use.3pm.xz
/usr/share/perl5/vendor_perl/Module/
/usr/share/perl5/vendor_perl/Module/Extract/Use.pm

Changelog

2018-09-20 - umeabot <umeabot> 1.43.0-4.mga7
(not released yet)
+ Revision: 1284786
- Mageia 7 Mass Rebuild
2017-10-03 - tv <tv> 1.43.0-3.mga7
+ Revision: 1165546
- rebuild with fixed rpm for missing autodeps
2017-09-28 - tv <tv> 1.43.0-2.mga7
+ Revision: 1160972
- req perl(PPI), thus fixing tons of builds
2017-09-22 - sander85 <sander85> 1.43.0-1.mga7
+ Revision: 1157444
- update to 1.043
2016-06-19 - pterjan <pterjan> 1.40.0-6.mga6
+ Revision: 1029995
- Rebuild for perl 5.22.2
2016-02-03 - umeabot <umeabot> 1.40.0-5.mga6
+ Revision: 933122
- Mageia 6 Mass Rebuild

See Also

Package Description
perl-Module-Extract-VERSION-1.113.0-3.mga7.noarch.rpm Extract a module version without running code
perl-Module-ExtractUse-0.343.0-1.mga7.noarch.rpm Find out what modules are used
perl-Module-Find-0.130.0-4.mga7.noarch.rpm Find and use installed modules in a (sub)category
perl-Module-Format-0.2.0-2.mga7.noarch.rpm Convert and manipulate stringified versions of Perl modules
perl-Module-Implementation-0.90.0-6.mga7.noarch.rpm Loads one of several alternate underlying implementations for a module
perl-Module-Info-0.370.0-3.mga7.noarch.rpm Information about Perl modules
perl-Module-Inspector-1.50.0-11.mga7.noarch.rpm An integrated API for inspecting Perl distributions
perl-Module-Install-1.190.0-2.mga7.noarch.rpm Standalone, extensible Perl module installer
perl-Module-Install-AckXXX-0.270.0-7.mga7.noarch.rpm Warn Author About XXX.pm
perl-Module-Install-AuthorRequires-0.20.0-8.mga7.noarch.rpm Declare author-only dependencies
perl-Module-Install-AuthorTests-0.2.0-9.mga7.noarch.rpm Designate tests only run by module authors
perl-Module-Install-AutoLicense-0.100.0-3.mga7.noarch.rpm A Module::Install extension to automagically generate LICENSE files
perl-Module-Install-AutoManifest-0.3.0-11.mga7.noarch.rpm Generate MANIFEST automatically
perl-Module-Install-CheckConflicts-0.20.0-10.mga7.noarch.rpm Notify users of possible conflicts with the distribution they're installing
perl-Module-Install-ExtraTests-0.8.0-11.mga7.noarch.rpm Ignorable, contextual test support for Module::Install
Advertisement
Advertisement