perl-MooX-Role-POE-Emitter-1.1.2-4.mga7.noarch.rpm


Advertisement

Description

perl-MooX-Role-POE-Emitter - Pluggable POE event emitter role for cows

Property Value
Distribution Mageia Cauldron
Repository Mageia Core i586
Package filename perl-MooX-Role-POE-Emitter-1.1.2-4.mga7.noarch.rpm
Package name perl-MooX-Role-POE-Emitter
Package version 1.1.2
Package release 4.mga7
Package architecture noarch
Package type rpm
Category Development/Perl
Homepage http://search.cpan.org/dist/MooX-Role-POE-Emitter
License GPL+ or Artistic
Maintainer -
Download size 32.30 KB
Installed size 71.96 KB
This is a the Moo::Role manpage for a the POE manpage Observer Pattern
implementation; it is derived from the POE::Component::Syndicator manpage
by BINGOS, HINRIK, APOCAL et al, but with more cows ;-)
Consuming this role gives your class a the POE::Session manpage capable of
emitting events to loaded plugins and registered "listener" sessions. It
also brings in the MooX::Role::Pluggable manpage, making your emitter
pluggable (see the the MooX::Role::Pluggable manpage documentation for
plugin-related details).
You do not need to create your own the POE::Session manpage; calling the
/_start_emitter manpage will spawn one for you.

Alternatives

Package Version Architecture Repository
perl-MooX-Role-POE-Emitter-1.1.2-4.mga7.noarch.rpm 1.1.2 noarch Mageia Core
perl-MooX-Role-POE-Emitter - - -

Requires

Name Value
perl(Carp) -
perl(Class::Method::Modifiers) -
perl(List::Objects::Types) >= 1.0.0
perl(List::Objects::WithUtils) >= 2.7.0
perl(Moo) >= 1.6.0
perl(Moo::Role) -
perl(MooX::Role::Pluggable) >= 1.0.0
perl(MooX::Role::Pluggable::Constants) -
perl(POE) -
perl(Scalar::Util) -
perl(Try::Tiny) -
perl(Type::Tiny) >= 1.0.0
perl(Types::Standard) -
perl(feature) -
perl(strictures) >= 2.0.0
perl-base >= 2:5.28.0

Provides

Name Value
perl(MooX::Role::POE::Emitter) == 1.1.2
perl-MooX-Role-POE-Emitter == 1.1.2-4.mga7

Download

Type URL
Mirror distrib-coffee.ipsl.jussieu.fr
Binary Package perl-MooX-Role-POE-Emitter-1.1.2-4.mga7.noarch.rpm
Source Package perl-MooX-Role-POE-Emitter-1.1.2-4.mga7.src.rpm

Install Howto

  1. Enable Mageia Core repository on Install and Remove Software
  2. Update packages list:
    # urpmi.update -a
  3. Install perl-MooX-Role-POE-Emitter rpm package:
    # urpmi perl-MooX-Role-POE-Emitter

Files

Path
/usr/share/doc/perl-MooX-Role-POE-Emitter/Changes
/usr/share/doc/perl-MooX-Role-POE-Emitter/LICENSE
/usr/share/doc/perl-MooX-Role-POE-Emitter/META.json
/usr/share/doc/perl-MooX-Role-POE-Emitter/META.yml
/usr/share/doc/perl-MooX-Role-POE-Emitter/MYMETA.yml
/usr/share/doc/perl-MooX-Role-POE-Emitter/README.mkdn
/usr/share/man/man3/MooX::Role::POE::Emitter.3pm.xz
/usr/share/perl5/vendor_perl/MooX/
/usr/share/perl5/vendor_perl/MooX/Role/
/usr/share/perl5/vendor_perl/MooX/Role/POE/Emitter.pm

Changelog

2018-09-19 - umeabot <umeabot> 1.1.2-4.mga7
(not released yet)
+ Revision: 1269804
- Mageia 7 Mass Rebuild
2016-06-19 - pterjan <pterjan> 1.1.2-3.mga6
+ Revision: 1030724
- Rebuild for perl 5.22.2
2016-02-18 - umeabot <umeabot> 1.1.2-2.mga6
+ Revision: 967323
- Mageia 6 Mass Rebuild

See Also

Package Description
perl-MooX-Role-Parameterized-0.82.0-1.mga7.noarch.rpm Dsl to apply roles with composition parameters
perl-MooX-Role-Pluggable-1.2.2-4.mga7.noarch.rpm MooX::Role::Pluggable EAT values
perl-MooX-Singleton-1.200.0-7.mga7.noarch.rpm Turn your Moo class into singleton
perl-MooX-StrictConstructor-0.10.0-2.mga7.noarch.rpm A role to make Moo constructors strict
perl-MooX-Struct-0.17.0-2.mga7.noarch.rpm Make simple lightweight record-like structures that make sounds like cows
perl-MooX-Types-MooseLike-0.290.0-4.mga7.noarch.rpm Moo types for numbers
perl-MooX-Types-MooseLike-Numeric-1.30.0-2.mga7.noarch.rpm Moo types for numbers
perl-MooX-late-0.15.0-6.mga7.noarch.rpm Easily translate Moose code to Moo
perl-Moose-2.201.100-4.mga8.i586.rpm A complete modern object system for Perl 5
perl-Moose-Autobox-0.160.0-4.mga7.noarch.rpm The Indexed role
perl-Moose-Policy-0.50.0-8.mga7.noarch.rpm Moose-mounted police
perl-MooseX-AbstractMethod-0.4.0-7.mga7.noarch.rpm Declare methods requirements that must be satisfied
perl-MooseX-Aliases-0.110.0-9.mga7.noarch.rpm Attribute metaclass trait for L<MooseX::Aliases>
perl-MooseX-Alien-1.10.0-7.mga7.noarch.rpm Extend a non-Moose class with Moose
perl-MooseX-AlwaysCoerce-0.230.0-3.mga7.noarch.rpm Automatically enable coercions for Moose attributes
Advertisement
Advertisement