perl-POSIX-Regex-1.0.300-11.mga8.i586.rpm


Advertisement

Description

perl-POSIX-Regex - Port of the glibc gnu regex engine into perl

Property Value
Distribution Mageia Cauldron
Repository Mageia Core i586
Package filename perl-POSIX-Regex-1.0.300-11.mga8.i586.rpm
Package name perl-POSIX-Regex
Package version 1.0.300
Package release 11.mga8
Package architecture i586
Package type rpm
Category Development/Perl
Homepage http://search.cpan.org/dist/POSIX-Regex
License GPL+ or Artistic
Maintainer -
Download size 22.19 KB
Installed size 33.64 KB
This is a port of the glibc gnu regex engine into perl.  There are few reasons
you would need this.  The few I can think of include:
0) You wish to use untrusted user expressions in such a way as to be able to
catch errors.  Example:  eval { alarm 2;  m/((){1024}){1024}/ } is an instant
uncatchable segmentation fault.  GNU's regexps will still fail, but in a timeout
way rather than an instant segfault way.
1) You wish to have POSIX compliance on ... something ...  Perl's regexps are
slightly different -- arguably better, but different.
( ... if you think of anything else, let me know, since reason 0 evaporates under 5.9.3+ ... )

Alternatives

Package Version Architecture Repository
perl-POSIX-Regex-1.0.300-11.mga8.x86_64.rpm 1.0.300 x86_64 Mageia Core
perl-POSIX-Regex - - -

Requires

Name Value
libc.so.6 -
libc.so.6(GLIBC_2.0) -
libc.so.6(GLIBC_2.1.3) -
libc.so.6(GLIBC_2.3.4) -
libc.so.6(GLIBC_2.4) -
libperl.so.5.30 -
perl(Carp) -
perl(Exporter) -
perl(ExtUtils::Constant) >= 0.160.0
perl(XSLoader) -
perl(base) -
perl(strict) -
perl(warnings) -
perl-base >= 2:5.30.0

Provides

Name Value
perl(POSIX::Regex) == 1.0.300
perl-POSIX-Regex == 1.0.300-11.mga8
perl-POSIX-Regex(x86-32) == 1.0.300-11.mga8

Download

Type URL
Mirror distrib-coffee.ipsl.jussieu.fr
Binary Package perl-POSIX-Regex-1.0.300-11.mga8.i586.rpm
Source Package perl-POSIX-Regex-1.0.300-11.mga8.src.rpm

Install Howto

  1. Enable Mageia Core repository on Install and Remove Software
  2. Update packages list:
    # urpmi.update -a
  3. Install perl-POSIX-Regex rpm package:
    # urpmi perl-POSIX-Regex

Files

Path
/usr/lib/.build-id/
/usr/lib/.build-id/0f/0bad281807adb22d679e4698d36139fd86ac92
/usr/lib/perl5/vendor_perl/POSIX/Regex.pm
/usr/lib/perl5/vendor_perl/POSIX/Regex.pod
/usr/lib/perl5/vendor_perl/auto/
/usr/lib/perl5/vendor_perl/auto/POSIX/
/usr/lib/perl5/vendor_perl/auto/POSIX/Regex/Regex.so
/usr/share/doc/perl-POSIX-Regex/Changes
/usr/share/doc/perl-POSIX-Regex/META.json
/usr/share/doc/perl-POSIX-Regex/META.yml
/usr/share/doc/perl-POSIX-Regex/README
/usr/share/man/man3/POSIX::Regex.3pm.xz

Changelog

2019-08-27 - tmb <tmb> 1.0.300-11.mga8
+ Revision: 1433877
- rebuild for perl 5.30
2018-09-21 - umeabot <umeabot> 1.0.300-10.mga7
+ Revision: 1293642
- Mageia 7 Mass Rebuild
2018-08-08 - pterjan <pterjan> 1.0.300-9.mga7
+ Revision: 1249865
- Rebuild for perl 5.28
2017-10-03 - tv <tv> 1.0.300-8.mga7
+ Revision: 1166314
- rebuild with fixed rpm for missing autodeps
2017-08-31 - pterjan <pterjan> 1.0.300-7.mga7
+ Revision: 1149110
- Rebuild for perl ABI changes

See Also

Package Description
perl-POSIX-strftime-Compiler-0.420.0-2.mga7.noarch.rpm GNU C library compatible strftime for loggers and servers
perl-PPI-1.270.0-1.mga8.noarch.rpm Parse, Analyze and Manipulate Perl without perl
perl-PPI-HTML-1.80.0-10.mga7.noarch.rpm Generate syntax-hightlighted HTML for Perl using PPI
perl-PPI-PowerToys-0.140.0-11.mga7.noarch.rpm A handy collection of small PPI-based utilities
perl-PPI-Tester-0.150.0-12.mga7.noarch.rpm A wxPerl-based interactive PPI debugger/tester
perl-PPI-XS-0.910.0-4.mga8.i586.rpm (Minor) XS acceleration for PPI
perl-PPIx-DocumentName-0.1.3-2.mga7.noarch.rpm Utility to extract a name from a PPI Document
perl-PPIx-EditorTools-0.210.0-1.mga7.noarch.rpm Introduces a temporary variable using PPI
perl-PPIx-QuoteLike-0.8.0-1.mga8.noarch.rpm Represent an interpolation
perl-PPIx-Regexp-0.67.0-1.mga8.noarch.rpm Represent an independent subexpression marker
perl-PPIx-Utilities-1.1.0-8.mga7.noarch.rpm A problem identified by L<PPIx::Utilities|PPIx::Utilities>
perl-Package-Constants-0.60.0-4.mga7.noarch.rpm Package Constants
perl-Package-DeprecationManager-0.170.0-2.mga7.noarch.rpm Manage deprecation warnings for your distribution
perl-Package-Generator-1.106-7.mga7.noarch.rpm pseudo-garbage-collection for packages
perl-Package-Pkg-0.2.0-9.mga7.noarch.rpm Handy package munging utilities
Advertisement
Advertisement