perl-Params-Validate-1.290.0-6.mga8.i586.rpm


Advertisement

Description

perl-Params-Validate - Validate method/function call parameters

Property Value
Distribution Mageia Cauldron
Repository Mageia Core i586
Package filename perl-Params-Validate-1.290.0-6.mga8.i586.rpm
Package name perl-Params-Validate
Package version 1.290.0
Package release 6.mga8
Package architecture i586
Package type rpm
Category Development/Other
Homepage http://metacpan.org/release/Params-Validate/
License GPL+ or Artistic
Maintainer -
Download size 75.67 KB
Installed size 240.84 KB
The Params::Validate module provides a flexible system for validation
method/function call parameters.
The validation can be as simple as checking for the presence of required
parameters or as complex as validating object classes (via isa) or capabilities
(via can), checking parameter types, and using customized callbacks to ensure
data integrity.

Alternatives

Package Version Architecture Repository
perl-Params-Validate-1.290.0-6.mga8.x86_64.rpm 1.290.0 x86_64 Mageia Core
perl-Params-Validate - - -

Requires

Name Value
libc.so.6 -
libc.so.6(GLIBC_2.0) -
libc.so.6(GLIBC_2.1.3) -
libc.so.6(GLIBC_2.4) -
perl >= 0:5.008001
perl(Carp) -
perl(Exporter) -
perl(Module::Implementation) -
perl(Params::Validate) -
perl(Params::Validate::Constants) -
perl(Scalar::Util) >= 1.100.0
perl(XSLoader) -
perl(strict) -
perl(vars) -
perl(warnings) -
perl-base >= 2:5.30.0

Provides

Name Value
perl(Params::Validate) == 1.290.0
perl(Params::Validate::Constants) == 1.290.0
perl(Params::Validate::PP) == 1.290.0
perl(Params::Validate::XS) == 1.290.0
perl-Params-Validate == 1.290.0-6.mga8
perl-Params-Validate(x86-32) == 1.290.0-6.mga8

Download

Type URL
Mirror distrib-coffee.ipsl.jussieu.fr
Binary Package perl-Params-Validate-1.290.0-6.mga8.i586.rpm
Source Package perl-Params-Validate-1.290.0-6.mga8.src.rpm

Install Howto

  1. Enable Mageia Core repository on Install and Remove Software
  2. Update packages list:
    # urpmi.update -a
  3. Install perl-Params-Validate rpm package:
    # urpmi perl-Params-Validate

Files

Path
/usr/lib/.build-id/
/usr/lib/.build-id/9d/b278eecc0afdfeb412a6a42356558f9697cb0b
/usr/lib/perl5/vendor_perl/Params/Validate.pm
/usr/lib/perl5/vendor_perl/Params/ValidatePP.pm
/usr/lib/perl5/vendor_perl/Params/ValidateXS.pm
/usr/lib/perl5/vendor_perl/Params/Validate/Constants.pm
/usr/lib/perl5/vendor_perl/Params/Validate/PP.pm
/usr/lib/perl5/vendor_perl/Params/Validate/XS.pm
/usr/lib/perl5/vendor_perl/auto/
/usr/lib/perl5/vendor_perl/auto/Params/
/usr/lib/perl5/vendor_perl/auto/Params/Validate/
/usr/lib/perl5/vendor_perl/auto/Params/Validate/XS/XS.so
/usr/share/doc/perl-Params-Validate/Changes
/usr/share/doc/perl-Params-Validate/INSTALL
/usr/share/doc/perl-Params-Validate/LICENSE
/usr/share/doc/perl-Params-Validate/META.json
/usr/share/doc/perl-Params-Validate/META.yml
/usr/share/doc/perl-Params-Validate/MYMETA.yml
/usr/share/doc/perl-Params-Validate/TODO
/usr/share/man/man3/Params::Validate.3pm.xz

Changelog

2019-08-28 - tv <tv> 1.290.0-6.mga8
+ Revision: 1434710
- BR perl-ExtUtils-MakeMaker
- rebuild with perl-5.30
2018-09-21 - umeabot <umeabot> 1.290.0-5.mga7
+ Revision: 1293649
- Mageia 7 Mass Rebuild
2018-08-05 - shlomif <shlomif> 1.290.0-4.mga7
+ Revision: 1247974
- Rebuild for new perl 5.28.0
2017-10-03 - tv <tv> 1.290.0-3.mga7
+ Revision: 1166129
- rebuild with fixed rpm for missing autodeps
2017-08-31 - pterjan <pterjan> 1.290.0-2.mga7
+ Revision: 1149100
- Rebuild for perl ABI changes

See Also

Package Description
perl-Params-ValidationCompiler-0.300.0-2.mga7.noarch.rpm Defines exceptions thrown by Params::ValidationCompiler
perl-Parse-Binary-0.110.0-10.mga7.noarch.rpm Convert between variant records and hashes
perl-Parse-CPAN-Packages-2.400.0-4.mga7.noarch.rpm Parse 02packages.details.txt.gz
perl-Parse-CPAN-Packages-Fast-0.90.0-4.mga7.noarch.rpm Parse CPAN's package index
perl-Parse-EDID-1.0.7-3.mga7.noarch.rpm Extended display identification data (EDID) parser
perl-Parse-Earley-0.150.0-8.mga7.noarch.rpm Parse::Earley - Parse any Context-Free Grammar
perl-Parse-ErrorString-Perl-0.270.0-3.mga7.noarch.rpm Parse error messages from the perl interpreter
perl-Parse-ExuberantCTags-1.20.0-20.mga8.i586.rpm Efficiently parse exuberant ctags files
perl-Parse-IRC-1.220.0-3.mga7.noarch.rpm A parser for the IRC protocol
perl-Parse-LocalDistribution-0.190.0-2.mga7.noarch.rpm Parses local .pm files as PAUSE does
perl-Parse-MIME-1.5.0-1.mga7.noarch.rpm Parse mime-types, match against media ranges
perl-Parse-Method-Signatures-1.3.19-3.mga7.noarch.rpm Turn parse TC data into Moose TC object
perl-Parse-PMFile-0.410.0-2.mga7.noarch.rpm Parses .pm file as PAUSE does
perl-Parse-RecDescent-1.967.15-2.mga7.noarch.rpm A recursive descent parser generator for Perl
perl-Parse-RecDescent-Consumer-1.30.0-8.mga7.noarch.rpm Parse::RecDescent::Consumer - reveal text matched through n token transitions
Advertisement
Advertisement