perl-Perl-Critic-PetPeeves-JTRAMMELL-0.40.0-7.mga6.noarch.rpm


Advertisement

Description

perl-Perl-Critic-PetPeeves-JTRAMMELL - Prohibit superfluous initializations

Property Value
Distribution Mageia Cauldron
Repository Mageia Core i586
Package name perl-Perl-Critic-PetPeeves-JTRAMMELL
Package version 0.40.0
Package release 7.mga6
Package architecture noarch
Package type rpm
Installed size 13.40 KB
Download size 15.94 KB
Official Mirror distrib-coffee.ipsl.jussieu.fr
Module 'Perl::Critic::PetPeeves::JTRAMMELL' provides policies that I want
that haven't already been implemented elsewhere. So far this is:

Alternatives

Package Version Architecture Repository
perl-Perl-Critic-PetPeeves-JTRAMMELL-0.40.0-7.mga6.noarch.rpm 0.40.0 noarch Mageia Core
perl-Perl-Critic-PetPeeves-JTRAMMELL - - -

Requires

Name Value
perl(Perl::Critic::Policy) -
perl(Perl::Critic::Utils) -
perl(base) -
perl(strict) -
perl(warnings) -
perl-base >= 2:5.22.2

Provides

Name Value
perl(Perl::Critic::PetPeeves::JTRAMMELL) == 0.40.0
perl(Perl::Critic::Policy::Variables::ProhibitUselessInitialization) == 0.20.0
perl-Perl-Critic-PetPeeves-JTRAMMELL == 0.40.0-7.mga6

Download

Type URL
Binary Package perl-Perl-Critic-PetPeeves-JTRAMMELL-0.40.0-7.mga6.noarch.rpm
Source Package perl-Perl-Critic-PetPeeves-JTRAMMELL-0.40.0-7.mga6.src.rpm

Install Howto

  1. Enable Mageia Core repository on Install and Remove Software
  2. Update packages list:
    # urpmi.update -a
  3. Install perl-Perl-Critic-PetPeeves-JTRAMMELL rpm package:
    # urpmi perl-Perl-Critic-PetPeeves-JTRAMMELL

Files

Path
/usr/lib/perl5/vendor_perl/5.22.2/Perl/
/usr/lib/perl5/vendor_perl/5.22.2/Perl/Critic/
/usr/lib/perl5/vendor_perl/5.22.2/Perl/Critic/PetPeeves/JTRAMMELL.pm
/usr/lib/perl5/vendor_perl/5.22.2/Perl/Critic/Policy/
/usr/lib/perl5/vendor_perl/5.22.2/Perl/Critic/Policy/Variables/ProhibitUselessInitialization.pm
/usr/share/doc/perl-Perl-Critic-PetPeeves-JTRAMMELL/Changes
/usr/share/doc/perl-Perl-Critic-PetPeeves-JTRAMMELL/META.yml
/usr/share/doc/perl-Perl-Critic-PetPeeves-JTRAMMELL/MYMETA.yml
/usr/share/doc/perl-Perl-Critic-PetPeeves-JTRAMMELL/README
/usr/share/man/man3/Perl::Critic::PetPeeves::JTRAMMELL.3pm.xz
/usr/share/man/man3/Perl::Critic::Policy::Variables::ProhibitUselessInitialization.3pm.xz

Changelog

2016-06-19 - pterjan <pterjan> 0.40.0-7.mga6
+ Revision: 1031967
- Rebuild for perl 5.22.2
2016-02-20 - umeabot <umeabot> 0.40.0-6.mga6
+ Revision: 971522
- Mageia 6 Mass Rebuild
2015-10-15 - tv <tv> 0.40.0-5.mga6
+ Revision: 891864
- BR perl(Module::Build)
2014-10-19 - umeabot <umeabot> 0.40.0-4.mga5
+ Revision: 790688
- Rebuild to potentially add missing dependencies
2014-10-15 - umeabot <umeabot> 0.40.0-3.mga5
+ Revision: 745185
- Second Mageia 5 Mass Rebuild
2014-09-16 - umeabot <umeabot> 0.40.0-2.mga5
+ Revision: 685931
- Mageia 5 Mass Rebuild
2014-05-06 - jquelin <jquelin> 0.40.0-1.mga5
+ Revision: 620714
- update to 0.04
2013-10-19 - umeabot <umeabot> 0.30.0-2.mga4
+ Revision: 527198
- Mageia 4 Mass Rebuild

See Also

Package Description
perl-Perl-Critic-Pulp-96.0.0-1.mga7.noarch.rpm Don't use Foo:: style barewords
perl-Perl-Critic-Storable-0.10.0-7.mga6.noarch.rpm Perl::Critic policy for using Storable
perl-Perl-Critic-StricterSubs-0.50.0-3.mga6.noarch.rpm Perl::Critic plugin for stricter subroutine checks
perl-Perl-Critic-Swift-1.0.3-7.mga6.noarch.rpm Additional policies for Perl::Critic
perl-Perl-Critic-Tics-0.9.0-5.mga6.noarch.rpm (this => is => not => good)
perl-Perl-Destruct-Level-0.20.0-17.mga7.i586.rpm Allow to change perl's destruction level
perl-Perl-Metrics-Simple-0.180.0-3.mga6.noarch.rpm Methods analyzing a single file
perl-Perl-MinimumVersion-1.380.0-6.mga6.noarch.rpm Find a minimum required version of perl for Perl code
perl-Perl-OSType-1.10.0-1.mga7.noarch.rpm Map Perl operating system names to generic types
perl-Perl-PrereqScanner-1.23.0-3.mga6.noarch.rpm A tool to scan your Perl code for its prerequisites
perl-Perl-Tags-0.320.0-6.mga7.noarch.rpm Testing output of L<Perl::Tags>
perl-Perl-Tidy-20180220.0.0-1.mga7.noarch.rpm Parses and beautifies perl source
perl-Perl-Tidy-Sweetened-1.120.0-1.mga7.noarch.rpm Tweaks to Perl::Tidy to support some syntactic sugar
perl-Perl-Version-1.13.0-5.mga6.noarch.rpm Parse and manipulate Perl version strings
perl-Perl-osnames-0.110.0-3.mga6.noarch.rpm List possible $^O ($OSNAME) values, with description
Advertisement
Advertisement