perl-Perl-Critic-Tics-0.9.0-6.mga7.noarch.rpm


Advertisement

Description

perl-Perl-Critic-Tics - (this => is => not => good)

Property Value
Distribution Mageia Cauldron
Repository Mageia Core i586
Package filename perl-Perl-Critic-Tics-0.9.0-6.mga7.noarch.rpm
Package name perl-Perl-Critic-Tics
Package version 0.9.0
Package release 6.mga7
Package architecture noarch
Package type rpm
Category Development/Perl
Homepage http://search.cpan.org/dist/Perl-Critic-Tics
License GPL+ or Artistic
Maintainer -
Download size 25.61 KB
Installed size 50.51 KB
The Perl-Critic-Tics distribution includes extra policies for Perl::Critic
to address a fairly random assortment of things that make me (rjbs) wince.

Alternatives

Package Version Architecture Repository
perl-Perl-Critic-Tics-0.9.0-6.mga7.noarch.rpm 0.9.0 noarch Mageia Core
perl-Perl-Critic-Tics - - -

Requires

Name Value
perl(Perl::Critic::Policy) -
perl(Perl::Critic::Utils) -
perl(Perl::Critic::Violation) -
perl(parent) -
perl(strict) -
perl(warnings) -
perl-base >= 2:5.28.0

Provides

Name Value
perl(Perl::Critic::Policy::Tics::ProhibitLongLines) == 0.9.0
perl(Perl::Critic::Policy::Tics::ProhibitManyArrows) == 0.9.0
perl(Perl::Critic::Policy::Tics::ProhibitUseBase) == 0.9.0
perl(Perl::Critic::Tics) == 0.9.0
perl-Perl-Critic-Tics == 0.9.0-6.mga7

Download

Type URL
Mirror distrib-coffee.ipsl.jussieu.fr
Binary Package perl-Perl-Critic-Tics-0.9.0-6.mga7.noarch.rpm
Source Package perl-Perl-Critic-Tics-0.9.0-6.mga7.src.rpm

Install Howto

  1. Enable Mageia Core repository on Install and Remove Software
  2. Update packages list:
    # urpmi.update -a
  3. Install perl-Perl-Critic-Tics rpm package:
    # urpmi perl-Perl-Critic-Tics

Files

Path
/usr/share/doc/perl-Perl-Critic-Tics/Changes
/usr/share/doc/perl-Perl-Critic-Tics/LICENSE
/usr/share/doc/perl-Perl-Critic-Tics/META.yml
/usr/share/doc/perl-Perl-Critic-Tics/README
/usr/share/man/man3/Perl::Critic::Policy::Tics::ProhibitLongLines.3pm.xz
/usr/share/man/man3/Perl::Critic::Policy::Tics::ProhibitManyArrows.3pm.xz
/usr/share/man/man3/Perl::Critic::Policy::Tics::ProhibitUseBase.3pm.xz
/usr/share/man/man3/Perl::Critic::Tics.3pm.xz
/usr/share/perl5/vendor_perl/Perl/
/usr/share/perl5/vendor_perl/Perl/Critic/Tics.pm
/usr/share/perl5/vendor_perl/Perl/Critic/Policy/
/usr/share/perl5/vendor_perl/Perl/Critic/Policy/Tics/ProhibitLongLines.pm
/usr/share/perl5/vendor_perl/Perl/Critic/Policy/Tics/ProhibitManyArrows.pm
/usr/share/perl5/vendor_perl/Perl/Critic/Policy/Tics/ProhibitUseBase.pm

Changelog

2018-09-19 - umeabot <umeabot> 0.9.0-6.mga7
(not released yet)
+ Revision: 1270506
- Mageia 7 Mass Rebuild
2016-06-19 - pterjan <pterjan> 0.9.0-5.mga6
+ Revision: 1031972
- Rebuild for perl 5.22.2
2016-02-08 - umeabot <umeabot> 0.9.0-4.mga6
+ Revision: 945126
- Mageia 6 Mass Rebuild

See Also

Package Description
perl-Perl-Destruct-Level-0.20.0-19.mga8.i586.rpm Allow to change perl's destruction level
perl-Perl-Metrics-Simple-0.180.0-4.mga7.noarch.rpm Methods analyzing a single file
perl-Perl-MinimumVersion-1.380.0-7.mga7.noarch.rpm Find a minimum required version of perl for Perl code
perl-Perl-OSType-1.10.0-2.mga7.noarch.rpm Map Perl operating system names to generic types
perl-Perl-PrereqScanner-1.23.0-4.mga7.noarch.rpm A tool to scan your Perl code for its prerequisites
perl-Perl-PrereqScanner-NotQuiteLite-0.990.800-1.mga8.noarch.rpm A tool to scan your Perl code for its prerequisites
perl-Perl-Tags-0.320.0-7.mga7.noarch.rpm Testing output of L<Perl::Tags>
perl-Perl-Tidy-20190915.0.0-1.mga8.noarch.rpm Parses and beautifies perl source
perl-Perl-Tidy-Sweetened-1.150.0-1.mga7.noarch.rpm Tweaks to Perl::Tidy to support some syntactic sugar
perl-Perl-Version-1.13.0-6.mga7.noarch.rpm Parse and manipulate Perl version strings
perl-Perl-osnames-0.110.0-4.mga7.noarch.rpm List possible $^O ($OSNAME) values, with description
perl-Perl6-Classes-0.220.0-8.mga7.noarch.rpm Perl 6 class syntax for Perl 5
perl-Perl6-Doc-0.470.0-8.mga7.noarch.rpm Perl 6 Documentation Collection
perl-Perl6-Export-0.70.0-8.mga7.noarch.rpm Implements the Perl 6 is export trait
perl-Perl6-Export-Attrs-0.0.6-2.mga7.noarch.rpm The Perl 6 'is export(...)' trait as a Perl 5 attribute
Advertisement
Advertisement