perl-Pod-Coverage-0.230.0-7.mga6.noarch.rpm


Advertisement

Description

perl-Pod-Coverage - Checks if the documentation of a perl module is comprehensive

Property Value
Distribution Mageia Cauldron
Repository Mageia Core i586
Package name perl-Pod-Coverage
Package version 0.230.0
Package release 7.mga6
Package architecture noarch
Package type rpm
Installed size 32.49 KB
Download size 23.93 KB
Official Mirror distrib-coffee.ipsl.jussieu.fr
Developers hate writing documentation. They'd hate it even more if their
computer tattled on them, but maybe they'll be even more thankful in the long
run. Even if not, perlmodstyle tells you to, so you must obey. This perl module
provides a mechanism for determining if the pod for a given module is
comprehensive.

Alternatives

Package Version Architecture Repository
perl-Pod-Coverage-0.230.0-7.mga6.noarch.rpm 0.230.0 noarch Mageia Core
perl-Pod-Coverage - - -

Requires

Name Value
perl(B) -
perl(Devel::Symdump) >= 2.10.0
perl(Pod::Coverage) -
perl(Pod::Find) >= 0.210.0
perl(Pod::Parser) >= 1.130.0
perl(Test::More) -
perl(base) -
perl(constant) -
perl(lib) -
perl(strict) -
perl(vars) -
perl-base >= 2:5.22.2

Provides

Name Value
perl(Pod::Coverage) == 0.230.0
perl(Pod::Coverage::CountParents) -
perl(Pod::Coverage::ExportOnly) -
perl(Pod::Coverage::Extractor) -
perl(Pod::Coverage::Overloader) -
perl-Pod-Coverage == 0.230.0-7.mga6

Download

Type URL
Binary Package perl-Pod-Coverage-0.230.0-7.mga6.noarch.rpm
Source Package perl-Pod-Coverage-0.230.0-7.mga6.src.rpm

Install Howto

  1. Enable Mageia Core repository on Install and Remove Software
  2. Update packages list:
    # urpmi.update -a
  3. Install perl-Pod-Coverage rpm package:
    # urpmi perl-Pod-Coverage

Files

Path
/usr/bin/pod_cover
/usr/lib/perl5/vendor_perl/5.22.2/Pod/Coverage.pm
/usr/lib/perl5/vendor_perl/5.22.2/Pod/Coverage/CountParents.pm
/usr/lib/perl5/vendor_perl/5.22.2/Pod/Coverage/ExportOnly.pm
/usr/lib/perl5/vendor_perl/5.22.2/Pod/Coverage/Overloader.pm
/usr/share/doc/perl-Pod-Coverage/Changes
/usr/share/doc/perl-Pod-Coverage/META.yml
/usr/share/doc/perl-Pod-Coverage/MYMETA.yml
/usr/share/doc/perl-Pod-Coverage/examples/check_installed
/usr/share/doc/perl-Pod-Coverage/examples/script-covered
/usr/share/man/man3/Pod::Coverage.3pm.xz
/usr/share/man/man3/Pod::Coverage::CountParents.3pm.xz
/usr/share/man/man3/Pod::Coverage::ExportOnly.3pm.xz
/usr/share/man/man3/Pod::Coverage::Overloader.3pm.xz

Changelog

2016-06-19 - pterjan <pterjan> 0.230.0-7.mga6
+ Revision: 1032258
- Rebuild for perl 5.22.2
2016-02-02 - umeabot <umeabot> 0.230.0-6.mga6
+ Revision: 932439
- Mageia 6 Mass Rebuild
2014-10-15 - umeabot <umeabot> 0.230.0-5.mga5
+ Revision: 747846
- Second Mageia 5 Mass Rebuild
2014-09-30 - tv <tv> 0.230.0-4.mga5
+ Revision: 733265
- add exclude
2014-09-16 - umeabot <umeabot> 0.230.0-3.mga5
+ Revision: 685995
- Mageia 5 Mass Rebuild
2013-10-19 - umeabot <umeabot> 0.230.0-2.mga4
+ Revision: 527243
- Mageia 4 Mass Rebuild

See Also

Package Description
perl-Pod-Coverage-Moose-0.70.0-3.mga6.noarch.rpm L<Pod::Coverage> extension for L<Moose>
perl-Pod-Coverage-TrustPod-0.100.5-1.mga7.noarch.rpm Allow a module's pod to contain Pod::Coverage hints
perl-Pod-Cpandoc-0.160.0-1.mga7.noarch.rpm Perldoc that works for modules you don't have installed
perl-Pod-Elemental-0.103.4-3.mga6.noarch.rpm A Pod =command element
perl-Pod-Elemental-MakeSelector-0.120.0-2.mga6.noarch.rpm Build complex selectors as a single sub
perl-Pod-Elemental-PerlMunger-0.200.6-1.mga6.noarch.rpm A thing that takes a string of Perl and rewrites its documentation
perl-Pod-Elemental-Transformer-List-0.102.0-6.mga6.noarch.rpm Transform :list regions into =over/=back to save typing
perl-Pod-Elemental-Transformer-Verbatim-0.1.0-2.mga6.noarch.rpm Transform :verbatim regions into verbatim paragraphs
perl-Pod-Elemental-Transformer-WikiDoc-0.93.4-3.mga6.noarch.rpm A transformer to replace "wikidoc" data regions with Pod5 elements
perl-Pod-Escapes-1.70.0-3.mga6.noarch.rpm Perl module to resolve Pod E<...> sequences
perl-Pod-Eventual-0.94.1-7.mga6.noarch.rpm Just get an array of the stuff Pod::Eventual finds
perl-Pod-Generated-0.50.0-8.mga6.noarch.rpm Template plugin to help generate POD
perl-Pod-HTML2Pod-4.50.0-6.mga6.noarch.rpm Translate HTML into POD
perl-Pod-HtmlEasy-1.1.11-5.mga6.noarch.rpm Generate personalized HTML from PODs
perl-Pod-LaTeX-0.610.0-12.mga6.noarch.rpm Converts pod to latex with Pod::Parser
Advertisement
Advertisement